Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Creating Category With Api: No Image Created Rate Topic   - - - - -

 
  • gorka
  • Newbie
  • Members
  • Join Date: 28-Apr 14
  • 3 posts

Posted 08 May 2014 - 11:38 AM #1

Hi,

Using CS-cart 4.1.2

I'm trying to create a new category with an image with this data:

Array
(
	[category] => mycategory
	[company_id] => 1
	[status] => A
	[description] => <h2 class="text-primary">  This a description. </h2>
	[main_pair] => Array
		(
			[detailed] => Array
				(
					[image_path] => http://img.eltipografo.cl/media/2013/09/chrome-google.png
				)
		)	[meta_description] => This is the Meta Description
	[page_title] => This is the title
	[parent_id] => 1
)

When I check the new category on the administration panel, everything it's ok but the image, wich has not been created :(

I Also tried this solutions withput success:

[...]

[main_pair] => Array
		(
			[detailed] => Array
				(
					[http_image_path] => http://img.eltipografo.cl/media/2013/09/chrome-google.png
					[image_path] => http://img.eltipografo.cl/media/2013/09/chrome-google.png
				)

		)

[...]

And:


[...]

[main_pair] => Array
		(
			[http_image_path] => http://img.eltipografo.cl/media/2013/09/chrome-google.png
			[image_path] => http://img.eltipografo.cl/media/2013/09/chrome-google.png
		)

[...]


I tried this solution but didn't work: http://forum.cs-cart...post__p__166923

Any ideas?

Thnx,

Gorka.

 
  • gorka
  • Newbie
  • Members
  • Join Date: 28-Apr 14
  • 3 posts

Posted 09 May 2014 - 10:05 AM #2

Hi,

After looking on Core code, I realize Categories doesn't have an implemented behaviour to manage images (main_pair) as Products have.

Are you guys planning to perform it or is there a known an "easy" way to hardcode it?

Thnx in advance for your answer,

Gorka.