Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

CS-Cart & Multi-Vendor 4.0.3: Category Images, New Preset, and More Rate Topic   - - - - -

 
  • snorocket
  • Forum Janitor
  • Members
  • Join Date: 15-Mar 06
  • 2519 posts

Posted 08 November 2013 - 06:56 AM #21

I decided to give the upgrade a test run from 2.2.4 to 4.0.3 with the store import tool. The upgrade conflicted with one of my custom addons but once I removed my custom addon it went smoothly and only took a few minutes. I'm still not sure why it conflicted with only 1 addon and left the other 25+ alone, regardless the upgrade worked smoothly. Only complaint i would have is that the company name, address ect... should have been transferred into the new store - Sno
SNOROCKET.COM, Now Accepting PRE-ORDERS:
Customer Service (Helpdesk) Addon for CS-Cart v4.3.1
Quote and Invoicing Addon for CS-Cart v4.3.1

 
  • imac
  • Head of Product
  • CS-Cart Architects
  • Join Date: 22-Nov 05
  • 2074 posts

Posted 08 November 2013 - 07:14 AM #22

Hi i am running cs 4.0.2 and dont want to update the store that is live.

Can i simply import the database from 4.0.2 in to 4.0.3 then set it up and move it when it is ready?


It's not quite clear to me why you want to upgrade the database without upgrading the files. What is the point?

To get version 4.0.3 you need to upgrade both database and files - that is what the upgrade process does. There is no option to upgrade only database because it is useless since a 4.0.3 database can fail to work properly with 4.0.2 files.

Please note that not all the files will be overwritten during the upgrade. Only those that were changed during 4.0.2 -> 4.0.3 development. And in the Upgrade Center you will see the files to be overwritten.

Feel free to contact our tech support and they will upgrade your store.
Ilya Makarov,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug

 
  • imac
  • Head of Product
  • CS-Cart Architects
  • Join Date: 22-Nov 05
  • 2074 posts

Posted 08 November 2013 - 07:17 AM #23

I decided to give the upgrade a test run from 2.2.4 to 4.0.3 with the store import tool and if you have custom addons instead of ignoring and bypassing them it just hangs because it does'nt know what to do then just errors out shutting down the upgrade process.


Deart Snorocket,

The Store Import should not fail on third party add-ons. It is just moves the db tables without any changes to v4.0.3
Please take see the log file for details.
Ilya Makarov,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug

 
  • Traveler
  • Senior Member
  • Members
  • Join Date: 02-Feb 07
  • 902 posts

Posted 08 November 2013 - 11:28 AM #24

I have the upgrade files but a message that my subscription has expired - but I have a lifetime subscription.

Is this just me or do others have this problem?

I have submitted a support ticket - hopefully they will quickly take care of this and not wait till next week.

Version 4.9.2


 

Posted 08 November 2013 - 11:35 AM #25

Hi again I did update manually and seems bug with eu cookies warning script is repaired :-)

 
  • BaDTaG
  • Senior Member
  • Members
  • Join Date: 01-Jul 11
  • 188 posts

Posted 08 November 2013 - 12:14 PM #26

It's not quite clear to me why you want to upgrade the database without upgrading the files. What is the point?

To get version 4.0.3 you need to upgrade both database and files - that is what the upgrade process does. There is no option to upgrade only database because it is useless since a 4.0.3 database can fail to work properly with 4.0.2 files.

Please note that not all the files will be overwritten during the upgrade. Only those that were changed during 4.0.2 -> 4.0.3 development. And in the Upgrade Center you will see the files to be overwritten.

Feel free to contact our tech support and they will upgrade your store.


Hi i wanted to test the version 4.0.3 befor acualy doing the upgrade. but long story short i am now on 4.0.3 just instaled it in sub folder copyd database via cs-cart and imported it in 4.0.3 dit some twweeking and it runs. i have testet all i needed to test and now i have moved it to the front.

but i dit encounter one unrelated problem. i created a new block location with a iframe in it.i deleted the block and the iframe had jumpd to a difrent block (copyright block) so i had to delete that block (there was no sign of the iframe wen looking at the block) and create a new block.
VPS Hosting whit easy VPS control panel no technical skills required.
EDB Eksperten din online it forhandler

 
  • Traveler
  • Senior Member
  • Members
  • Join Date: 02-Feb 07
  • 902 posts

Posted 09 November 2013 - 06:57 AM #27

Dobreo Utero Imac,

Is there anyway you can get simple problems such as my above post fixed faster?

Amazingly someone on your staff replied that it would take a minimum of 2 to 3 business days (which when you include this weekend sounds like around one week or more...) to fix a simple CS Cart error which is related to a 4.03 upgrade which is why I post here.

I say amazingly as in the time it took them to answer my support request they could have checked my license and seen that I have a lifetime free upgrade. Then in about two minutes total time removed the upgrade freeze.

This has happened before in different variations and been posted as a bug report. CS cart said there would not be similar problems in future versions - yet you still have similar problems.

As others have said you need to focus on fixing basic problems before creating beautiful upgraded versions.

Looking forward to a prompt response from you or someone else on your team.

Spasibo.

Version 4.9.2


 
  • Pbraz
  • Advanced Member
  • Members
  • Join Date: 26-Aug 12
  • 105 posts

Posted 11 November 2013 - 10:00 AM #28

Relocated to another topic.
Paul
www.gohorse.com.au
Horse Rugs Store

 
  • gasngrills
  • Senior Member
  • Members
  • Join Date: 23-Feb 08
  • 247 posts

Posted 11 November 2013 - 05:09 PM #29

I'd recommend you upgrade to 4.0.3 after all the changes are applied to v4.0.2 so there won't be a need to actualize data in v4.0.3. It is not recommended to make store improt in v4.0.2, than upgrade to v4.0.3 and than make an actualization.

Or the best solution is to install v4.0.3 and make a clear store import - that's the safest way.


I wish I knew that before I upgraded my 4.0.2 which was still at Actualize data, but with the help of one of the users on this Forum I was able to Actualize the data into 4.0.3 and I'm still there, I will be finishing everything and going live with it.

CS-Cart 4.9.1


 
  • Traveler
  • Senior Member
  • Members
  • Join Date: 02-Feb 07
  • 902 posts

Posted 12 November 2013 - 04:48 AM #30

After cutting and pasting my license several times I got the file upgrades without a subscription error message - so far so good.

Now when I try to upgrade to 4.03 I get a series of error messages like the below (note I was not able to copy the complete message - my apologies...

Any ideas what I should do?

Error Occured db_data.sql Table ,name_cscart.cscart_settings_objects' doesn't exist (1146)
Insert into settings_vendor_values_upg SELECT CS CART settings_objects.object_id, company_id,

Error Occured db_data.sql Table ,name_cscart.cscart_settings_objects' doesn't exist (1146)
Delete from settings vendor_values_where object _id IN ( SELECT object_id FROM cscart_settings

Version 4.9.2


 
  • Traveler
  • Senior Member
  • Members
  • Join Date: 02-Feb 07
  • 902 posts

Posted 13 November 2013 - 11:21 AM #31

Confirmed by support the error messages are a bug which they are now working on to fix.

Also it seems like there is a backup problem:

Warning: strpos() [function.strpos]: Empty needle in
/home/name/public_html/var/cache/templates/design/backend/templates/58067f99f84164a5f96a8c78be0fab40ef8e727d.tygh.manage.tpl.php
on line 68

Version 4.9.2


 
  • andemh
  • Member
  • Members
  • Join Date: 26-Apr 13
  • 19 posts

Posted 15 November 2013 - 12:37 AM #32

Please we wait for Version 4.0.4
I sent you to programming errors in Version 4.0.3