Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

CS-Cart runnning on PHP 5.4 Rate Topic   - - - - -

 

Posted 08 August 2013 - 05:03 PM #1

Hi, my hosting provider just upgraded their PHP to 5.4, and now I see this:

"PHP version from 5.1.0 to 5.3.x is required. PHP 5.4.x and later are not supported. Your PHP is version 5.4.17, please ask your host to install a supported version."

How can make my version run 5.4? The shop is live, so any quick help or fix, would be very appreciated!

Jesper.

 
  • cscartrocks
  • Member
  • Members
  • Join Date: 24-Jan 11
  • 1838 posts

Posted 08 August 2013 - 05:12 PM #2

Contact your host to switch back to PHP 5.1.0-5.3.x. They should support it.

One Step Checkout Addon - The ultimate checkout experience
Best CS-Cart SEO addon - CS-Cart SEO Ultimate Addon
PM for 365-day support and custom development service


 

Posted 08 August 2013 - 06:30 PM #3

Hi cscartrocks.

I've just contacted them, and they are not able to switch the version back for my server.
Apparently, changing back the version, was to risky for the security.

 
  • P-Pharma
  • Junior Member
  • Members
  • Join Date: 30-Jun 10
  • 1139 posts

Posted 08 August 2013 - 06:43 PM #4

The last version of PHP 5.3 was released last month. It's EOL now but its still considered safe for now.
If your host persists that they can not downgrade your server then you have a real problem. Your only option will be to wait for the CS-Cart 4 migration tool and upgrade to CSC4 when its available. Until then you will be stuck.
Meanwhile PHP5.5 is already out.

 
  • cscartrocks
  • Member
  • Members
  • Join Date: 24-Jan 11
  • 1838 posts

Posted 08 August 2013 - 06:46 PM #5

Or move away from this hosting.

One Step Checkout Addon - The ultimate checkout experience
Best CS-Cart SEO addon - CS-Cart SEO Ultimate Addon
PM for 365-day support and custom development service


 

Posted 08 August 2013 - 08:10 PM #6

Sorry for my frustration, but how come CS-Cart is so late with this PHP version upgrade for their system? Moving the site is a pain, but i guess necessary.
Well, there goes my weekend :(
Thanks for your clarification, guys!

 
  • cscartrocks
  • Member
  • Members
  • Join Date: 24-Jan 11
  • 1838 posts

Posted 08 August 2013 - 08:26 PM #7

I think your current hosting is not quite customer-friendly. Even Magento doesn't officially support PHP 5.4.

One Step Checkout Addon - The ultimate checkout experience
Best CS-Cart SEO addon - CS-Cart SEO Ultimate Addon
PM for 365-day support and custom development service


 

Posted 08 August 2013 - 08:41 PM #8

This is really frustrating me. I've changed to another host where they support 5.2, 5.3 and 5.4 - how come it is so hard for the old one to do the same? It could save me A LOT of time and crappy work :(

 
  • P-Pharma
  • Junior Member
  • Members
  • Join Date: 30-Jun 10
  • 1139 posts

Posted 09 August 2013 - 01:59 AM #9

With PHP 5.3 being EOL its possible that a major vulnerability becomes known and it does not get patched. This is unlikely to happen soon, but its possible. My server was updated to PHP 5.4 last year. I have rented a VDS until a php 5.4 compatible version of CSCart can be migrated to. It has taken very long and we are still not there. But at least it should not be long now.