Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

CS-Cart v4 Instillation Question Rate Topic   - - - - -

 
  • Galactica
  • Advanced Member
  • Members
  • Join Date: 20-Jun 13
  • 50 posts

Posted 27 June 2013 - 04:46 PM #1

Hello All,

I am trying to install v4 of of CS-Cart on a new Hostgator VPS (New Store) and I am confused by the section of the instillation guide ( https://www.cs-cart....stallation.html ) dealing with permissions. Below is what is confusing me and my comments are in red.

---------------------

Change the original file permissions as advised below.

chmod 666 config.local.php -- Changed this on the server to 666

chmod -R 777 design images var -- There is no directory path design > images > var. I thought maybe it might mean change the design, images and var directories in the root to 777, but the next 3 steps below change those three to 666. So what should they be?

find design -type f -print0 | xargs -0 chmod 666 -- Please see comment above...

find images -type f -print0 | xargs -0 chmod 666 -- Please see comment above...

find var -type f -print0 | xargs -0 chmod 666 -- Please see comment above...

chmod 644 design/.htaccess images/.htaccess var/.htaccess var/themes_repository/.htaccess -- None of these .htaccess files exist in the v.4 download. I have turned on hidden files through cPanels file manager and still don't see these files... I have even downloaded the v4 zip from the files area twice to make sure I didn't have a corrupted version.

chmod 644 design/index.php images/index.php var/index.php var/themes_repository/index.php

---------------------

Any help clearing this up would be greatly appreciated!

Thanks,
Paul

 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 4006 posts

Posted 27 June 2013 - 06:40 PM #2

chmod 777 (folders):
  • /design
  • /images
  • /var
chmod 666 (all files):
  • /design/
  • /images/
  • /var/
chmod 644 (I am able to see these files):
  • /design/.htaccess
  • /images/.htaccess
  • /var/.htaccess
  • /var/themes_repository/.htaccess


 
  • Galactica
  • Advanced Member
  • Members
  • Join Date: 20-Jun 13
  • 50 posts

Posted 27 June 2013 - 11:27 PM #3

Thank you for the quick reply, that cleared things up for me... For some reason my mac had the .htaccess files hidden and as a dubble whammy my FTP client skipped over the htaccess files when I pushed the files to the site...

Once I realized that it was much smoother sailing...

Thanks again for the help!

Paul

 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 4006 posts

Posted 28 June 2013 - 02:42 AM #4

Just a tip for next time or anyone else...upload the .tgz or .zip file to your server then extract from there.

 

Posted 30 June 2013 - 11:50 AM #5

I'm glad that worked for you Galactica. I can't get the install to move from the first server and admin info screen. Uploaded the .zip and extracted on the server. Adjusted the permissions as per the remarks here but nothing. It's a new install on a clean, Martfox semi-VPS.

Not quite sure what to do next, really.

Wil

 
  • Galactica
  • Advanced Member
  • Members
  • Join Date: 20-Jun 13
  • 50 posts

Posted 01 July 2013 - 12:19 AM #6

I'm glad that worked for you Galactica. I can't get the install to move from the first server and admin info screen. Uploaded the .zip and extracted on the server. Adjusted the permissions as per the remarks here but nothing. It's a new install on a clean, Martfox semi-VPS.

Not quite sure what to do next, really.

Wil


I had to FTP mine up to our VPS... Did you set the permissions manually or run the script in the install docs? I ran the script and it seemed to work fine...

I am no CS-Cart expert ( new user) but I would double check all of the server settings and what not before trying again.

Hope that helps,
Paul

 

Posted 01 July 2013 - 07:52 PM #7

Everything's OK now. Had to set certain permissions for all folders (thank goodness for cpanel have a recursive function or I'd have been there all night). In the end I had missed database permissions which I guess is a schoolboy error. Still, we live and learn. I'm certainly no expert.

Thanks for the reply.

Wil