Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Google not indexing product pages Rate Topic   - - - - -

 
  • jain1980
  • Senior Member
  • Members
  • Join Date: 16-Dec 08
  • 306 posts

Posted 18 February 2013 - 06:37 AM #1

Google is not indexing our product pages and is indexing only the Home page, cateogries, multiple listing pages like 96 Per page, 48 per page, 12 per page etc multiple times.

Any suggestions on what could be wrong and how to fix this?

 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3809 posts

Posted 18 February 2013 - 11:44 AM #2

Hello jain1980,

Thank you for your message.

The problem requires the examination on your server. Please contact us via Customer Help Desk and provide temporary access to your server by clicking on the Add record link on the Access information page of your Help Desk account so that we could examine the issue.

Thank you.

---
Pavel Zyukin
CS-Cart Support team

Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • JGift
  • Member
  • Members
  • Join Date: 22-Jan 11
  • 97 posts

Posted 18 February 2013 - 08:31 PM #3

I am also interested in this fix and would like to know if its in the product......

 
  • StellarBytes
  • Senior Member
  • Members
  • Join Date: 08-Aug 11
  • 1807 posts

Posted 18 February 2013 - 08:53 PM #4

Simple thing to check...

Right-click on your product page > View Source

Ctrl+F (Find): noindex

If 'noindex' exists in the page, that's your problem, you're telling search engines not to index your product pages.
Hire StellarBytes for CS-Cart Design & Development Services

 
  • jain1980
  • Senior Member
  • Members
  • Join Date: 16-Dec 08
  • 306 posts

Posted 19 February 2013 - 05:27 AM #5

Simple thing to check...

Right-click on your product page > View Source

Ctrl+F (Find): noindex

If 'noindex' exists in the page, that's your problem, you're telling search engines not to index your product pages.


StellarBytes, You were absolutely spot on. I see this code on top of the page although I am not aware how has this code crept in. <meta name="noindex,nofollow" />

Any ideas to solve this?

My robot.txt files reads like this. I hope its correct.

User-agent: *
Disallow: /images/thumbnails/
Disallow: /skins/
Disallow: /payments/
Disallow: /store_closed.html
Disallow: /core/
Disallow: /lib/
Disallow: /install/
Disallow: /js/
Disallow: /schemas/

 
  • StellarBytes
  • Senior Member
  • Members
  • Join Date: 08-Aug 11
  • 1807 posts

Posted 19 February 2013 - 10:27 AM #6

It could be in a number of places:-

Loaded by a 3rd party addon

Or, commonly, in one of these files:

/skins/your_skin/customer/meta.tpl
/skins/your_skin/customer/common_templates/scripts.tpl
/skins/your_skin/customer/common_templates/styles.tpl
/skins/your_skin/customer/addons/my_changes/ <-- any X.post.tpl, X.pre.tpl, X.override.tpl inside any of the my_changes addons folders subfolders.

The 'Design Mode' should enable you to see which template files are being used and help track it down.
Hire StellarBytes for CS-Cart Design & Development Services

 
  • jain1980
  • Senior Member
  • Members
  • Join Date: 16-Dec 08
  • 306 posts

Posted 27 February 2013 - 04:45 PM #7

Fixed this. Disabled the SSL option in Admin "Keep HTTPS connection once a secure page is visited" and now all my product pages are being indexed properly. Thanks CS-cart support team for fixing this.

 

Posted 26 March 2013 - 02:58 PM #8

Fixed this. Disabled the SSL option in Admin "Keep HTTPS connection once a secure page is visited" and now all my product pages are being indexed properly. Thanks CS-cart support team for fixing this.


Thank you for the hint :)

 
  • alanpro
  • Senior Member
  • Members
  • Join Date: 25-May 08
  • 136 posts

Posted 12 April 2013 - 04:24 AM #9

Fixed this. Disabled the SSL option in Admin "Keep HTTPS connection once a secure page is visited" and now all my product pages are being indexed properly. Thanks CS-cart support team for fixing this.


Thanks for this tip. I found this problem in one of my client's site.
Web Hosting Deals
http://www.100webhosting.com

 

Posted 25 May 2013 - 06:18 AM #10

when i use site:babiken.com to search the google, i can not find any product pages of my website. that means my product pages are not indexed. right?

solution?
Fixed this. Disabled the SSL option in Admin "Keep HTTPS connection once a secure page is visited" and now all my product pages are being indexed properly. Thanks CS-cart support team for fixing this.

but i can not find where to change "Keep HTTPS connection once a secure page is visited" in the admin?

please help.

thank you very much in advance.

 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3871 posts

Posted 25 May 2013 - 06:23 AM #11

http://demo.cs-cart....tion_id=General

 

Posted 25 May 2013 - 06:46 AM #12

http://demo.cs-cart....tion_id=General


thank you firstly the fast reply.
so that means i should tick "Keep HTTPS connection once a secure page is visited:" and everything should be ok?

 
  • jhagg
  • Senior Member
  • Members
  • Join Date: 27-Mar 11
  • 233 posts

Posted 25 May 2013 - 08:58 AM #13

thank you firstly the fast reply.
so that means i should tick "Keep HTTPS connection once a secure page is visited:" and everything should be ok?


Uncheck it

 

Posted 25 May 2013 - 10:54 AM #14

Uncheck it


thank you

 
  • Don
  • Newbie
  • Trial users
  • Join Date: 20-May 13
  • 7 posts

Posted 05 June 2013 - 12:53 PM #15

Delete robot.txt in root directory , the robot.txt prevent SEO