Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

IE9 won't add to shopping cart Rate Topic   - - - - -

 
  • selectcase
  • Advanced Member
  • Trial users
  • Join Date: 26-Jan 13
  • 61 posts

Posted 15 February 2013 - 12:10 AM #1

I am still building my site and testing cs cart before purchase and tonight i noticed that everything is fine when using chrome but if i use internet explorer and add a product to the cart it shows it as added but when i click checkout it is empty!

i have no add-ons installed - i did have one eu cookie add-on from cs cart rocks but i have completely removed it so i don't think it was that.

The only other mods i have done are the "displaying multiple category images" from the knowledge base and adding the modified config.local.php file and htaccess file from stellarbytes excellent post on speeding up cs cart ver 3 (i could not get smartoptimizer to work yet)

i am using the latest version downloaded around 10 days ago

anyone know what this could be?

thanks

will

 
  • selectcase
  • Advanced Member
  • Trial users
  • Join Date: 26-Jan 13
  • 61 posts

Posted 15 February 2013 - 12:25 AM #2

just to update I have also reset all of the mods from the speed up cs cart post in the htaccess etc and set back to normal and there is still no change?

 
  • Struck
  • Teetering on Genious
  • Members
  • Join Date: 07-Mar 09
  • 2502 posts

Posted 15 February 2013 - 12:37 AM #3

Try clearing the files within your smartoptimizer cache folder.
Cooking with Gas on Version 4.1.2 (But proceeding with caution....)

 
  • selectcase
  • Advanced Member
  • Trial users
  • Join Date: 26-Jan 13
  • 61 posts

Posted 15 February 2013 - 07:23 AM #4

I dont have smartoptimizer installed but thanks anyway

 
  • StellarBytes
  • Senior Member
  • Members
  • Join Date: 08-Aug 11
  • 1807 posts

Posted 15 February 2013 - 11:21 AM #5

I don't think the .htaccess will have made any difference, are you using 'Compatability Mode' in IE9? If so, disable it and see if the problem still exists. Compatibility Mode is enabled when you see a little blue icon at the right-side of the URL in the bar at the top of IE9.

Since you couldn't get SmartOptimizer to work, you should remove this part of the .htaccess:

<IfModule mod_rewrite.c>
RewriteEngine On

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*\.(js|css))$ smartoptimizer/?$1

<IfModule mod_expires.c>
  RewriteCond %{REQUEST_FILENAME} -f
  RewriteRule ^(.*\.(js|css|html?|xml|txt))$ smartoptimizer/?$1
</IfModule>
<IfModule !mod_expires.c>
  RewriteCond %{REQUEST_FILENAME} -f
  RewriteRule ^(.*\.(gif|jpg|jpeg|png|swf|css|js|html?|xml|txt|ico))$ smartoptimizer/?$1
</IfModule>
</IfModule>

Hire StellarBytes for CS-Cart Design & Development Services

 
  • selectcase
  • Advanced Member
  • Trial users
  • Join Date: 26-Jan 13
  • 61 posts

Posted 15 February 2013 - 05:52 PM #6

Thanks Stellar

I had re-set everything back to normal and it was still no better so i will restore my changes tonight - it appears to be a bug becuase the online demo store is exactly the same so i think i may as well purchase my copy now and get a member of support to investigate it

thanks

will

 
  • selectcase
  • Advanced Member
  • Trial users
  • Join Date: 26-Jan 13
  • 61 posts

Posted 15 February 2013 - 09:09 PM #7

I think I have found the problem - the add to cart was not working for any cs cart site i tried so i then knew it must be a problem with my IE9 setup at home. I am running windows 7 64bit with 32bit IE with norton internet security - if i run IE9 64 bit without norton it works fine so i think its a conflict with norton internet security