Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Secure connection keeps dropping Rate Topic   - - - - -

 
  • Anil
  • Junior Member
  • Members
  • Join Date: 23-Jul 10
  • 30 posts

Posted 14 February 2013 - 12:36 AM #1

Hi,

My SSL just got renewed and my server people reinstalled it. After reinstalling, this problem started.

My secure connection keeps dropping. Sometimes its on and sometimes I get error on my firefox

Error code: ssl_error_rx_record_too_long

The worst thing is, I am not the only one who get this error, my customers are getting it, while they are checking out.

Right now the connection seems working but it may not stay on for long.

What I want to ask is, is this cs cart issue or server issue. Since the SSL worked great before renewal, I guess its server issue. But my server people are saying that its installed correctly, so I dont know!

Please help.

Cheers,

 
  • StellarBytes
  • Senior Member
  • Members
  • Join Date: 08-Aug 11
  • 1807 posts

Posted 14 February 2013 - 12:45 AM #2

See here - your server admins will be lucky and only need to either restart Apache, or the certificate itself isn't installed correctly and needs to be re-installed.

Not sure if it's the site in your forum signature or not, but I can access your Plant Biotech secure https:// without any errors, and the SSL reports as fully encrypted. Try clearing your web browser cache if the problematic site is the site in your signature.
Hire StellarBytes for CS-Cart Design & Development Services

 
  • Anil
  • Junior Member
  • Members
  • Join Date: 23-Jul 10
  • 30 posts

Posted 14 February 2013 - 04:10 AM #3

Thank yo so much StellarBytes. I have contacted my server people. I understand that sometimes you can connect to https pages on my website such as this one without any problmes but sometimes you cant. I cleared my cache and tried but still couldnt connect. Even my customers are saying that they cannot checkout.

I clicked on my GeoTrust seal on my store and certificate doesnt show Period of renewal.


I guess, I will just have to wait till my server guys restart apache and reinstall the certificate.

 
  • StellarBytes
  • Senior Member
  • Members
  • Join Date: 08-Aug 11
  • 1807 posts

Posted 14 February 2013 - 10:07 AM #4

It' showing the GeoTrust certificate is valid until 14/03/2015.
Hire StellarBytes for CS-Cart Design & Development Services

 
  • Anil
  • Junior Member
  • Members
  • Join Date: 23-Jul 10
  • 30 posts

Posted 15 February 2013 - 06:32 AM #5

Thats right. Even I observed that sometimes it shows up and sometime it doesnt. Even if the certificate shows up the period, if I click on the 'Sign-in' link on my store which is a secure page, it doesnt load and displays message that - Secure Connection Failed !

 
  • StellarBytes
  • Senior Member
  • Members
  • Join Date: 08-Aug 11
  • 1807 posts

Posted 15 February 2013 - 11:24 AM #6

Unless your server folks have fixed this issue, I'm still not having any problems navigating between http and https on your site.
Hire StellarBytes for CS-Cart Design & Development Services