Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Error Ult. v3.0.3 to v3.0.4: shops stopped working, free products! Rate Topic   - - - - -

 
  • Janssen
  • Advanced Member
  • Trial users
  • Join Date: 18-Jul 12
  • 83 posts

Posted 15 November 2012 - 06:43 AM #1

After looking at a message on my admin dashboard for over a week that an update is available, I yesterday installed the update.

First everything worked fine, collected a few orders on one shop, but then I received orders where all bought products were priced Zero. So you could shop for free in my store.
Prices were displayed correctly, but when added to the basket, the products were free.

Further investigation led to the fact that all stores (at the moment I have three) had the price set to Zero for all products added to the basket.

I made a backup before I began, so I downgraded to v3.0.3 again.

This sucks, because now I have all the errors of v3.0.3 again.

Regards,
JJ

 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3808 posts

Posted 15 November 2012 - 01:02 PM #2

Hello Janssen,

Thank you for your message.

I am sorry to hear that you have experienced this problem. It requires the examination on your server. Please contact us via Customer Help Desk and provide temporary access to your server by clicking on the Add record link on the Access information page of your Help Desk account so that we could examine the issue.

Thank you.

---
Pavel Zyukin
CS-Cart Support team

Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • Janssen
  • Advanced Member
  • Trial users
  • Join Date: 18-Jul 12
  • 83 posts

Posted 16 November 2012 - 04:10 PM #3

At this point there is not much to investigate as I downgraded everything.

 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3808 posts

Posted 19 November 2012 - 11:12 AM #4

Hello Janssen,

Thank you for the reply.

Sure, I understand that. The way in which we are going to examine the issue is the following: our technical support engineer will upgrade your store once again and examine the issue in detail, after this he/she will provide you with a fix to this problem. If this method suits you, please feel free contact us via Customer Help Desk. Unfortunately, there is no other way for us to find out the exact reason for this problem.

Thank you.

---
Pavel Zyukin
CS-Cart Support team

Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 

Posted 19 November 2012 - 12:15 PM #5

Make sure you delete ALL promotions before OR after upgrading.
Some logic does change between versions and I've noticed this issue reoccuring in 2.0,2.1 and 2.2 releases. I can't see why 3.0.x would be any different.
I've moved on from CS-Cart to WooC******** - If you need anything I can be of little help.