Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Upgrade from 2.1.3 to 2.1.4 Professional possible issues? Rate Topic   - - - - -

 
  • BlackFlag
  • Member
  • Members
  • Join Date: 08-Nov 12
  • 29 posts

Posted 08 November 2012 - 04:05 PM #1

I want to upgrade from 2.1.3 to 2.1.4 version and I want to know which issues will occur after the upgrade of the application? My administrator panel will be messed up?

 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3808 posts

Posted 16 November 2012 - 11:06 AM #2

Hello BlackFlag,

Thank you for your message.

There should not be any problems if you upgrade your store to version 2.1.4. If your CS-Cart admin panel CSS styles are messed up after upgrading the store, you can try clearing the template cache (you can find instructions on how to clear it here: http://kb.cs-cart.co...s-not-displayed) and clearing the browser cache (press CTRL+F5 and then CTRL+R key combinations). Generally it helps when such an issue occurs.

However I still cannot guarantee that no other problems will occur after upgrading the store, it depends on how you customized templates or PHP scripts of your CS-Cart installation (if there are any customizations). Also it depends on your server (its settings, limitations, etc.). So you should better create a copy of your CS-Cart store in some other directory on your server (you can use these instructions: http://kb.cs-cart.co...other-directory ) and perform the upgrade there. If everything is okay after this, you can upgrade your live store.

If you experience any problems after upgrading the store, please do not hesitate to contact us via Customer Help Desk and provide temporary access to your server by clicking on the Add record link on the Access information page of your Help Desk account so that we could examine the issue. Our technical support engineers will be glad to assist you. But I hope that you will upgrade your store smoothly and without any issues.

Thank you.

---
Pavel Zyukin
CS-Cart Support team

Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • johnbol1
  • Never Re
  • Members
  • Join Date: 23-Feb 10
  • 4551 posts

Posted 16 November 2012 - 12:12 PM #3

I went from 2.13 to 2.14 and all was good, all addons worked ok. just back everything up first if you are heavily customised.

John

Custom printed hi visibility clothing sale the UK's online hivis safety shop
v4.5.2


 
  • BlackFlag
  • Member
  • Members
  • Join Date: 08-Nov 12
  • 29 posts

Posted 16 November 2012 - 12:44 PM #4

Thanks for answering to me. Also I want to know if I will extend my license for the upcoming year, and then if I will make the upgrade version to version to reach the 2.2.5 I will able to do it without issues? Especially I'm worried with the skin and the templates and possible issues and incompatibilities after an upgrade procedure! I want to know it, because it's vital to me to upgrade to a 2.x.x version to use some add-ons which aren't supported by my version.

 
  • johnbol1
  • Never Re
  • Members
  • Join Date: 23-Feb 10
  • 4551 posts

Posted 16 November 2012 - 12:51 PM #5

Thanks for answering to me. Also I want to know if I will extend my license for the upcoming year, and then if I will make the upgrade version to version to reach the 2.2.5 I will able to do it without issues? Especially I'm worried with the skin and the templates and possible issues and incompatibilities after an upgrade procedure! I want to know it, because it's vital to me to upgrade to a 2.x.x version to use some add-ons which aren't supported by my version.


All depends how much you have changed your store, I went from 2.1.2 through to 2.24 without too much trouble.
Install a test site and upgrade that first if you have any concerns, or like i said before do a full backup of database and all files folders, that way if anything serious was to happen just put it all back

John

Custom printed hi visibility clothing sale the UK's online hivis safety shop
v4.5.2


 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11302 posts

Posted 17 November 2012 - 06:29 AM #6

Best approach is to copy the store and do the upgrades on the copy.
Save any file you have to modify locally on your PC.
Once you're all upgraded, go do the same thing on your live store (backing it up first).
After the upgrade is done, just write out the locally modified files and you should be good to go.

EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • BlackFlag
  • Member
  • Members
  • Join Date: 08-Nov 12
  • 29 posts

Posted 17 November 2012 - 08:24 AM #7

I'm trying to run my website through wamp but every time it says to me that an "error occurred".

 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11302 posts

Posted 17 November 2012 - 08:13 PM #8

Put your store in development mode and you will see the exact database error you are encountering.

EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • BlackFlag
  • Member
  • Members
  • Join Date: 08-Nov 12
  • 29 posts

Posted 18 November 2012 - 07:30 PM #9

I can't even enter to admin mode.

 
  • brandonvd
  • is Super Awesome
  • Members
  • Join Date: 19-Dec 06
  • 2632 posts

Posted 18 November 2012 - 09:22 PM #10

Try doing what is on the second post of http://forum.cs-cart...-error-occured/ Then you can see what the errors are without going into the admin.

Thanks,

Brandon