Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Options error Rate Topic   - - - - -

 
  • jeffshead
  • Member
  • Members
  • Join Date: 15-May 08
  • 121 posts

Posted 03 October 2012 - 10:10 PM #1

Can someone tell me what this error means and how I can fix it?

I just tried to add an option to a product and this error popped up on the screen:

...
Database error: Duplicate entry '1-EN' for key 'PRIMARY' (1062)
Invalid query: INSERT INTO cscart_product_options_descriptions (`option_name`, `description`, `comment`, `inner_hint`, `incorrect_message`, `option_id`, `lang_code`) VALUES ('Installation Service', '
Have us install this mod for you.
', '', '', '', '1', 'EN')

Backtrace:
File: C:\WampDeveloper\Websites\www.mysite.com\webroot\core\fn.database.php Line: 267 Function: db_error File: C:\WampDeveloper\Websites\www.mysite.com\webroot\core\fn.catalog.php Line: 6755 Function: db_query File: C:\WampDeveloper\Websites\www.mysite.com\webroot\controllers\admin\product_options.php Line: 162 Function: fn_update_product_option File: C:\WampDeveloper\Websites\www.mysite.com\webroot\core\fn.control.php Line: 638 Function: include File: C:\WampDeveloper\Websites\www.mysite.com\webroot\core\fn.control.php Line: 458 Function: fn_run_controller File: C:\WampDeveloper\Websites\www.mysite.com\webroot\_admin_.php Line: 24 Function: fn_dispatch
...
CS-Cart 4.6.3 SP1

 
  • jeffshead
  • Member
  • Members
  • Join Date: 15-May 08
  • 121 posts

Posted 03 October 2012 - 10:34 PM #2

There were a bunch of options already in the database. I really don't know how they got there. I've never added an option nor did I have the demo database installed.

I just deleted all of the options and it now works.
CS-Cart 4.6.3 SP1

 
  • novista
  • Senior Member
  • Members
  • Join Date: 14-Jul 11
  • 199 posts

Posted 03 October 2012 - 10:59 PM #3

Check this carefully. I had a similar problem in my Ultimate store. The options came back. I eventually had to go into the tables and deleted them manually from several places.

 
  • jeffshead
  • Member
  • Members
  • Join Date: 15-May 08
  • 121 posts

Posted 08 October 2012 - 05:15 PM #4

Check this carefully. I had a similar problem in my Ultimate store. The options came back. I eventually had to go into the tables and deleted them manually from several places.

That's exactly what I did.

Thanks for the confirmation that I'm not the only one who has experienced this.
CS-Cart 4.6.3 SP1