Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Statistics addon - Country flags not showing up Rate Topic   * * * * * 1 votes

 
  • denisgomes
  • Advanced Member
  • Members
  • Join Date: 14-Mar 12
  • 80 posts

Posted 15 June 2012 - 02:23 PM #1

Anyone noticed that the country flags in the statistics plugin aren't showing up in the final version of CS-Cart 3?

As far as I can tell, CS-Cart has changed this to use CSS sprites (all the flags are now stored on a single file, /skins/basic/admin/images/flags.png). However, the Statistics addon is still referring to the individual flags, ie. /skins/basic/admin/images/flags/br.png. Since these files are not present in a clean install, they do not show up in the statistics screens.

This is not a critical issue of course, I just wanted to let you guys know about it.
Mugs, mouse pads and photo products personalized with your logos or photos
Check us out at http://www.produtosexclusivos.com.br

 
  • posto
  • Senior Member
  • Members
  • Join Date: 19-Sep 11
  • 160 posts

Posted 15 June 2012 - 02:40 PM #2

Jes you have right

you can replace the line 67 whit this code
In skins/basic/admin/addons/statistics/views/statistics/components/visitor.tpl
<td><i class="flag flag-{$visitor.country_code|default:"01"|lower}" alt="{$visitor.country}" title="{$visitor.country}" align="top" /></i>&nbsp;{if $visitor.country}{$visitor.country}{elseif $visitor.country_code}{$visitor.country_code}{else}{$lang.undefined}{/if}</td>

Templates for v3

**see Posto's Templates Tread**

 
  • denisgomes
  • Advanced Member
  • Members
  • Join Date: 14-Mar 12
  • 80 posts

Posted 15 June 2012 - 04:36 PM #3

It works (after a /admin.php?cc).

Thanks. And this should make it to the next release.
Mugs, mouse pads and photo products personalized with your logos or photos
Check us out at http://www.produtosexclusivos.com.br

 
  • Magpie Don
  • Senior Member
  • Members
  • Join Date: 01-Apr 09
  • 832 posts

Posted 22 July 2012 - 05:06 PM #4

If you have version 2, you can add the flags folder from v2 to your images folder in v3 and this will fix the problem. Looks like v3's build forgot to include the flags folder.

CS-Cart Ultimate ver 4.11.3


 
  • nassmall
  • Junior Member
  • Members
  • Join Date: 19-May 08
  • 18 posts

Posted 22 July 2012 - 11:08 PM #5

Thank you (Posto) I tried your changes, it works good,

 
  • sIiiS
  • Newbie
  • Trial users
  • Join Date: 06-Jul 12
  • 8 posts

Posted 04 August 2012 - 08:32 AM #6

Great posto,
it work for me too, nice solution :)