Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

error with image viewer while upgrade Rate Topic   - - - - -

 
  • elk
  • Member
  • Members
  • Join Date: 28-Jan 11
  • 92 posts

Posted 23 March 2012 - 05:41 PM #1

Hello
I upgrade from 2.1.3 to 2.2.4 . And i think when i upgrade from 2.1.3 to 2.1.4 the following error appear

The image gallery (the one with 3 thumbs) is over its box. See image to understand

i use electro skin. if i use basic skin it is ok. so the problem seems to be somewhere on skin/electro/customer/... and not at var/skin_reprository/... or other

i have combine all css to one big.css file and point there all files (from ver 2.1.2)
I have tried the following but nothing:
  • ../common_templates/styles.tpl set to original (so it does not use the big.css)
  • check cache to see if the problem is there but not
  • used all galleries prettyphoto,lightbox,fancybox.
  • select different product styles, and also set the olders files or files from basic skin (product styles="Default template" "Modern template" etc) My current product template is "Modern Template Long product options)
  • remove facebook like and google+ but nothing
  • check image.tpl and product_images.tpl for errors but nothing.
P.S.I always clear entire cache before i change something (?cc, clear smartoptimizer cache, erase var/cache&complied

I really need some help
Thanks in advance

Attached Thumbnails

  • error_with_previewer.jpg

Mylot.gr // Mobiles & Gadgets
CS-Cart 2.1.3 ver. working fine

 
  • brandonvd
  • is Super Awesome
  • Members
  • Join Date: 19-Dec 06
  • 2632 posts

Posted 23 March 2012 - 06:30 PM #2

First off, do you know that you are calling up the same style sheet like 10 times? Also, why are your style sheets being called from your body instead of your head?

To fix your problem though, you'd change your big-styles.css file

You currently have:

.jcarousel-prev-horizontal, .jcarousel-next-horizontal, .prev-horizontal, .next-horizontal {
  background: url("images/icons/prev_but.gif") no-repeat scroll 50% 50% #ECECEC;
  cursor: pointer;
  height: 38px;
  margin: 0 1px 0 0;
  width: 12px;
}

Just change it to:

.jcarousel-prev-horizontal, .jcarousel-next-horizontal, .prev-horizontal, .next-horizontal {
  background: url("images/icons/prev_but.gif") no-repeat scroll 50% 50% #ECECEC;
  cursor: pointer;
  height: 38px;
  margin: -38px 1px 0 0;
  width: 12px;
}

Basically I just gave it a -38px top margin.

Hope that helps,

Brandon

 
  • elk
  • Member
  • Members
  • Join Date: 28-Jan 11
  • 92 posts

Posted 23 March 2012 - 10:00 PM #3

thanks a lot brandonvd. once again you saved me.
i did change these two vars (next_but and prev_but) to -38px and it fixed.
But it is strange. because i didn't change anything to my big-styles.css while upgrade. so i should have worked. ...anyway. it works now

and about your notice. I see now (using powermapper.com) that all these strange thing in the top
<link href="/skins/electro/customer/images/icons/favicon.ico" rel="shortcut icon" />
<link href="/skins/electro/customer/css/ui/jqueryui.css" rel="stylesheet" type="text/css"/>
<link href="/skins/electro/customer/big-styles.css" rel="stylesheet" type="text/css" />
<!-- <link href="/skins/electro/customer/styles.css" rel="stylesheet" type="text/css" />
<link href="/skins/electro/customer/print.css" rel="stylesheet" media="print" type="text/css" /> -->
<link href="/skins/electro/customer/big-styles.css" rel="stylesheet" type="text/css" />
<!--<link href="/skins/electro/customer/dropdown.css" rel="stylesheet" type="text/css" />-->
<!--[if lte IE 7]>
<link href="/skins/electro/customer/styles_ie.css" rel="stylesheet" type="text/css" />
<![endif]-->
<link href="/skins/electro/customer/big-styles.css" rel="stylesheet" type="text/css" /><link href="/skins/electro/customer/big-styles.css" rel="stylesheet" type="text/css" /><link href="/skins/electro/customer/big-styles.css" rel="stylesheet" type="text/css" />
<!--[if lte IE 7]>
<link href="/skins/electro/customer/addons/buy_together/styles_ie.css" rel="stylesheet" type="text/css" />
<![endif]-->
<!--<link href="/skins/electro/customer/addons/tags/styles.css" rel="stylesheet" type="text/css" />-->
<link href="/skins/electro/customer/big-styles.css" rel="stylesheet" type="text/css" />
<!--<link href="/skins/electro/customer/addons/news_and_emails/styles.css" rel="stylesheet" type="text/css" />-->
<link href="/skins/electro/customer/big-styles.css" rel="stylesheet" type="text/css" />
<link href="/skins/electro/customer/big-styles.css" rel="stylesheet" type="text/css" />
<!--<link href="/skins/electro/customer/addons/discussion/styles.css" rel="stylesheet" type="text/css" />-->
<link href="/skins/electro/customer/big-styles.css" rel="stylesheet" type="text/css" />
<link href="/skins/electro/customer/big-styles.css" rel="stylesheet" type="text/css" />
<script type="text/javascript" src="/lib/js/jquery/jquery.min.js"></script>
<script type="text/javascript" src="/lib/js/jqueryui/jquery-ui.custom.min.js"></script>
<script type="text/javascript" src="/lib/js/tools/tooltip.min.js"></script>
<script type="text/javascript" src="/lib/js/appear/jquery.appear-1.1.1.js"></script>
<script type="text/javascript" src="/var/cache/js/editors/tinymce.editor.js"></script>
<script type="text/javascript" src="/var/cache/js/core.js"></script>
<script type="text/javascript" src="/var/cache/js/ajax.js"></script>
<script type="text/javascript">
//<![CDATA[
var index_script = 'index.php';
var current_path = '';
var changes_warning = 'Y';
var lang = {

i don't know why is. I was using gtmetrix.com and my site looked fine. never checked this. I'll try to fix it.
Maybe because i had (from ver 2.1.3) combined all css to one big-styles.css file.
and now the new ver uses "{join_css content=$smarty.capture.styles}" at common_templates/styles.tpl

any recommendation/help of where to look?

thanks again brandonvd
Mylot.gr // Mobiles & Gadgets
CS-Cart 2.1.3 ver. working fine

 
  • brandonvd
  • is Super Awesome
  • Members
  • Join Date: 19-Dec 06
  • 2632 posts

Posted 24 March 2012 - 03:24 AM #4

Honestly, I'm not sure. I don't know exactly what you did, so it is kind of hard to say. I keep all of my styles separated by using hooks, so what you did is definitely different than what I'm used to.

I'd try and separate out your custom styles and learning hooks and going that route. It would take some work, but it would be worth it in the end.

Also, yes, there is a setting in the config.php file that allows you to join your css and also one to join your js, so now the cart does this for you.

I hope that helps a bit at least.

Thanks,

Brandon