Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Google Checkout order notification failing Rate Topic   - - - - -

 
  • ecb1
  • Member
  • Members
  • Join Date: 17-Mar 08
  • 77 posts

Posted 17 December 2011 - 10:34 PM #1

I recently updated my cart software from 2.0.8 to 2.1.4 and also changed my templates from aquarelle yellow to new vision blue.

I'm not sure if either of those changes are causing my issue, but all of a sudden Google Checkout is no longer able to send order notifications to my cart. The customer is able to place the order successfully on my site using Google Checkout, and I can then log into google checkout and see the successful order, but it's not communicating it back to my cart and the orders section in my admin panel does not show the order.The only reason I know there is an order is a I get a purchase receipt email from google. I also later get an auto-email from google checkout that says:

Attention required: order notification failing

We've made several unsuccessful attempts to send order notifications to your notification callback URL ______. As a result, you aren't receiving order status, risk, or other notifications.


To help you identify the issue with your callback URL, please review the errors we encountered while sending notifications to you. To review this error information:
  • Sign in to Google Checkout.
  • Click on the Tools tab.
  • Click Integration Console.

Error messages will appear under 'Integration Issues.' If necessary, you can also update your callback URL in the 'API callback URL' box on the same page.


The settings, including my google merchant ID, merchant key, and callback url all seem to be correct when I cross reference them in my admin on my site and on google checkout, so I'm not sure what my problem is. When I log into GC, go to Tool section and click on Integration, I see a lengthy error message but am unable to interpret it and can't tell what my specific issue is.


I'm hoping someone here might be able to pinpoint my issue since I'm not very experienced with this stuff. I'm wondering if I messed something up when I changed templates, or maybe something broke during my upgrade. Thanks in advance for any assistance anyone can offer. (I would post my error message but am not sure if there is any sensitive info in there that I shouldn't make public).


Thanks again



-ecb1


 
  • ecb1
  • Member
  • Members
  • Join Date: 17-Mar 08
  • 77 posts

Posted 17 December 2011 - 11:05 PM #2

also, when i try to navigate to the api callback url, i get 404 error page not found. is this the problem and if so, how would i go about correcting it?
v 2.0.12

 
  • ecb1
  • Member
  • Members
  • Join Date: 17-Mar 08
  • 77 posts

Posted 18 December 2011 - 02:53 AM #3

I opened up a ticket with my web host and they are asking the following questiosn. I was hoping someone here might know the answer:

Hi,

When I visit that site, I'm also seeing the 404 error. Are there any mod_rewrite rules in place that could be preventing this from loading? Also, does Google Checkout require specific ports to communicate outside of 80?

Regards,
Eric
v 2.0.12

 
  • ecb1
  • Member
  • Members
  • Join Date: 17-Mar 08
  • 77 posts

Posted 18 December 2011 - 03:51 AM #4

This appears to have solved my problem:

http://forum.cs-cart...post__p__107422
v 2.0.12