Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

From 2.2.2 to 2.2.3 upgrade problem - Forbidden Rate Topic   - - - - -

 
  • YouRockDaddy
  • Senior Member
  • Members
  • Join Date: 11-Apr 06
  • 319 posts

Posted 20 October 2011 - 07:14 PM #1

Version: 2.2.3 Release date: 09/30/2011 01:01 AM Filesize: 810 Kb

I begin the upgrade, and it list files to be upgraded, then I think it backups the files, then gives a page with

........................................................................................................................continue

Then take me to


Forbidden

You don't have permission to access /xyzadmin.php on this server. <-------my custom admin page

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache mod_fcgid/2.3.6 FrontPage/5.0.2.2635 mod_bwlimited/1.4 mod_auth_passthrough/2.1 Server at www.domanname.com Port 443

 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 12052 posts

Posted 21 October 2011 - 02:08 AM #2

Sounds like an .htaccess problem. This is Apache throwing the error I'm guessing because the core configuration (or your .htaccess) is telling it not to allow PHP files in that directory.

EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • YouRockDaddy
  • Senior Member
  • Members
  • Join Date: 11-Apr 06
  • 319 posts

Posted 24 October 2011 - 12:14 AM #3

Contents of /.htaccess

DirectoryIndex index.html index.php

<IfModule mod_rewrite.c>
RewriteEngine on
# Some hostings require RewriteBase to be uncommented
# Example:
# Your store url is http://www.yourcompany.com/store/cart
# So "RewriteBase" should be:
# RewriteBase /store/cart
RewriteBase /
#RewriteCond %{REQUEST_FILENAME} !\.(png|gif|ico|swf|jpe?g|js|css)$
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteRule . index.php?sef_rewrite=1 [L,QSA]
</IfModule>

 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 12052 posts

Posted 24 October 2011 - 03:40 AM #4

.htaccess is standard.
I'm guessing that you have incorrect permissions on files that is preventing them from being "read" by the PHP process. Since you can obviously run xyzadmin.php to run the upgrade then something is happening during the upgrade that is either adding the '/' to your php filename or the permissions are wrong.

Not something that's going to get solved in the forums. Suggest you burn a couple of support credits to get help from cs-cart or hire one of the consultants who lurk here to help you.

Can you access the site again outside of the upgrade process?

EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • FrogWild
  • Junior Member
  • Members
  • Join Date: 23-Feb 11
  • 14 posts

Posted 30 November 2011 - 10:54 PM #5

I have the exact same issue. I remember having to change the admin folder name and setting certain permissions as part of the original installation process, but I've never had to jack with these during an upgrade. I deleted the contents of the .htaccess file to get rid of my 404 error, but now it's stuck on my custom permissions/admin folder. Any ideas? Or standard settings I can fall back on to get the upgrade done?
FrogWild.com - High-end Tactical LED Flashlights by

Fenix • EagleTac • JetBeam • NiteCore • 4Sevens • Klarus • Lumintop • ThruNite • Wolf Eyes

 

Posted 19 August 2012 - 01:24 AM #6

Folks, this is an old post, but I found it while I was pulling my hair out trying to fix the very same problem. After trying everything under the sun (and I mean everything). It is caused by a mod security issue, and adding the lines to the .htaccess file will NOT help. You MUST contact your host provider and have them change it for you.

Hope this helps. My host made the changes (I am on a shared, linux host) and viola! Updated super smooth and easy without problem.

 

Posted 19 August 2012 - 01:38 AM #7

Please let me add, once you try the script and get this error it trips a flag on the host. Tell them you need them to fix the "Mod Sec Error - Apache".