Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

CS: ACCESS DENIED Webmail Rate Topic   - - - - -

 
  • bigjmart
  • Senior Member
  • Members
  • Join Date: 29-Jan 10
  • 192 posts

Posted 24 November 2010 - 10:26 PM #1

Why do I keep getting this error message when I try to log into the webmail?

 
  • Struck
  • Teetering on Genious
  • Members
  • Join Date: 07-Mar 09
  • 2502 posts

Posted 24 November 2010 - 10:41 PM #2

Why do I keep getting this error message when I try to log into the webmail?


Walmart finally found you on their radar! :D
Cooking with Gas on Version 4.1.2 (But proceeding with caution....)

 

Posted 24 November 2010 - 10:46 PM #3

How about to reply to the 52 other threads you created to assist the community?
I've moved on from CS-Cart to WooC******** - If you need anything I can be of little help.

 
  • bigjmart
  • Senior Member
  • Members
  • Join Date: 29-Jan 10
  • 192 posts

Posted 25 November 2010 - 05:42 PM #4

Walmart finally found you on their radar! :D


Walmart is so large, why would they care about me?

 

Posted 29 December 2010 - 04:52 PM #5

I go the same thing going on. Activated Webmail, then when i click on it and it says: CS:ACCESS DENIED

Checked folder permissions, all are set properly.

Anyone found a solution for this problem?

 
  • d.saveliev
  • Junior Member
  • Members
  • Join Date: 20-Nov 10
  • 41 posts

Posted 23 January 2011 - 10:39 PM #6

To admin your WebMail, you need to go to http://[YOUR-SERVER-...web/mailadm.php

login: mailadm
password: 12345

And it doesn't let you in.

If that's the case - here's what you need to do.
To get your password, you have to open this file in your site (CS-Cart) directory:
/addons/webmail/lib/webmail/data/settings/settings.xml
Your mailadm password is in the node <AdminPassword> in the file.

Now you can login and administer your WebMail.

Just in case. Here you can find help on WebMail: http://[YOUR-SERVER-...elp/default.htm

Hope this post'll save to someone a couple of hours trying to figure out why the default password '12345' doesn't work.

 
  • d.saveliev
  • Junior Member
  • Members
  • Join Date: 20-Nov 10
  • 41 posts

Posted 23 January 2011 - 10:46 PM #7

1. Go to the directory /addons/webmail/lib/webmail/data/settings
2. Open the settings.xml
3. Find the node <AdminPassword> there: this IS your password to administer your webmail
4. Open http://[YOUR_CS-CART...web/mailadm.php

login: mailadm
password: [you'd just got it from p. 3.]

Just in case. Here yo can read help on the WebMail: http://[YOUR_CS-CART...elp/default.htm

Hope that's what you need.

 
  • elk
  • Member
  • Members
  • Join Date: 28-Jan 11
  • 92 posts

Posted 15 March 2011 - 04:28 PM #8

i get a 404 page when access to webmail. Webmail was working at 2.1.2 but not at 2.1.3 even if i upload the old func.php file of the webmail addon
Mylot.gr // Mobiles & Gadgets
CS-Cart 2.1.3 ver. working fine

 
  • snorocket
  • Forum Janitor
  • Members
  • Join Date: 15-Mar 06
  • 2519 posts

Posted 15 March 2011 - 05:15 PM #9

Have you tried uninstalling and reinstalling the addon, I heard sometimes that works but not alwasy - Sno
SNOROCKET.COM, Now Accepting PRE-ORDERS:
Customer Service (Helpdesk) Addon for CS-Cart v4.3.1
Quote and Invoicing Addon for CS-Cart v4.3.1

 
  • orangegirl
  • Support engineer
  • CS-Cart Support
  • Join Date: 08-Jan 08
  • 589 posts

Posted 16 March 2011 - 06:27 AM #10

i get a 404 page when access to webmail. Webmail was working at 2.1.2 but not at 2.1.3 even if i upload the old func.php file of the webmail addon


Please check the permissions for the "addons" directory of your CS-Cart installation. They should be 755. The same is for "addons/webmail" directory and all its subdirectories and files.
Kate Lazarevskaya,
CS-Cart Support Engineer
CS-Cart Knowledge Base | CS-Cart Reference Guide

 
  • elk
  • Member
  • Members
  • Join Date: 28-Jan 11
  • 92 posts

Posted 16 March 2011 - 09:39 AM #11

Please check the permissions for the "addons" directory of your CS-Cart installation. They should be 755. The same is for "addons/webmail" directory and all its subdirectories and files.


thanks a lot.
i had set the permissions of addons/webmail to 755 but not addons folder as well
Mylot.gr // Mobiles & Gadgets
CS-Cart 2.1.3 ver. working fine

 
  • kaz
  • Junior Member
  • Members
  • Join Date: 24-Jan 11
  • 16 posts

Posted 19 January 2012 - 08:41 PM #12

Hi

Did everyone get to sort this problem out?

All of my permissions are set to 755, but I still can't access the email.

Also when I go to the "settings.xml" file there is a different password there to the one I'm supposed to use. According to my web host I am supposed to be using my own password that i have set up for my email.

This is what I get in my address bar: http://www.techgems....dex.php?error=1

Even after setting the permission for the index.php file to 755, it doesn't work.

If there are any better suggestions anyone else can make it would be appreciated.

kind regards
Kaz
www.techgems.co.uk

 
  • StellarBytes
  • Senior Member
  • Members
  • Join Date: 08-Aug 11
  • 1807 posts

Posted 24 January 2012 - 11:57 AM #13

Literally tried everything to get this addon working again after enabling it to see how it worked in 2.2.3, shortly before I upgraded to 2.2.4. Now I want to re-enable it, I can't login, the dreaded "CS: Access Denied" error - I have checked file/folder permissions, the password stored in settings.xml, etc. I even tried uploading a fresh copy of the entire /addons/webmail/ folder, to no avail. Manually cleared the cache, still nothing. Oh well, looks like it's time to call in the pro's. Will post back when I find out what has caused this problem in my case.
Hire StellarBytes for CS-Cart Design & Development Services

 
  • StellarBytes
  • Senior Member
  • Members
  • Join Date: 08-Aug 11
  • 1807 posts

Posted 24 January 2012 - 02:40 PM #14

Ok, I have the solution for CS-Cart 2.2.4.

First, create a backup of this file, then edit and upload the changes:

addons/webmail/lib/webmail/web/inc_settings_path.php

Replace:
define('DIR_ROOT', $_root);
define('AREA', 'A');
include($_root . '/config.php');
With:
define('DIR_ROOT', $_root);
define('AREA', 'A');
define('ACCOUNT_TYPE', 'admin');
include($_root . '/config.php');

Hire StellarBytes for CS-Cart Design & Development Services

 
  • royalribbons
  • Junior Member
  • Members
  • Join Date: 10-Feb 09
  • 1 posts

Posted 25 January 2012 - 04:58 AM #15

After the updates above I now get this message "Please wait while WebMail is loading . . ." and nothing happens. Anyone else able to get WebMail to work in 2.2.4?
[SIZE=4]Keith Johnson[/SIZE]
Royal Ribbons and Awards

 
  • ilib
  • Advanced Member
  • Members
  • Join Date: 22-Mar 12
  • 92 posts

Posted 03 July 2012 - 12:20 PM #16

I commented line 13 in addons/webmail/lib/webmail/web/inc_settings_path.php (CS 3.0.1)

// die('CS: ACCESS DENIED');

and it works now!

Use advanced login if your mail server is elsewhere but on localhost

CS-Cart and Magento support and development

https://shop.kozeta.lt


 
  • anandhud
  • Newbie
  • Trial users
  • Join Date: 04-Aug 12
  • 1 posts

Posted 16 August 2012 - 02:00 PM #17

I commented line 13 in addons/webmail/lib/webmail/web/inc_settings_path.php (CS 3.0.1)

// die('CS: ACCESS DENIED');

and it works now!

Use advanced login if your mail server is elsewhere but on localhost


This worked fine.

 
  • remoteone
  • Member
  • Members
  • Join Date: 06-Oct 09
  • 742 posts

Posted 19 June 2013 - 02:39 AM #18

Ive had this same problem. V 2.1.4
Made the changes above but get this msg below, which looks like a PHP version incompatibility issue?

Error while parsing XML.
Error code 2.
Response text:

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Antarctica/Macquarie' for 'EST/10.0/no DST' instead in /home/mysite/public_html/myfolder/addons/webmail/lib/webmail/web/common/class_log.php on line 10

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'xxxxxx_xxxx'@'xxx-xxx.hosting-service.net.au' (using password: YES) in /home/mysite/public_html/myfolder/addons/webmail/lib/webmail/web/db/class_dbmysql.php on line 40

Id love to get this webmail working.
Help apreciated.