Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

CS-Cart 2.1.0 is released Rate Topic   - - - - -

 
  • RafaJ
  • Junior Member
  • Members
  • Join Date: 22-May 09
  • 8 posts

Posted 17 August 2010 - 06:16 PM #141

Thanks for your help!
I followed the steps you're saying, but when I turn off suppliers everything disappears again

I have opened a ticket...

 
  • ghsc
  • Junior Member
  • Members
  • Join Date: 03-Aug 07
  • 53 posts

Posted 17 August 2010 - 10:45 PM #142

We recommend to use the CS-Cart 2.1.0 for live stores.

Some problems may occur if your making upgrade from 2.0.15.

If your 2.0.15 store has a lot of file modifications, we highly recommend you to perform an upgrade to 2.1 on a test installation of your store first. Then check if everything works fine, and only after that upgrade your live store.



Ok so I have been trying to do a clean install for the past 10 hours.
uploaded all files, and fixed permissions and started the install:

I can't get past page 2 of the installation wizard! I have tried on two different sites, same problem on both.

Every time I click next before the database installation starts, it wants to download index.php (in firefox) or browser shows install/index.php with message: server error page cannot be found (safari).

I am doing this on a test server luckily. its located on a dedicated server that runs 4 other cs-cart sites. php settings are all good.

what could it be?

All file permissions have been checked, triple checked. its driving me crazy.

i also disabled the .htaccess files and reactivated them.

 
  • S-Combs
  • Senior Member
  • Members
  • Join Date: 09-Nov 06
  • 692 posts

Posted 17 August 2010 - 10:58 PM #143

If this is a dedicated server, please check your Apache error log and /var/log/messages to see if those will give us some hints as to what the problem is.
Secure Cart Hosting
[CS-Cart Optimized Solutions and Server Management]

 
  • S-Combs
  • Senior Member
  • Members
  • Join Date: 09-Nov 06
  • 692 posts

Posted 17 August 2010 - 11:02 PM #144

ghsc. If this is a dedicated server, please check your Apache error log and /var/log/messages to see if those will give us some hints as to what the problem is.
Secure Cart Hosting
[CS-Cart Optimized Solutions and Server Management]

 
  • vmajor
  • Member
  • Members
  • Join Date: 08-Feb 10
  • 74 posts

Posted 18 August 2010 - 03:22 AM #145

I also have the Out-of-stock message for in stock items in product list view.

See here:

http://shop.velocite-bikes.com/

Wheels show as out of stock, but they are not.

http://shop.velocite...0-wheelset.html

Since we are tracking inventory per variant, my guess is that whoever re-wrote the code for the product list view missed the variant/option inventory tracking feature.

Please advise on how to fix this.

V.

 
  • RafaJ
  • Junior Member
  • Members
  • Join Date: 22-May 09
  • 8 posts

Posted 18 August 2010 - 02:27 PM #146

Now, if Suppliers are disabled, Supplier's products are not shown in Storefront.
Turn on the Suppliers functionality (Administration -> Settings -> Suppliers). Edit the product with supplier (set Supplier to your company). Turn of the suppliers functionality.

Or you can go to the Database interface for example phpMyAdmin and in table cscart_products set field "company_id" = 0.

SQL query:
UPDATE cscart_products SET company_id = 0;

The problem was that in previous version "supplier" addon was enable (but not working), I don´t know why. They make changes in database and now works fine, now I can disable it without missing items.

Thanks

 
  • SevenSuns
  • Junior Member
  • Members
  • Join Date: 14-Nov 09
  • 15 posts

Posted 18 August 2010 - 04:39 PM #147

My products all show out of stock at http://www.lilyslathers.com I have no special inventory setup that would be causing that. The numbers are right in the control panel, but the site shows "Out of Stock". Customers can still add the item and order, but that message will prevent a lot from doing so. Your help is appreciated!!!

 
  • ghsc
  • Junior Member
  • Members
  • Join Date: 03-Aug 07
  • 53 posts

Posted 18 August 2010 - 04:53 PM #148

ghsc. If this is a dedicated server, please check your Apache error log and /var/log/messages to see if those will give us some hints as to what the problem is.


hi, thanks for the advice. i did check the file /var/log/messages

but did not find any clues as to why it not working. most of the logs are about drweb antivirus and my watchdog settings.

Cs-cart team told me to disable mod_security...

did that in .htaccess, but there is no effect.

By the way I have 5 working installations of cs-cart on the same dedicated server. only difference is i installed them from 2.0.13 or 0.12 some earlier version.

this is really driving me crazy and i know, its a little thing that needs changing, just cant figure out what.

gave cs-cart staff access to my ftp....and 99% of the time they solve the problem. so i hope they can figure it out...

IF ANYONE KNOWS WHY MY BROWSER TRIES TO DOWNLOAD INDEX.PHP IN THE INSTALL, PLEASE LET ME KNOW..

:-)

 
  • S-Combs
  • Senior Member
  • Members
  • Join Date: 09-Nov 06
  • 692 posts

Posted 18 August 2010 - 05:02 PM #149

The Apache error log would contain the most helpful information.. If you are on a cPanel system then it will be located here /usr/local/apache/logs/error_log

I told you to also check messages because by default that is where Suhosin will post errors if it is installed.

If index.php is the only php file it is trying to download then it may be corrupted. If you notice other files doing this as well then you have a configuration problem somewhere.
Secure Cart Hosting
[CS-Cart Optimized Solutions and Server Management]

 
  • zeero6
  • Senior Member
  • Members
  • Join Date: 25-Jan 07
  • 649 posts

Posted 18 August 2010 - 05:22 PM #150

This version is so freaking slow. Even Admin area times out sometimes

Version 4.9.3 SP1


 
  • snorocket
  • Forum Janitor
  • Members
  • Join Date: 15-Mar 06
  • 2519 posts

Posted 18 August 2010 - 06:35 PM #151

This version is so freaking slow. Even Admin area times out sometimes

I can confirm that when upgraded one of our stores to 2.1 it was significantly slower on both the customer and admin side, almost to the point it timed out as well. After clearing the cache several times it seems to be back to normal - Sno
SNOROCKET.COM, Now Accepting PRE-ORDERS:
Customer Service (Helpdesk) Addon for CS-Cart v4.3.1
Quote and Invoicing Addon for CS-Cart v4.3.1

 
  • zeero6
  • Senior Member
  • Members
  • Join Date: 25-Jan 07
  • 649 posts

Posted 18 August 2010 - 08:19 PM #152

Did you delete any files manually or used the /admin.php?cc option?

Thanks

Version 4.9.3 SP1


 
  • Net-burst
  • Junior Member
  • Members
  • Join Date: 19-Nov 09
  • 30 posts

Posted 18 August 2010 - 10:16 PM #153

I can confirm that when upgraded one of our stores to 2.1 it was significantly slower on both the customer and admin side, almost to the point it timed out as well. After clearing the cache several times it seems to be back to normal - Sno

Hm. I can also confirm this on fresh install. Whereas live 2.0.15 take ~1-3 seconds to load, fresh and empty 2.1 often takes ~7-15 seconds... I use nginx+php-fpm+apc. It does not matter whether apc is active or not... ?cc does not help. Even manual deletion of cache & compiled directories does not help.

 
  • snorocket
  • Forum Janitor
  • Members
  • Join Date: 15-Mar 06
  • 2519 posts

Posted 19 August 2010 - 01:02 AM #154

Did you delete any files manually or used the /admin.php?cc option?

Thanks

I just used admin.php?cc like 10x's - Sno
SNOROCKET.COM, Now Accepting PRE-ORDERS:
Customer Service (Helpdesk) Addon for CS-Cart v4.3.1
Quote and Invoicing Addon for CS-Cart v4.3.1

 
  • ghsc
  • Junior Member
  • Members
  • Join Date: 03-Aug 07
  • 53 posts

Posted 19 August 2010 - 12:23 PM #155

The Apache error log would contain the most helpful information.. If you are on a cPanel system then it will be located here /usr/local/apache/logs/error_log

I told you to also check messages because by default that is where Suhosin will post errors if it is installed.

If index.php is the only php file it is trying to download then it may be corrupted. If you notice other files doing this as well then you have a configuration problem somewhere.


Hi I am using plesk.

my logs are in usr/local/psa/

I've checked about 20 log files. cant find nothing....

but isnt it wierd that i was able to install 4 other installations earlier this year.....and am running 4 installations and a new install does not work????????

its all on the same dedicated server with the same settings.

this stuff drives me crazy, cs-cart staffs seems very busy lately.

and judging by the comments here, its a bad idea to upgrade (performance seems to be very slow!)