Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

CS-Cart 2.1.0 is released Rate Topic   - - - - -

 
  • jint
  • Member
  • Members
  • Join Date: 14-Oct 09
  • 77 posts

Posted 14 August 2010 - 11:35 AM #121

I've reverted back to my old CS Cart install, works fine :D :D :D

 
  • Traveler
  • Senior Member
  • Members
  • Join Date: 02-Feb 07
  • 995 posts

Posted 14 August 2010 - 12:39 PM #122

I've reverted back to my old CS Cart install, works fine :D :D :D



But you are still brave for trying!

Thank you.

Version 4.13.3


 
  • Darius
  • Douchebag
  • Members
  • Join Date: 20-Apr 08
  • 3561 posts

Posted 14 August 2010 - 12:46 PM #123

First, I thank those brave individuals who have upgraded and posted their experiences.


Yea, I would never risk upgrading live store to release like such...

 
  • Hetha
  • Junior Member
  • Members
  • Join Date: 08-Nov 09
  • 22 posts

Posted 14 August 2010 - 01:49 PM #124

Upgraded today on a quite heavily modified shop and all working fine.

Had some problems with templates and also with display of stock status but this was largely due to our own template modifications and trying to locate where to re-implement our own code changes.

Orders have been placed successfully and very happy with look and feel and also new checkout system.

 

Posted 14 August 2010 - 01:51 PM #125

I cannot "sort/ shop/ search" by supplier . How do I do this now?

 
  • AmitP
  • Senior Member
  • Members
  • Join Date: 08-Feb 10
  • 510 posts

Posted 14 August 2010 - 08:40 PM #126

Has anyone tried updating their google base at all from 2.1 I have imported the exported products feed and where as i used to have 657 products of 687 i now have 476 of 687. Anyone also seen a decrease in valid products accepted by google? I took a look at the exported .csv and the price column is completely ruined. The price on many of the products is either "0" of a negative figure like "-8.2" Can this please get sorted.
VPS 2.0GHz + 1GB RAM

 
  • nedd
  • Senior Member
  • Members
  • Join Date: 13-Jan 08
  • 125 posts

Posted 15 August 2010 - 09:52 AM #127

CS-Cart 2.1 introduces a completely reorganized images file structure for performance reasons.

You can safely remove the {CS-Cart directory}/var/upgrade directory after a successful upgrade to reduce the number of inodes in use.


You should make it optional for store owners, or, at least, WARN!!! in advance store owners that the old images structure/locations will be lost after upgrade.

Do you mean remove complete /var/upgrade/ directory and all of it's files/subfolders?

 
  • yacine
  • Junior Member
  • Members
  • Join Date: 20-Nov 05
  • 5 posts

Posted 16 August 2010 - 06:40 AM #128

Hot Deals block not showing images

 
  • BarryH
  • Senior Member
  • Members
  • Join Date: 03-Sep 07
  • 1459 posts

Posted 16 August 2010 - 07:16 AM #129

Hot Deals block not showing images


Yeah same here. We thought it was because we changed image sizes in products. But maybe it just a bug!!!!

BarryH

 

CS-Cart v4.4.3 (Plus one being developed v4.5.2 SP2)
UK User


 
  • 2tl
  • Architect
  • Twigmo team
  • Join Date: 03-Dec 09
  • 230 posts

Posted 16 August 2010 - 07:20 AM #130

You should make it optional for store owners, or, at least, WARN!!! in advance store owners that the old images structure/locations will be lost after upgrade.

Do you mean remove complete /var/upgrade/ directory and all of it's files/subfolders?


You old images are backuped too, it /var/upgrade/...2.0.15-2.1.0.../backup/images

On the page Administration -> Upgrade center -> Installed upgrades there is the "remove" link. You can use it for removing all upgrade and backup files. Use it only if you are sure that the store works fine and you don't do the revert.

 
  • S-Combs
  • Senior Member
  • Members
  • Join Date: 09-Nov 06
  • 692 posts

Posted 16 August 2010 - 10:45 AM #131

yacine and Barry

You might try the fix posted by KleriK in this bug report

http://forum.cs-cart...ew&vbug_id=2053
Secure Cart Hosting
[CS-Cart Optimized Solutions and Server Management]

 
  • AmitP
  • Senior Member
  • Members
  • Join Date: 08-Feb 10
  • 510 posts

Posted 16 August 2010 - 11:19 AM #132

Does anyone have google base problems at all? I have tried exporting a variety of databases now with google base export and it either exports half of our product database, or give the price field as either a 0 or negative figure. We get alot of hits through Froogle and to not have this functionality is going to hit us quite hard I think. Any help would be greatly appreciated. Also the exported files link no longer works so I cant direct download through CS-Cart I now have to FTP in order to achieve this.

Regards
VPS 2.0GHz + 1GB RAM

 
  • BarryH
  • Senior Member
  • Members
  • Join Date: 03-Sep 07
  • 1459 posts

Posted 16 August 2010 - 11:30 AM #133

Does anyone have google base problems at all? I have tried exporting a variety of databases now with google base export and it either exports half of our product database, or give the price field as either a 0 or negative figure. We get alot of hits through Froogle and to not have this functionality is going to hit us quite hard I think. Any help would be greatly appreciated. Also the exported files link no longer works so I cant direct download through CS-Cart I now have to FTP in order to achieve this.

Regards


Be very careful, check what has been exported as it is sending 0 or - price values to google.

http://forum.cs-cart...ew&vbug_id=2072

I have just re done all of mine, by exporting products and cut and pasting prices to get them right.

BarryH

 

CS-Cart v4.4.3 (Plus one being developed v4.5.2 SP2)
UK User


 
  • AmitP
  • Senior Member
  • Members
  • Join Date: 08-Feb 10
  • 510 posts

Posted 16 August 2010 - 11:36 AM #134

Be very careful, check what has been exported as it is sending 0 or - price values to google.

http://forum.cs-cart...ew&vbug_id=2072

I have just re done all of mine, by exporting products and cut and pasting prices to get them right.


Yeah i know, I had to delete my datafeed and upload an old .csv I luckily had on my server. This is tragic.....lol, I don't have the time to manually redo them all. :-)
VPS 2.0GHz + 1GB RAM

 
  • 2tl
  • Architect
  • Twigmo team
  • Join Date: 03-Dec 09
  • 230 posts

Posted 16 August 2010 - 12:00 PM #135

First, I thank those brave individuals who have upgraded and posted their experiences.

Next, I am wondering if CS cart can tell us when the next upgrade will be that will have all the bug fixes for 2.1?


The upgrade script was updated. Some bugfixes were included in new upgrade script.
The new version of Cs-Cart will be available nearly at the end of this month.

 
  • 2tl
  • Architect
  • Twigmo team
  • Join Date: 03-Dec 09
  • 230 posts

Posted 16 August 2010 - 12:01 PM #136

Upgraded today on a quite heavily modified shop and all working fine.

Had some problems with templates and also with display of stock status but this was largely due to our own template modifications and trying to locate where to re-implement our own code changes.

Orders have been placed successfully and very happy with look and feel and also new checkout system.


Thank you for the kind words )

 
  • 2tl
  • Architect
  • Twigmo team
  • Join Date: 03-Dec 09
  • 230 posts

Posted 16 August 2010 - 12:15 PM #137

Has anyone tried updating their google base at all from 2.1 I have imported the exported products feed and where as i used to have 657 products of 687 i now have 476 of 687. Anyone also seen a decrease in valid products accepted by google? I took a look at the exported .csv and the price column is completely ruined. The price on many of the products is either "0" of a negative figure like "-8.2" Can this please get sorted.


The discussion of this problem will be at http://forum.cs-cart...ew&vbug_id=2062

 
  • 2tl
  • Architect
  • Twigmo team
  • Join Date: 03-Dec 09
  • 230 posts

Posted 16 August 2010 - 12:24 PM #138

Yeah same here. We thought it was because we changed image sizes in products. But maybe it just a bug!!!!


I will discuss this problem here: http://forum.cs-cart...ew&vbug_id=2067

 
  • RafaJ
  • Junior Member
  • Members
  • Join Date: 22-May 09
  • 8 posts

Posted 17 August 2010 - 09:30 AM #139

I have updated from 2.0.5 to 2.1.0 and I found a problem, several items are missing from some categories, I can see them in the admin panel but not the storefront.
- These items are active
- Show out of stock products is Active

I can see that missing items has "supplier" word at the end of description (??)

Thanks

Help please.

 
  • 2tl
  • Architect
  • Twigmo team
  • Join Date: 03-Dec 09
  • 230 posts

Posted 17 August 2010 - 12:44 PM #140

I have updated from 2.0.5 to 2.1.0 and I found a problem, several items are missing from some categories, I can see them in the admin panel but not the storefront.
- These items are active
- Show out of stock products is Active

I can see that missing items has "supplier" word at the end of description (??)

Thanks

Help please.


Now, if Suppliers are disabled, Supplier's products are not shown in Storefront.
Turn on the Suppliers functionality (Administration -> Settings -> Suppliers). Edit the product with supplier (set Supplier to your company). Turn of the suppliers functionality.

Or you can go to the Database interface for example phpMyAdmin and in table cscart_products set field "company_id" = 0.
SQL query:
UPDATE cscart_products SET company_id = 0;