Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

CS-Cart 2.1.0 is released Rate Topic   - - - - -

 
  • Lazic
  • Junior Member
  • Members
  • Join Date: 05-Sep 09
  • 11 posts

Posted 09 August 2010 - 08:03 PM #21

m2
i created that folders and now have this
Warning: mkdir() expects parameter 2 to be long, string given in /home/xxx/public_html/xx/core/fn.fs.php on line 114

Warning: include(/home/xxxxpublic_html/xxx/var/compiled/admin/%%45^45E^45E480CD%%index.tpl.php) [function.include]: failed to open stream: Permission denied in /home/xxxx/public_html/xxxx/lib/templater/Smarty.class.php on line 1258

Warning: include() [function.include]: Failed opening '/home/xxxx/public_html/xxxx/var/compiled/admin/%%45^45E^45E480CD%%index.tpl.php' for inclusion (include_path='/home/xxxx/public_html/shop/lib/pear/.:/usr/lib/php:/usr/local/lib/php') in /home/xxxx/public_html/xxxx/lib/templater/Smarty.class.php on line 1258

 
  • admin
  • CEO
  • Administrators
  • Join Date: 11-Apr 06
  • 168 posts

Posted 09 August 2010 - 08:12 PM #22

Another update.

Fix instructions have been updated. Please perform the described steps once again.

And please keep us informed on results.

Thank you, guys. We appreciate your patience.
Sincerely yours,
Vladimir Kalynyak
CEO

 
  • Lazic
  • Junior Member
  • Members
  • Join Date: 05-Sep 09
  • 11 posts

Posted 09 August 2010 - 08:22 PM #23

i am back a shop.tnx

 
  • zeero6
  • Senior Member
  • Members
  • Join Date: 25-Jan 07
  • 649 posts

Posted 09 August 2010 - 08:23 PM #24

Thank you again
Working great

Version 4.9.3 SP1


 
  • sellon
  • Senior Member
  • Members
  • Join Date: 07-Feb 10
  • 151 posts

Posted 09 August 2010 - 11:45 PM #25

Another update.

Fix instructions have been updated. Please perform the described steps once again.

And please keep us informed on results.

Thank you, guys. We appreciate your patience.


Admin,

As a new/fresh install I am assuming I don't need to worry about these updates/fixes and they will be incorporated in the download for 2.1..am I correct?

This fixes I am assuming is more for people who have trouble whilst upgrading.

 
  • TonyK
  • Member
  • Members
  • Join Date: 03-Mar 06
  • 1686 posts

Posted 10 August 2010 - 12:08 AM #26

I believe that is the case, yes.

upgrades were broken but not fresh installs.
Pimpin' skins since v1.0

 
  • mitbar
  • Member
  • Members
  • Join Date: 14-May 10
  • 54 posts

Posted 10 August 2010 - 12:21 AM #27

what is everyones feedback on this so far?

 
  • ghgames
  • Member
  • Banned
  • Join Date: 24-Jun 10
  • 61 posts

Posted 10 August 2010 - 04:58 AM #28

any more updates? Doesn't seem to find it in the upgrade center now.. And I tried installing it new... but restoring of backup is not possible... causes database error..

Database error: Unknown column 'object_holder' in 'field list' (1054)
Invalid query: SELECT object_holder, description FROM cscart_common_descriptions WHERE object_id = 0 AND lang_code = 'EN'

Backtrace:
File: /home/thegeekz/public_html/eshop/core/fn.database.php
Line: 310
Function: db_error
File: /home/thegeekz/public_html/eshop/core/fn.database.php
Line: 245
Function: db_query
File: /home/thegeekz/public_html/eshop/core/fn.common.php
Line: 3056
Function: db_get_hash_single_array
File: /home/thegeekz/public_html/eshop/core/fn.init.php
Line: 152
Function: fn_get_manifest
File: /home/thegeekz/public_html/eshop/init.php
Line: 153
Function: fn_init_templater
File: /home/thegeekz/public_html/eshop/admin.php
Line: 23
Function: require

 
  • Darius
  • Douchebag
  • Members
  • Join Date: 20-Apr 08
  • 3559 posts

Posted 10 August 2010 - 06:26 AM #29

In demo site with English lang default in statistics online visitor countries shown as Litauen, Indien, Rusland, CanaDA why so?

 
  • Andy Ye
  • CS-Cart team
  • Join Date: 16-Jun 10
  • 13 posts

Posted 10 August 2010 - 06:56 AM #30

any more updates? Doesn't seem to find it in the upgrade center now.. And I tried installing it new... but restoring of backup is not possible... causes database error..


You can manually restore the backup database by importing the following SQL files:

{CS-Cart directory}/var/upgrade/upgrade_2.0.15-2.1.0.tgz/backup/uc.sql
{CS-Cart directory}/var/upgrade/upgrade_2.0.15-2.1.0.tgz/backup/uc2.sql

 
  • 2tl
  • Architect
  • Twigmo team
  • Join Date: 03-Dec 09
  • 230 posts

Posted 10 August 2010 - 08:44 AM #31

In demo site with English lang default in statistics online visitor countries shown as Litauen, Indien, Rusland, CanaDA why so?


Thank you for the information.

This problem will be fixed in next version of Cs-Cart store.
You can resolve this problem by yourself, this code in the "unified diff" format shows what to do.
Code:
Index: addons/statistics/controllers/admin/statistics.php
===================================================================
--- a/addons/statistics/controllers/admin/statistics.php
+++ b/addons/statistics/controllers/admin/statistics.php
@@ -1205,5 +1205,5 @@
         $join['?:stat_search_phrases'] = "?:stat_sessions.phrase_id = ?:stat_search_phrases.phrase_id";
         $join['?:stat_languages'] = "?:stat_sessions.client_language = ?:stat_languages.lang_code";
-        $join['?:country_descriptions'] = db_quote("?:stat_ips.country_code = ?:country_descriptions.code AND ?:country_descriptions.lang_code = ?d", CART_LANGUAGE);
+        $join['?:country_descriptions'] = db_quote("?:stat_ips.country_code = ?:country_descriptions.code AND ?:country_descriptions.lang_code = ?s", CART_LANGUAGE);
 
         $filter_condition = fn_bild_sql_join($join);
This fix provided in unified diff format, see:
http://www.artima.co...p?thread=164293
http://www.araxis.co...rt_unified.html

 
  • user2008
  • Member
  • Members
  • Join Date: 17-Jan 08
  • 91 posts

Posted 10 August 2010 - 09:05 AM #32

Dear CS-Cart developer Stuff:

Latest version installed to local server

I see login screen sending "something" to cs-stuff. Firewall reported.

http://127.0.0.1/adm...n_url=admin.php

What does it mean?

Attached Thumbnails

  • firewall.jpg


 
  • joe
  • Senior Member
  • Members
  • Join Date: 06-Jan 09
  • 824 posts

Posted 10 August 2010 - 09:44 AM #33

In order to fix the upgrade issue please do the following:

1. Open for editing the “config.local.php” file in the root directory of your CS-Cart installation.

2. Find the following piece of code there:

// Developer configuration file
if (file_exists(DIR_ROOT . '/local_conf.php')) {
include(DIR_ROOT . '/local_conf.php');
}


3.
Add the following code below it:


define('TABLE_PREFIX', 'cscart_');  
define('DEFAULT_FILE_PERMISSIONS', 0644);
define('DEFAULT_DIR_PERMISSIONS', 0755);
so, that it reads:

// Developer configuration file
if (file_exists(DIR_ROOT . '/local_conf.php')) {
include(DIR_ROOT . '/local_conf.php');
}
define('TABLE_PREFIX', 'cscart_');
define('DEFAULT_FILE_PERMISSIONS', 0644);
define('DEFAULT_DIR_PERMISSIONS', 0755);


Important note!
If you manually did change the default database prefix “cscart_” to a different value then you must use it instead: substitute the “cscart_” text in the instructions above to your new prefix value.


4. Save the file.

This should fix the error.

Feel free to contact our technical support team via the Help Desk system if you need an assistance regarding the issue.

Every user has to apply this bunch of code in order to upgrade to 2.1.0?
PM me for custom project

 
  • S-Combs
  • Senior Member
  • Members
  • Join Date: 09-Nov 06
  • 692 posts

Posted 10 August 2010 - 09:55 AM #34

Dear CS-Cart developer Stuff:

Latest version installed to local server

I see login screen sending "something" to cs-stuff. Firewall reported.

http://127.0.0.1/adm...n_url=admin.php

What does it mean?


That is an image loading from cs-cart.com when you log into the admin area
		<img src="https://www.cs-cart.com/images/background.gif" height="1" width="1" alt="" />
</body>

Secure Cart Hosting
[CS-Cart Optimized Solutions and Server Management]

 
  • user2008
  • Member
  • Members
  • Join Date: 17-Jan 08
  • 91 posts

Posted 10 August 2010 - 09:57 AM #35

That is an image loading from cs-cart.com when you log into the admin area

        <img src="https://www.cs-cart.com/images/background.gif" height="1" width="1" alt="" />
</body>

Hmm. Team will be happy if our install completed or admin logged in. :D

 
  • 2tl
  • Architect
  • Twigmo team
  • Join Date: 03-Dec 09
  • 230 posts

Posted 10 August 2010 - 10:08 AM #36

Every user has to apply this bunch of code in order to upgrade to 2.1.0?


Of course they hasn't to. We're releasing a fixed upgrade script, it's going to be available ASAP.

 
  • joe
  • Senior Member
  • Members
  • Join Date: 06-Jan 09
  • 824 posts

Posted 10 August 2010 - 10:14 AM #37

Of course not. We're releasing a fixed upgrade script, it's going to be available ASAP.

Will the admin side replace the old upgrade files which are already downloaded(not installed yet) with the new upgrade script?
PM me for custom project

 
  • 2tl
  • Architect
  • Twigmo team
  • Join Date: 03-Dec 09
  • 230 posts

Posted 10 August 2010 - 10:35 AM #38

Will the admin side replace the old upgrade files which are already downloaded(not installed yet) with the new upgrade script?


Yes, new upgrade script will replace old, when you click "Refresh packages list"

 
  • joe
  • Senior Member
  • Members
  • Join Date: 06-Jan 09
  • 824 posts

Posted 10 August 2010 - 11:32 AM #39

Yes, new upgrade script will replace old, when you click "Refresh packages list"

Good to hear that. Thanks for the tips.
PM me for custom project

 
  • AmitP
  • Senior Member
  • Members
  • Join Date: 08-Feb 10
  • 510 posts

Posted 10 August 2010 - 02:59 PM #40

any more updates? Doesn't seem to find it in the upgrade center now.. And I tried installing it new... but restoring of backup is not possible... causes database error..

Database error: Unknown column 'object_holder' in 'field list' (1054)
Invalid query: SELECT object_holder, description FROM cscart_common_descriptions WHERE object_id = 0 AND lang_code = 'EN'

Backtrace:
File: /home/thegeekz/public_html/eshop/core/fn.database.php
Line: 310
Function: db_error
File: /home/thegeekz/public_html/eshop/core/fn.database.php
Line: 245
Function: db_query
File: /home/thegeekz/public_html/eshop/core/fn.common.php
Line: 3056
Function: db_get_hash_single_array
File: /home/thegeekz/public_html/eshop/core/fn.init.php
Line: 152
Function: fn_get_manifest
File: /home/thegeekz/public_html/eshop/init.php
Line: 153
Function: fn_init_templater
File: /home/thegeekz/public_html/eshop/admin.php
Line: 23
Function: require


Could we please have a bit of help with this? just tried restoring my 2.0.15 db into 2.1 fresh install and it doesn't work. :-(

ty
VPS 2.0GHz + 1GB RAM