Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Can't activate SEO addon Rate Topic   - - - - -

 
  • resen
  • Junior Member
  • Members
  • Join Date: 07-Jul 10
  • 3 posts

Posted 07 July 2010 - 10:23 PM #1

Please help, I can't activate seo addon,
its just new install of CS-Cart (installed in root directory)

i get this message-
SEO URLs can't work for now - they were disabled. Please check your webserver and URL manipulation engine settings.

.htaccess - without changes

please help!!!

 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3848 posts

Posted 07 July 2010 - 10:25 PM #2

Check mod_rewrite on server

 
  • resen
  • Junior Member
  • Members
  • Join Date: 07-Jul 10
  • 3 posts

Posted 07 July 2010 - 10:33 PM #3

at httpd.conf (is uncommented)

LoadModule rewrite_module modules/mod_rewrite.so

i also have other site with joomla seo activated, and its work good
but i really cant understand what can be with cs-cart :(

 
  • S-Combs
  • Senior Member
  • Members
  • Join Date: 09-Nov 06
  • 692 posts

Posted 08 July 2010 - 09:54 AM #4

If you are sure mod_rewrite is working on the server and your rewritebase setting is correct but are still not able to activate the addon, try this.

Open
addons/seo/schemas/settings/actions.post.php

Comment out the following code that handles that activation check

		if (strpos($result[0]['RESPONSE'], '200 OK') === false) {
$new_value = 'D';
fn_set_notification('W', fn_get_lang_var('warning'), fn_get_lang_var('warning_seo_urls_disabled'));
}


Change to

/* if (strpos($result[0]['RESPONSE'], '200 OK') === false) {
$new_value = 'D';
fn_set_notification('W', fn_get_lang_var('warning'), fn_get_lang_var('warning_seo_urls_disabled'));
} */

Secure Cart Hosting
[CS-Cart Optimized Solutions and Server Management]

 
  • timst
  • Member
  • Members
  • Join Date: 13-Feb 09
  • 110 posts

Posted 08 July 2010 - 02:04 PM #5

You say .htaccess is unchanged?
the line down below "RewriteBase" has to be changed to your store path

ex.. www.yourshop.com/store would be
RewriteBase /store

or www.yourshop.com would be:
RewriteBase /


# Some hostings require RewriteBase to be uncommented
# Example:
# Your store url is http://www.yourcompany.com/store/cart
# So "RewriteBase" should be:
# RewriteBase /store/cart
RewriteBase /
V 4.2.2

 
  • resen
  • Junior Member
  • Members
  • Join Date: 07-Jul 10
  • 3 posts

Posted 08 July 2010 - 04:24 PM #6

If you are sure mod_rewrite is working on the server and your rewritebase setting is correct but are still not able to activate the addon, try this.

Open
addons/seo/schemas/settings/actions.post.php

Comment out the following code that handles that activation check

		if (strpos($result[0]['RESPONSE'], '200 OK') === false) {
$new_value = 'D';
fn_set_notification('W', fn_get_lang_var('warning'), fn_get_lang_var('warning_seo_urls_disabled'));
}


Change to

/* if (strpos($result[0]['RESPONSE'], '200 OK') === false) {
$new_value = 'D';
fn_set_notification('W', fn_get_lang_var('warning'), fn_get_lang_var('warning_seo_urls_disabled'));
} */


Very Big Thanks!!! This solution helps me

 
  • shareef790
  • Member
  • Members
  • Join Date: 12-Jul 11
  • 17 posts

Posted 25 August 2011 - 11:28 AM #7

Oh Great help for me too. Even I had the same issue and fixed now.

 

Posted 26 April 2013 - 02:41 PM #8

I've noticed this issue also tends to occur when you have the website behind basic access authentication for development / testing purposes.

EDIT: Oh whoa....sorry for the old topic bump.

Edited by wartornskull, 26 April 2013 - 02:42 PM.