Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Live Help beta 3 Rate Topic   * * * * - 1 votes

 
  • zeke
  • Megamind
  • Administrators
  • Join Date: 01-Nov 05
  • 472 posts

Posted 02 April 2010 - 10:19 AM #1

Hello,

Live Help beta 3 is released. It includes minor usability improvements and MacOS version. Download:

Windows version: http://zeke.dev.cs-c...0-beta3-win.zip
Linux version: http://zeke.dev.cs-c...0-beta3-lin.tgz
new MacOS version: http://zeke.dev.cs-c...0-beta3-mac.zip

Server code: http://zeke.dev.cs-c...help-server.tgz

 
  • Noman
  • Senior Member
  • Members
  • Join Date: 29-Oct 07
  • 526 posts

Posted 02 April 2010 - 11:22 AM #2

Thank you sir ;)
I'm Number 1, so why try harder?

CIA wannabe or having doubts and need some answers?
Spy Gadgets and CCTV Equipment

 
  • 2020
  • Senior Member
  • Members
  • Join Date: 11-Feb 07
  • 509 posts

Posted 02 April 2010 - 05:09 PM #3

Thanks for the new version! The new Mac Operator app works exactly like the Windows version - well done.

Usability issue:

Here's a common scenario that could cause some confusion among operators:
2 operators online - Bob and Mary
1 customer online - Joe
Joe© is waiting for chat
Bob(O) initiates Chatting with Joe© and sends chat text
Mary(O) mistakenly clicks on chatting Joe© and also sends chat text

Nothing in the "Chat" pane alerts Mary that she is trying to chat with someone already connected to another Operator. Mary will see responses from Joe, but Joe won't see any chat text sent from Mary.

Granted, if Mary looks at the Detailed Info or Event log, she'll see that Joe is connected to Bob - but that info should be more obvious.

Ideally, Mary should be able to see the full conversation between Bob and Joe. Even better: let Mary join in the chat. If that isn't possible, sending chat text should be disabled for Mary.

A similar function that would be nice: Let operators chat with each other.

Functionality issue:

I wasn't able to get Tray notifications to work. Sounds worked fine.

Glen

 
  • jobosales
  • Senior Member
  • Members
  • Join Date: 04-Nov 06
  • 3114 posts

Posted 02 April 2010 - 11:00 PM #4

Good to see the Mac client.

Replies sent to offline messages containing email addresses with "+' addressing are not sent.

Bob
CS-Cart 2.0.14 (testing)

 
  • jobosales
  • Senior Member
  • Members
  • Join Date: 04-Nov 06
  • 3114 posts

Posted 06 April 2010 - 09:46 PM #5

What is the purpose of the "Statistics" column in the Admin chat history (?dispatch=chat_history.manage)? It is currently just an empty column.

Also, please note that the following issues reported for Beta 2 are still present:
http://forum.cs-cart...21&postcount=22

3) In chat history detail, when viewing a message, the link to the person's email who sent the message displays incorrectly (the html anchor tags are visible - possible getting encoded or the escaping mechanism is set in the wrong order - i.e. you are castrating form input with escaping and replacements but that it happening to the email address after the anchor tags have already been applied).


http://forum.cs-cart...30&postcount=23

A few things interface-wise.

1) When replying to an offline message, the message does not get flagged as 'read' - only when you open a message and close it without replying.

2) There needs to be a button to "hide read messages" from the off-line message list.


Bob
CS-Cart 2.0.14 (testing)

 
  • zeke
  • Megamind
  • Administrators
  • Join Date: 01-Nov 05
  • 472 posts

Posted 08 April 2010 - 08:49 AM #6

Functionality issue:

I wasn't able to get Tray notifications to work. Sounds worked fine.


What version do you use - mac or windows?

 
  • zeke
  • Megamind
  • Administrators
  • Join Date: 01-Nov 05
  • 472 posts

Posted 08 April 2010 - 08:58 AM #7

Problem with emails with "+" sign was fixed.

Chat with several operators - blocking added.

You can download updated version by the links above.

 
  • jobosales
  • Senior Member
  • Members
  • Join Date: 04-Nov 06
  • 3114 posts

Posted 08 April 2010 - 11:00 PM #8

In Live Help->Chat history, you cannot reverse the sort order for 'Earliest' even though there is an arrow to indicate ascending order.

Also, should the other columns be sortable and what is the empty statistics column for?

Bob
CS-Cart 2.0.14 (testing)

 
  • sh1nn3r
  • Member
  • Members
  • Join Date: 19-Nov 09
  • 85 posts

Posted 09 April 2010 - 01:41 AM #9

Anyone have a demo of this running so I can take a look at it?

 
  • Fleety
  • Member
  • Members
  • Join Date: 03-Mar 09
  • 46 posts

Posted 12 April 2010 - 09:02 AM #10

Well i'm happy about the Mac client, and have everything installed but have got something out of whack as i can't see an operator online when my user is connected. The Leave Message link isn't functional yet either so i guess i've goofed.

So far I have tested in most common browsers, results are consistant.
Posted Image

Has anyone else had this problem and figured it out?

Any pointers or guesses?

Fleety
Doing not dreaming
--------------------------

2.0.10
Genetically Altered Electro skin

 
  • RSW
  • Senior Member
  • Members
  • Join Date: 11-Nov 09
  • 175 posts

Posted 16 April 2010 - 02:56 AM #11

I have a quick question... when someone leaves a message, and you respond I assume that they receive the message at the email address that is show in the window, BUT what return address is used??? I can't find an email setting for the operators?
=======================
running on Apache 2 - CentOS

 
  • jobosales
  • Senior Member
  • Members
  • Join Date: 04-Nov 06
  • 3114 posts

Posted 16 April 2010 - 03:33 AM #12

It uses the address specified for "User department e-mail address" in Administration->Settings:Company. Not sure this is the best choice. It probably makes more sense to use the address specified for the Help/Support department.

Bob
CS-Cart 2.0.14 (testing)

 
  • RSW
  • Senior Member
  • Members
  • Join Date: 11-Nov 09
  • 175 posts

Posted 17 April 2010 - 08:41 PM #13

yes, that would probably make sense. Would be nice to be able to specify an account per operator as well..
=======================
running on Apache 2 - CentOS

 
  • rinx
  • Member
  • Members
  • Join Date: 21-Jan 10
  • 52 posts

Posted 19 April 2010 - 01:30 AM #14

Installed fine
On home page the picture of the agent when live and when offline dost show up
on all other pages it does

 
  • jobosales
  • Senior Member
  • Members
  • Join Date: 04-Nov 06
  • 3114 posts

Posted 19 April 2010 - 02:22 AM #15

Installed fine
On home page the picture of the agent when live and when offline dost show up
on all other pages it does

In Design->Blocks, check that the "Live Help" block is not disabled on the "Home Page" tab.

Bob
CS-Cart 2.0.14 (testing)

 
  • rinx
  • Member
  • Members
  • Join Date: 21-Jan 10
  • 52 posts

Posted 19 April 2010 - 02:43 AM #16

its active i see everything
Chat Support
(pic is missing on home page)
Leave message

 

Posted 29 April 2010 - 05:41 AM #17

I tried this and for the most part it works - thanks!

First question: during tests the person's name appears to the operator as "anonymous (IP ADDRESS)" but the operator's name appears correctly to the visitor. What is the purpose of a person entering their name if at our end it appears as anonymous?

Second question: how do I remove the whole live help sidebox when chat is offline? Kinda useless just to tell visitors, "Livehelp is offline."
Web development in progress with CS-Cart 3.x

 

Posted 05 May 2010 - 01:37 AM #18

Disregard my previous post - switched to Livezilla. More features and it just works out of the box.
Web development in progress with CS-Cart 3.x

 
  • ywalker
  • Senior Member
  • Members
  • Join Date: 25-Oct 09
  • 104 posts

Posted 15 May 2010 - 02:51 PM #19

Hi Zeke,

I have been evaluating livehelp software and was not going to take a look at CS-Cart's LiveHelp but changed my mind and installed on my demo site. I was pleasantly surprised and have decided to take a closer look.

Questions - I looked in the language file and based on all the variables it appears I should be able to see some indication when a person is typing ... is that for future?

How can I change the images displayed for online/offline - I looked in the livehelp styles and they are not there also checked all the live help files under addons, can not seem to find them.

I want to customize the background of my pop-up's; they appear to use site settings in styles.css, if I create my own classes for livehelp popups in which style sheets should I put them or is this in the js files?

I did a test session and the script/history of that session was not saved in admin, is there something I need to do in the desktop client to save sessions. I looked at the settings in admin and they appear okay.

Thanks for your help.
Yvonne Walker
VPS - WiredTree Hosting
CS-Cart 2.0.15

 
  • ywalker
  • Senior Member
  • Members
  • Join Date: 25-Oct 09
  • 104 posts

Posted 15 May 2010 - 10:41 PM #20

Never mind on the images Zeke, I found what I needed. Actually discovered how to place them any where I wanted without the block confinement.

I do have a odd thing happening when I click on the image to leave a message, it opens the pop-up but appears to open two of them, one disappears and the one to enter information stays on the screen.

I also found information in the code that seems to indicate you do have it coded to show indication when a site visitor is typing yet it is not showing in the desktop client, at least not for me.

The desktop client stored history of my test but not admin.

Thanks.
Yvonne Walker
VPS - WiredTree Hosting
CS-Cart 2.0.15