Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

SEO addon fails to install Rate Topic   - - - - -

 
  • pako
  • Junior Member
  • Members
  • Join Date: 04-Oct 06
  • 21 posts

Posted 15 November 2006 - 06:38 PM #1

Hello, I've got a quick question regarding the installation of the SEO addon. When I try to activate it I get the error message saying: "You're trying to use SEO addon, but it seems like no Apache web server or mod_rewrite module is installed on your server. SEO addon is disabled. Please check your configuration." I have Apache up and running so I know thats not the problem, and mod_rewrite is also activated. Any help getting this to run would be greatly appreciated.

 
  • Zyles
  • Senior Member
  • Members
  • Join Date: 06-Nov 06
  • 596 posts

Posted 15 November 2006 - 09:43 PM #2

Are you sure mod_rewrite is properly configured? Have you tried any other scripts? Do some basic mod_rewrite tests to see if it works.
Marketing tip:

Did you know a targeted e-mail marketing campaign can bring conversion rates up to 3.9%? By using reliable e-mail marketing software you can upsell to existing customers on a tight budget. If you are not using e-mail marketing you are missing out big time. I recommend and use Aweber.

 
  • jerky_man
  • Member
  • Members
  • Join Date: 31-Oct 06
  • 63 posts

Posted 16 November 2006 - 09:05 AM #3

I am also having the same problem. I have verified that mod_rewrite is installed and working properly, but the SEO module still doesn't work. Any help?

 
  • Zyles
  • Senior Member
  • Members
  • Join Date: 06-Nov 06
  • 596 posts

Posted 16 November 2006 - 10:01 PM #4

Have you tried contacting the support helpdesk?
Marketing tip:

Did you know a targeted e-mail marketing campaign can bring conversion rates up to 3.9%? By using reliable e-mail marketing software you can upsell to existing customers on a tight budget. If you are not using e-mail marketing you are missing out big time. I recommend and use Aweber.

 
  • ghsadmin
  • Junior Member
  • Members
  • Join Date: 01-Jul 09
  • 1 posts

Posted 01 July 2009 - 05:31 AM #5

I needed to modify the file /var/www/html/cscart/.htaccess

I had to modify the line:

RewriteBase /

to:

RewriteBase /cscart/

The /cscart/ relates to the installation directory of your cart.

The /var/www/html/ is the root directory for apache web sites. This path could vary depending on your os.

Cheers
Peter W.

 
  • aircomms
  • Junior Member
  • Members
  • Join Date: 30-Jun 08
  • 110 posts

Posted 01 July 2009 - 08:57 AM #6

The standard verification of SEO functionality does not work in some cases even if the SEO settings are correct on the server.
I have just commented this verification on the code.
I replaced the following part of code:
function fn_settings_actions_addons_seo(&$new_value, $old_value)
{
	if ($new_value == 'A') {
		$result = fn_http_request('GET', Registry::get('config.http_location') . '/catalog.html?version');
		if (strpos($result[0]['RESPONSE'], '200 OK') === false) {
			$new_value = 'D';
			fn_set_notification('W', fn_get_lang_var('warning'), fn_get_lang_var('warning_seo_urls_disabled'));
		}
	}
	fn_rm(DIR_COMPILED . 'customer');
	return true;
}
with this one:
function fn_settings_actions_addons_seo(&$new_value, $old_value)
{
	if ($new_value == 'A') {
		$result = fn_http_request('GET', Registry::get('config.http_location') . '/catalog.html?version');
		if (strpos($result[0]['RESPONSE'], '200 OK') === false) {
			//$new_value = 'D';
			//fn_set_notification('W', fn_get_lang_var('warning'), fn_get_lang_var('warning_seo_urls_disabled'));
		}
	}
	fn_rm(DIR_COMPILED . 'customer');
	return true;
}
in the "/addons/seo/schemas/settings/actions.post.php" file.
[quote]