Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

We do not want 2.0.10... Rate Topic   - - - - -

 
  • Noman
  • Senior Member
  • Members
  • Join Date: 29-Oct 07
  • 526 posts

Posted 22 November 2009 - 01:05 AM #1

... until all issues from the Bug tracker and sorted out! Give it another week or two please!

Thank you for your attention.
I'm Number 1, so why try harder?

CIA wannabe or having doubts and need some answers?
Spy Gadgets and CCTV Equipment

 
  • jegesmaci
  • Senior Member
  • Members
  • Join Date: 05-Oct 09
  • 403 posts

Posted 22 November 2009 - 01:20 AM #2

Amen! Please don't make our upgrades hurt.

Release Beta if you want, but then say it is beta.

Get feedback and then make any necessary changes.

Then you will be ready for General Availability.

Thanks,

Adam

 
  • jobosales
  • Senior Member
  • Members
  • Join Date: 04-Nov 06
  • 3114 posts

Posted 22 November 2009 - 01:30 AM #3

While I agree with the sentiment, you are always free to forego the update until others have tried things out. Even then, I always first update a backup of my site to see what might go wrong on my installation.

Bob
CS-Cart 2.0.14 (testing)

 
  • AJCABRERA
  • Member
  • Members
  • Join Date: 20-Sep 08
  • 63 posts

Posted 22 November 2009 - 03:21 AM #4

While I agree with the sentiment, you are always free to forego the update until others have tried things out. Even then, I always first update a backup of my site to see what might go wrong on my installation.

Bob

You almost feel obligated to upgrade since the version prior always has issues. I have't seen a stable release yet. I agree with the beta idea. Because that's what they really are. Don't be Microsoft and release half baked code. Over time, you'll lose confidence from regulars and in the long run you'll lose more. (money and respect). Call it what it is. Software isn't 100% but the last releases are 95% and that's not good enough. With or without a backup. Most, don't have enough skills to get themselves out of the first problem they see. And, you don't post any solutions. Even a small update is high risk.
Thanks,
Aj

BlueHost
Linux - Shared
Shared SSL
CS-Cart 2.12
PHP 5.2.11
MySQL DB

 
  • jobosales
  • Senior Member
  • Members
  • Join Date: 04-Nov 06
  • 3114 posts

Posted 22 November 2009 - 05:40 AM #5

You almost feel obligated to upgrade since the version prior always has issues. I have't seen a stable release yet. I agree with the beta idea. Because that's what they really are. Don't be Microsoft and release half baked code. Over time, you'll lose confidence from regulars and in the long run you'll lose more. (money and respect). Call it what it is. Software isn't 100% but the last releases are 95% and that's not good enough. With or without a backup. Most, don't have enough skills to get themselves out of the first problem they see. And, you don't post any solutions. Even a small update is high risk.

Thank you for reinforcing my point.

Beta testing could improve release quality but I still would not install without first testing against my data on my server. I worked in IT long enough to know that this step was crucial even with software which was beta-tested.

In the end, you really only have three choices: stay put until others have taken the arrows, forge ahead in the hopes that the benefits outweigh the problems or test to see the actual benefit/problem margin for yourself before committing to a gamble on your live site. People who are risk-averse or who lack the skills to get themselves out of situations are probably best served by staying put until the inital problems get sorted out.

Bob
CS-Cart 2.0.14 (testing)

 
  • scubagoo
  • Member
  • Members
  • Join Date: 22-Aug 09
  • 32 posts

Posted 22 November 2009 - 04:53 PM #6

Just to fix bugs though, no new features. Here's why

My total number of hits from 12 to 13th went from 332 to 39... and others got cut in half, the day of the upgrade So number of orders is obviously down even ought we're paying for advertizind and its not doing any good because orders can't go through. TOo many 404, too may payement processors not found. ALl that. I can't revert because of a bug in the system. They keep saying I installed a new 2.09 with no upgrades, and can't help me. No true.


11/15/2009 36 2 34 28
11/14/2009 35 1 34 31
11/13/2009 39 2 37 30
11/12/2009 332 287 45 41
11/11/2009 410 341 69 64
11/10/2009 351 296 55 52
11/09/2009 497 435 62 56

SO yes for the sake of money, progress, business we DO need something, anything.

Robert

 
  • IamJim
  • Junior Member
  • Members
  • Join Date: 24-Nov 09
  • 6 posts

Posted 24 November 2009 - 03:03 AM #7

Maybe you'all can help me.

a: Just downloaded the new "trial"

b: I have previous cart from last year

c: The 'jerk' I spent 3.5 months with...screwed me

d: Where are the danged version numbers found in the files of this thing? (sorry, I forget)

e: My sentiments also, as coming from being on MSFT and Borland dev teams back in the late 80's up until Win2K... No one should have to forgo the PAIN of someones new "mousetrap" pains....

Thank's in advance!!

 
  • brandonvd
  • is Super Awesome
  • Members
  • Join Date: 19-Dec 06
  • 2633 posts

Posted 24 November 2009 - 07:55 AM #8

Well I'm sure that everyone here will do their best to help you.

Sorry about the "jerk", that sucks.

I don't think the version number are anywhere. Maybe your config file? One way to find out is use:

index.php?version

Just put it at the end like

http://www.domain.co...dex.php?version

This will tell you what version you are using.

I'm not quite following you on the last bit, but I think you are just agreeing with everyone else.

I hope this helps,

Brandon

 
  • scubagoo
  • Member
  • Members
  • Join Date: 22-Aug 09
  • 32 posts

Posted 25 November 2009 - 05:20 AM #9

Thank you CS team!

I've already had a dramatic several fold increase in traffic, orders are increasing, pages are fast, the update installed without a hitch. Awesome

Thanks

 
  • IamJim
  • Junior Member
  • Members
  • Join Date: 24-Nov 09
  • 6 posts

Posted 25 November 2009 - 05:07 PM #10

Brandonvd, thank you very much for the reply... That command didn't show me this demo version...more than likely because I editied the home page already?

Maybe you can help me on this... as "the jerks" cart is no longer on and active domain, and these carts are "based on that"... so I can not get the cart live...to EXPORT and then import into the new one I just tossed up?

I have it still on the server...so all files and sql...but then again, a version from last year and it's a totally different interface in admin.

In other words...I know if I had the old version...I could just clone the DB somehow?

Thing is, I gave the guy a year to come clean and pony (settle up)... I think that's more than enough...and I think it is time to take my work and start selling.

Thanks again,

Jim

 
  • jobosales
  • Senior Member
  • Members
  • Join Date: 04-Nov 06
  • 3114 posts

Posted 25 November 2009 - 05:15 PM #11

You can find the version number in /config.php. Look for the following:
// Product information
define('PRODUCT_NAME', 'CS-CART');
[B][COLOR="Red"]define('PRODUCT_VERSION', '2.0.10');[/COLOR][/B]
define('PRODUCT_STATUS', '');

Bob
CS-Cart 2.0.14 (testing)

 
  • IamJim
  • Junior Member
  • Members
  • Join Date: 24-Nov 09
  • 6 posts

Posted 25 November 2009 - 05:37 PM #12

Jobosales, thank-you very much..

OK, the 'dead cart' on my server is: 1.3.5-SP3

This 'demo' is : 2.0.9

My present day battle is to IMPORT (from the dead cart) so please remember that there's no LIVE SITE to simply gain access via admin and EXPORT....as I have no way to bring it live...

So, is there any tricks or shortcuts anyone can reco please?

Thanks again all...just that I've been away from this cart since last fall.

 
  • clips
  • Aged Resident Loon
  • Members
  • Join Date: 14-Jan 07
  • 1650 posts

Posted 26 November 2009 - 03:20 PM #13

In the end, you really only have three choices: stay put until others have taken the arrows, forge ahead in the hopes that the benefits outweigh the problems or test to see the actual benefit/problem margin for yourself before committing to a gamble on your live site. People who are risk-averse or who lack the skills to get themselves out of situations are probably best served by staying put until the inital problems get sorted out.

Bob


YEP! We will stay put with 1.3.5 sp4 until 2 has all the "bugs" worked out. The problem is CS keeps coming out with so many changes that they appear to never fix bugs from previous releases. I had considered upgrading the first quarter of next year, but I'm just not sold on CS2 being ready for rookies like myself to battle through it.
Regards,
Jim

 
  • IamJim
  • Junior Member
  • Members
  • Join Date: 24-Nov 09
  • 6 posts

Posted 26 November 2009 - 03:32 PM #14

Yeah, that's where I am screwed...and feeling like a frigging hostage at this point. (sorry for venting) but it needs to be :D

The 1.3.5 SP3 was up and running fine... My frigging fault, is that I am a "trusting sole" and spent 3.5 months populating and building a site for "my guy" and which I think I netted not quite 700 for (at least I got something)

My big mistake, was I advised him about CS-CART and instead of Me BUYING (and then billing him) in the beginning, I suggested he PURCHASE it, ( as to cover my butt financially to start) and that seems to be a mistake for sure.

This 2.0.9 seems to be junk, I don't have frigging time in my live to play "labrat" anymore.

I came BACK HERE to get what I spent a lot of time last year...simply UP & RUNNING as being a NICE GUY, I figured I would wait to see if the jerk I spent all this time...ever ponied up....Never did, and last I heard from him was October 5th of 2008

All I simply want to do, is get my works...now...up and selling.

Now?? For the heck of it... and maybe you folks can help me out on this, as anyone successfully done a import of 1.3.5 to this NEW broken Arrow?

I have one other fact...I am witnessing also...and not liking what I see for sure :-)

Jim

PS added ??

Does anyone have a 1.3.5 Zip or install? Maybe that is all I need?


 
  • jobosales
  • Senior Member
  • Members
  • Join Date: 04-Nov 06
  • 3114 posts

Posted 26 November 2009 - 05:05 PM #15

If your 1.3.5 installation is not customized, things should be pretty straight-forward - many of us have upgraded our sites successfully from version 1.3.5 to some 2.0.x update.

The first thing your need to do is BACKUP! Both files and database.

You then need to do the upgrade from 1.3.5-sp3 to 1.3.5-sp4 using the upgrade package available at the file area of the help desk. Backup again after your upgrade.

Now you can upgrade to v 2.0.x using the instructions provided at http://kb2.cs-cart.com/upgrade135-20

Bob
CS-Cart 2.0.14 (testing)

 
  • IamJim
  • Junior Member
  • Members
  • Join Date: 24-Nov 09
  • 6 posts

Posted 26 November 2009 - 05:22 PM #16

Both files and database.


Bob, and thank you for the reply.

OK, I need to toss this out (as a question) to everyone...as here is why.

a: Since the original install a year ago in July, it's been only on my dedicated server.

b: When he never paid (and I also was doing a non-cart site for him) never comp'd either...I shut him off simply with WHM.... He ended up renewing the domain...whcih foes nowhere now...(see below...Guess What)

c: It's been awhile since I have thought about this even, but long story short is that a few months ago... In July for sure and also in September I know the DB existed....as I went in and snagged the SQL for the Country Codes etc...for another project. (just for all the countries)

So, I'd hop in with phpMyAdmin etc...

d: I grabbed a new domain, downloaded the 2.0.9 demo a couple days ago...and did the install (and figured I would get up to speed etc) and that's how I landed back on the forums. FIRST!!

e: Guess what? Today, (being a holiday) I figured...OK... Let's see if I can get this thing going....

The site files are all still there (always have been) yet will not work etc...as for reasons of dead domain and he more than likely removed as he's tossed it up @ name-services.com FOR SALE..

So, an hour ago... I hop into phpMyAdmin...and the frigging DB is totally gone?

I am sure most of you'all on this forum...have kept up registered versions...etc....but I am trying to figure out (as I know danged sure I never deleted it) where the HECK the DB went...that was attached to this account? (sigh)

Have you ever read anything of this sort?

Thx again,

jim

 
  • GT40Graham
  • Junior Member
  • Members
  • Join Date: 18-Oct 08
  • 25 posts

Posted 27 November 2009 - 08:44 AM #17

YEP! We will stay put with 1.3.5 sp4 until 2 has all the "bugs" worked out. The problem is CS keeps coming out with so many changes that they appear to never fix bugs from previous releases. I had considered upgrading the first quarter of next year, but I'm just not sold on CS2 being ready for rookies like myself to battle through it.


And so say all of us!

Regards,


Graham.

 
  • Weccop
  • Member
  • Members
  • Join Date: 04-Aug 09
  • 34 posts

Posted 28 November 2009 - 11:10 PM #18

Upgraded to 2.0.10 today and everything is working as it should be.

 
  • gabrieluk
  • Senior Member
  • Members
  • Join Date: 21-Jul 09
  • 133 posts

Posted 02 January 2010 - 12:07 AM #19

YEP! We will stay put with 1.3.5 sp4 until 2 has all the "bugs" worked out. The problem is CS keeps coming out with so many changes that they appear to never fix bugs from previous releases. I had considered upgrading the first quarter of next year, but I'm just not sold on CS2 being ready for rookies like myself to battle through it.

Hi Clips,
I agree with you.Is best to have an older version of software ,but that actually works,no fancy java,smarties...blablabla.Windows XP is a good example of an stable,older software.
I would like to share with you the only concern i have about 1.3.5 sp4:SECURITY.Are you in to it?Because i'm not.I think the only danger of using SP4 is vulnerabilities.Please let me know what u are doing in your shop about SECURITY.Also,i would like to propose to CS to call ALL 2.0 versions as BETA(testing in progress),and the other would be give REAL VALUE for the golden piece of code that sp4 IS.Please create a list with all the security fixes for this version,as it is the only one that actually works flaweslly.
Number 1

 
  • IamJim
  • Junior Member
  • Members
  • Join Date: 24-Nov 09
  • 6 posts

Posted 02 January 2010 - 12:14 AM #20

I 2nd the motion..

Labrats do not have to shell out real $$$ to get wiped out :cool: