Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Using SMTP settings for Google Apps Email Rate Topic   - - - - -

 
  • Trixman
  • Junior Member
  • Members
  • Join Date: 04-Sep 09
  • 30 posts

Posted 29 October 2009 - 02:42 PM #1

Anyone using Google Apps here for their email?

I do, and no matter the settings it doesn't seem to be able to work (get error messages when trying to send anything out).

The standard settings according to google would be:

smtp.gmail.com
user@yourdomain.com
password

Tried adding ports at the end of the smtp address (:465) but to no avail.

If I select 'php' it works fine, going through my server, but of course the 'sender' address is the default server mail which has nothing to do with my company.

Anyone get it working? (for clarity this is google apps mail, rather than gmail, where you use your own domain within gmail)

 
  • Justin Mason
  • Junior Member
  • Members
  • Join Date: 29-Oct 09
  • 7 posts

Posted 29 October 2009 - 10:07 PM #2

Hello Trixman.

I'm having the same issue. Subscribed!

 
  • Justin Mason
  • Junior Member
  • Members
  • Join Date: 29-Oct 09
  • 7 posts

Posted 02 November 2009 - 08:04 PM #3

I looked into this and it appears that its not available for hosted users. It does appear that SMTP works with normal gmail accounts, but they are rate limited.

Anyone else have any information?
CS Cart 2.0.8

 
  • Traveler
  • Senior Member
  • Members
  • Join Date: 02-Feb 07
  • 924 posts

Posted 03 November 2009 - 12:47 AM #4

While we are on the subject:

If I have mydomain.com and I want to use Googleapps email for only me2mydomain.com and not the other email addresses is that possible?

Then I would like to use Thunderbird as my email client.

All using the standard free edition.

Looking at the instructions it seemed to be an all (email addresses) or nothing setup.

But I may have been confused....

Version 4.9.2


 
  • Samj
  • Junior Member
  • Trial users
  • Join Date: 31-May 09
  • 1 posts

Posted 28 December 2009 - 01:54 PM #5

It appears that SSL is required for mail via google apps to work.
http://forums.kayako...pps-smtp-15469/
This may be an alternative:
http://www.google.co...e814d05e6&hl=en

I don't have an ssl certificate to play with yet though...

 

Posted 05 August 2010 - 03:14 PM #6

I don't know whether any of you are still stumped by this. I got it figured out and wanted to share this just in case it might help anyone.

First, read this knowledgebase article and make the changes to the code as detailed there: http://kb2.cs-cart.com/gmail

Then, in your Administration>Settings>Email choose SMTP for method and use these settings:

SMTP Host: smtp.gmail.com:465
SMTP username: email address of your Google Apps account
SMTP password: password of Google Apps account

Place a check mark for "Use SMTP authentication."

IMPORTANT: make sure port 465 is unblocked in your server firewall.

If you follow these instructions and it still doesn't work, post back here and I'll try to help, since I have it working on my site.

 
  • PelPub
  • Junior Member
  • Members
  • Join Date: 07-Sep 10
  • 2 posts

Posted 07 September 2010 - 02:45 PM #7

I had SMTP via Google Apps working with the following settings:

Host: gmail-smtp-in.l.google.com
SMTP username: my email address
SMTP password: my email password
Authentication: Unchecked.

But it's stopped working! It fails with a 'cannot authenticate' message (if authentication is checked) and a 'no such user' error if authentication unchecked.

I have tried the settings described above and the code changes in the knowledgebase (thanks kingsleypress) but can't make it work. I'm on 2.1.1, have tried reverting but that doesn't work. I am in the process of fiddling around with an SSL cert on the server so am worried that has had some effect though my host thinks not.

Any help greatly appreciated!

 
  • S-Combs
  • Senior Member
  • Members
  • Join Date: 09-Nov 06
  • 692 posts

Posted 07 September 2010 - 03:26 PM #8

This will effect some of you that are hosted on servers running the CSF firewall.

If the following setting in its configuration is activated it will block your ability to use outside SMTP servers.

SMTP_BLOCK

"This option will help prevent the most common form of spam abuse on a server that bypasses exim and sends spam directly out through port 25. Enabling this option will prevent any web script from sending out using socket connection, such scripts should use the exim or sendmail binary instead"
Secure Cart Hosting
[CS-Cart Optimized Solutions and Server Management]

 
  • PelPub
  • Junior Member
  • Members
  • Join Date: 07-Sep 10
  • 2 posts

Posted 09 September 2010 - 08:01 PM #9

Thanks S-Combs, I looked into this. No luck, SMTP_BLOCK isn't activated.

A major pain! Anyone else suffering from Google Apps for SMTP not working on their site?

 
  • CS-Carter
  • Junior Member
  • Members
  • Join Date: 07-Sep 10
  • 27 posts

Posted 10 September 2010 - 12:50 PM #10

Google Gmail now requires SMTP Authentication.

If Authentication isn't working it's a no go.

Also you can try using port 25 (with SSL), 465 (with SSL) or 587 (with TLS) as they are suppose to be working on SMTP also.

From Google:
Incoming Mail (POP3) Server - requires SSL: pop.gmail.com
Use SSL: Yes
Port: 995
Outgoing Mail (SMTP) Server - requires TLS or SSL: smtp.gmail.com (use authentication)
Use Authentication: Yes
Port for TLS/STARTTLS: 587
Port for SSL: 465
Account Name: your full email address (including @gmail.com or @your_domain.com) Email Address: your email address (username@gmail.com or username@your_domain.com) Password: your Gmail password
“The good man brings good things out of the good stored up in his heart, and the evil man brings evil things out of the evil stored up in his heart. For out of the overflow of his heart his mouth speaks.”

 
  • Guest_Unregistered_*
  • Guests

Posted 10 September 2010 - 04:02 PM #11

Have you tried unlocking the Captcha?


Visit https://www.google.c...m/UnlockCaptcha


http://mail.google.c...py?answer=78754

 
  • NaMo
  • Senior Member
  • Members
  • Join Date: 26-Jan 14
  • 199 posts

Posted 07 February 2014 - 05:49 PM #12

Hi there,

Has anyone resolved this?
We are still getting errors like this.

"Error Message could not be sent.
Mailer Error: SMTP Error: Could not authenticate."

Does not having SSL cause this problem?

We are using google apps email id and have provided the correct details to authenticate.
Any help would be greatly appreciated.

Regards,
NaMo

 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 12076 posts

Posted 08 February 2014 - 01:24 AM #13

You have to change the port number manually in the php mailer class. Cs-cart does not make this a configurable option from the admin.

EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • NaMo
  • Senior Member
  • Members
  • Join Date: 26-Jan 14
  • 199 posts

Posted 27 February 2014 - 01:06 PM #14

Hi tbirnseth,

Could you be a bit more specific regarding which php mailer class(in terms of file location)? :)

Regards,
NaMo

 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 12076 posts

Posted 27 February 2014 - 10:10 PM #15

For V2/V3 it's in lib/phpmailer/class.smtp.php
For V4 it's in app/lib/other/phpmailer/class.smtp.php

However, you can use the 'send_mail_pre' hook to set $mailer->SMTP_PORT to whatever you want which is what I would recommend

But the port should really be part of the smtp configuration screen.

EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • NaMo
  • Senior Member
  • Members
  • Join Date: 26-Jan 14
  • 199 posts

Posted 28 February 2014 - 08:55 AM #16

Hi tbirnseth,

I couldn't find the $mailer variable in the class.smtp.php.

But, will it work if I just modify the $SMTP_PORT found in the class.smtp.php and set it to the required SMPT_PORT?

Regards,
NaMo

 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 12076 posts

Posted 28 February 2014 - 10:33 PM #17

The $mailer variable is set in fn_send_mail() function. It is passed to the hook. It is a "class pointer" so you will not find it in the class code.

My belief is that you should hire a developer to do this for you. Anyone proficient in cs-cart and php should be able to do it for you in fairly short order.

EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3814 posts

Posted 04 April 2014 - 06:35 AM #18

Hello NaMo!

Thank you for the message.

To resolve the issue please try taking steps from the E-mails are not sent to the gmail account article of our Knowledge base. Please let note that for CS-Cart or Multi-Vendor of 4th branch, you should edit the file located in the app/lib/other/phpmailer/class.smtp.php directory of your CS-Cart or Multi-Vendor installation.

I hope this will help you.

---
Anastasiya Kozlova
CS-Cart Support team

Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • NaMo
  • Senior Member
  • Members
  • Join Date: 26-Jan 14
  • 199 posts

Posted 04 April 2014 - 07:21 AM #19

Hi Anastasiya,
Thanks for the response but unfortunately this didn't work.
When we turned on the SMTP authentication, then it pointed out that "
Message could not be sent.
Mailer Error: SMTP Error: Could not authenticate."didn't work and when we unticked it then we got the following error as attached in the screenshot.
We have also deleted the cache and have entered the corrrect details.

Kindly let us know what should we do.

Attached Thumbnails

  • email.PNG


 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3814 posts

Posted 04 April 2014 - 07:58 AM #20

Dear NaMo!

Hi Anastasiya,
Thanks for the response but unfortunately this didn't work.
When we turned on the SMTP authentication, then it pointed out that "
Message could not be sent.
Mailer Error: SMTP Error: Could not authenticate."didn't work and when we unticked it then we got the following error as attached in the screenshot.
We have also deleted the cache and have entered the corrrect details.

Kindly let us know what should we do.


Thank you for the screen shot attached.

As far as I see from your screen shot, SMTP authentication is not activated in your mail client. In this case I recommend you to take the steps from this article to learn more information on how to use Google's SMTP server.

I hope this will help you.
Thank you.

---
Anastasiya Kozlova
CS-Cart Support team

Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation