Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

2.0.4 Problems with pdf invoice? Rate Topic   - - - - -

 
  • Telemaco78
  • Member
  • Members
  • Join Date: 12-Sep 08
  • 89 posts

Posted 24 June 2009 - 09:55 PM #1

hi lads

I´m just asking to myself if I´m just the only one who has problems generating the pdf invoice....

Aparently it works fine it generate the pdf and ask for download it but when you open it ... The images are not showed at all (logo etc...), and also all the information of the invoice is dissorder, character with accents (spanish accents) are showed in lower case....

Is that a bug? Insatllation went right and all works but the invoices ...

Thanks

 
  • djuzapto
  • Member
  • Members
  • Join Date: 05-Mar 09
  • 135 posts

Posted 25 June 2009 - 10:23 AM #2

Dear.
I haven't got your solution, sorry.


PDF invoice don't generate for me.
I wait, i wait, i wait but never PDF printed.

May be a folder permission problem?

 
  • zeero6
  • Senior Member
  • Members
  • Join Date: 25-Jan 07
  • 649 posts

Posted 25 June 2009 - 03:10 PM #3

same here

HTTP error 401
Could not open URL http://www.xxxxxx.co...voice_logo2.gif you've specified.

Server responded with:

HTTP/1.1 401 Authorization Required
Date: Thu, 25 Jun 2009 15:13:51 GMT
Server: Apache/1.3.41 (Unix)
WWW-Authenticate: Basic realm="Protected Area"
Keep-Alive: timeout=15, max=255
Connection: Keep-Alive
Content-Type: text/html; charset=iso-8859-1

Version 4.9.3 SP1


 
  • Telemaco78
  • Member
  • Members
  • Join Date: 12-Sep 08
  • 89 posts

Posted 25 June 2009 - 07:54 PM #4

I dont think it would be because of permissions, I did installed as CS-CART instructions, all is going right.... PDF documents open with no problems and I have no any errors just instead the logo I got the shop name and I dunno it´s because that text I have instead the logo it´s too long all the text is moved

 
  • djuzapto
  • Member
  • Members
  • Join Date: 05-Mar 09
  • 135 posts

Posted 25 June 2009 - 10:17 PM #5

It's OK for me

I set writable permission to folder > "CSCARTFOLDER"/lib/html2pdf/cache

 
  • sky50
  • Junior Member
  • Members
  • Join Date: 19-Jan 09
  • 1 posts

Posted 30 June 2009 - 12:51 AM #6

Telemaco78

Did you ever get this error fixed with images on the pdf?

I had the exact same issue which I found the issue was that openssl was not enable on my server. Even if you have an SSL cert installed, you must have openssl enabled and running for the pdf to generate correctly with images.

Hope this helps.

Thanks
Sky50

 
  • kingmax
  • Junior Member
  • Members
  • Join Date: 28-May 06
  • 5 posts

Posted 25 July 2010 - 06:11 AM #7

I think that the problem should be caused by html2pdf.
This module don't support unicode characters.
For english characters, there is no problem.