Will Php 5.4 Or Greater Break Cs Cart 2.2.2?

Hi Guys, I'm needing to upgrade the php on a VPS and the only thing stopping me is that one of the stores is running CS-CART: version 2.2.2 PROFESSIONAL.

Currently our VPS is running 5.3.28 but I need to upgrade it to support some other apps. So, just wondering if upgrading the php will break the old CS Cart install? I suspect it will and that I might have to move it to another server until I can upgrade it.

Yes, you will get errors but you should be able to upgrade php and then add the following to your .htaccess file in 2.2.2 to keep using PHP 5.3.

AddHandler application/x-httpd-php53 .php .php5 .php4 .php3

Wow thanks! I've never heard of that before. So sorry for the dumb question; does the server need to have the older php libraries (5.3) still installed for CS Cart to access them?

They should be but ask your host to be sure.

So it turns out that php 5.3 has reached EOL. If the php is upgraded, 5.3x can't be accessed in any way. Bummer.

Might have to update the website.