What do these error messages mean?

These messages appear from time to time in both admin and front end.

They, aparently, are not creating any other problems than appearing.



Clicking on any object will load correctly and message disapears


[QUOTE]

Warning: file_put_contents(/home/www/mysite.com/web/shop/var/cache/cache_update_handlers.php) [function.file-put-contents]: failed to open stream: Operation not permitted in /home/www/mysite.com/web/shop/core/class.registry.php on line 172[/QUOTE]



cache_update_handlers.php permission set to 2777

class.registry.php permission set to 0664



Double checked permissions in VAR IMAGES SKIN CATALOG: All are set to 2777

[quote name=‘aerofan’]These messages appear from time to time in both admin and front end.

They, aparently, are not creating any other problems than appearing.



Clicking on any object will load correctly and message disapears







cache_update_handlers.php permission set to 2777

class.registry.php permission set to 0664



Double checked permissions in VAR IMAGES SKIN CATALOG: All are set to 2777[/quote]



Are the var/cache and var/compliled folder writable? 777?

Its trying to write to a file or folder however there is a permissions problem. Looks like it has something to do with the cache but I’m too new to CS-Cart to pinpoint it

[QUOTE]Are the var/cache and var/compliled folder writable? 777?[/QUOTE]



Yes both have 2777 permission



(FireFTP shows also “2” value for “SGID”)

If it says “Permission denied”, then it must be a permissions problem.



It might be because your PHP is in “safe mode” and does not execute commands like “move one file to another in the server’s filesystem”. Check your php.ini for “safe_mode” and “safe_mode_exec_dir”.



I guess it is a server side problem. Contact your hosting provider.

Thanks Indy,



Here is provider PHPINFO.PHP



phpinfo.php


[QUOTE]

“safe_mode” “Off”

“safe_mode_exec_dir” “no value”[/QUOTE]



Any other idea?

No idea, ask your hosting provider for help.

[quote name=‘aerofan’]Yes both have 2777 permission



(FireFTP shows also “2” value for “SGID”)[/QUOTE]





Can you change the 2 to a 0?