Website Shop is Slow

Hi All,



Im hoping someone can help me here.



We have 2 shops using Cs-Cart both on the same dedicated server on two independant domain names.



The 1st shop is nice and fast and literally has 1000’s of customers/orders within the database.



The 2nd shop is running pretty slow for some reason. This applies to both the frontend and the backend of the shop. This shop has about a 1000 customers which compared to the shop above is very minimal.



Could someone possibly advise me what could be going wrong here…



Regards

Tom

Could you post links to your shops?

Yeah, links…Or else how can we help you?

You did not mention what version are you running shops.



In case it is 135



then go to



admin.php?target=settings



then below Catalog



uncheck Use temporary tables during product search/catalog browsing (increases performance)



My shop on dedicated server runs x10 times faster.

Hi all,



Sorry was having a blonde day! haha



Ok here is the url for the shop. - [url]http://www.calosol.com/cart[/url]



The site is currently using Version 1.3.5 SP2 due to the fact its had a custom mod completed via the CS team.



The above shop is the one im experiencing problems with.



This is another shop on our same dedi server which you will see is running fine - [url]http://www.freshpets.co.uk/cart[/url]



This morning ive optimised the Database within CS Cart this has made no difference. The images are being stored in the “file system” location, other than that im exhusted with other options to improve the speed.



Thanks in advance.



Tom

Hi There,



Ive updated this check box. It was initially checked. Unfortunately this hasnt made any difference.



Regards

Tom


[quote name=‘Darius’]You did not mention what version are you running shops.



In case it is 135



then go to



admin.php?target=settings



then below Catalog



uncheck Use temporary tables during product search/catalog browsing (increases performance)



My shop on dedicated server runs x10 times faster.[/QUOTE]

I was trying to open site and got this with firefox


Reported Attack Site!

This web site at www.calosol.com has been reported as an attack site and has been blocked based on your security preferences.




[url]http://safebrowsing.clients.google.com/safebrowsing/diagnostic?client=Firefox&hl=en-US&site=http://www.calosol.com/cart/[/url]



other one worked fine


[quote name=‘tomupton’]Hi all,



Sorry was having a blonde day! haha



Ok here is the url for the shop. - [url]http://www.calosol.com/cart[/url]



The site is currently using Version 1.3.5 SP2 due to the fact its had a custom mod completed via the CS team.



The above shop is the one im experiencing problems with.



This is another shop on our same dedi server which you will see is running fine - [url]http://www.freshpets.co.uk/cart[/url]



This morning ive optimised the Database within CS Cart this has made no difference. The images are being stored in the “file system” location, other than that im exhusted with other options to improve the speed.



Thanks in advance.



Tom[/QUOTE]

I can’t get to your first site, Kaspersky is saying Trojan-Downloader JS.Gumblar.a virus. But after reading here could be a false positive.

Thanks for all your replies!



Well it looks like the site has been hacked! Ive identified code across the site which im cleaning up as we speak.



Thanks so much for identifying this for me!



Regards

TOm


yea my virus software blocked a trojan horse from your site:



Reported Attack Site!
This web site at www.calosol.com has been reported as an attack site and has been blocked based on your security preferences.

Attack sites try to install programs that steal private information, use your computer to attack others, or damage your system.

Some attack sites intentionally distribute harmful software, but many are compromised without the knowledge or permission of their owners.

Hi All,



I think ive cleared everything from the website. Its was a real nasty case of hacking.



The problem i am facing now is that the home page seems a bit slow. - [url]http://www.calosol.com/cart/index.php[/url]



All other internal pages are fine, as with the admin pages.



Have i missed something, or does it seem quick to load for you guys?



I have gone through every single page of the site and deleted the nasty code.



Thanks in advance.



Tom

Sorry Tom doesn’t look like you got rid of it.

Grrr back to the drawing board!


Hi All,



Im still trying to get to the bottom of this. It certainly looks like its just the homepage of my store which is causing the problems. All other pages seem to be ok.



Im lost for idea’s on what pages could have potentially been hacked and would be causing the slowness for this site.



Ive emailed CS via the helpdesk to ask them for some advice, still havent had a reply by.



My store is using 1.3.5 SP2 and im concerned that ive just seen there is a security patch avilable for download. We have had some custom mods done via CS Cart and my concern is whether if i patched the site would this knock out the Mods we paid for?



Any advice would be fab.



Tom

[quote name=‘tomupton’]… if i patched the site would this knock out the Mods we paid for?



Any advice would be fab.



Tom[/QUOTE]



You never know what will happen to custom mods… Make it offline Back it up first, test the backup. If you use CPanel on your hosting account, perform an additional backup just in case. 2 backups are always better than one. Test them if you’re able to see what’s inside. Disable custom mods if possible. Apply the SP4 and see what happens. With custom mods issues, contact the developer or come back to us. We are strong and ready. Have fun and good luck.

Thanks for the reply mate.



The custom mods were completed by Cs Cart themselves.



My main concern is why they left a file on my server called sp.php im not too sure whether this may have led to the breach?



Tom


Can you attach this file so we can see it? Remove passwords first if any.

Hi All,



Right i think ive got to the bottom of it! (phew)



After rooting through about 200 odd files, i identified that i had missed 1 file! Grrr.



Anyway if someone could check this now for me, that would be fab. You should notice the home page opens far quicker now.



Regards

Tom

p.s. Thanks to everyone who has given me some advice here, its much appreciated.

Your website is flagged as infected. You will need to contact Google to remove it. It comes up with:





Warning - visiting this web-site may harm your computer!



[url]http://www.stopbadware.org/reports/container?reportname=http://www.calosol.com/cart/index.php?target=products&product_id=6&sa=X&oi=interstitial&ct=stopbadware[/url]





And this is on both, IE and FF. DO something or people won’t be able to spend millions there :wink:

Thanks mate, i submitted a review to them earlier on today!



Just hoping it doesnt take weeks for them to remove it!



Tom


[quote name=‘Noman’]Your website is flagged as infected. You will need to contact Google to remove it. It comes up with:





Warning - visiting this web-site may harm your computer!



[url]http://www.stopbadware.org/reports/container?reportname=http://www.calosol.com/cart/index.php?target=products&product_id=6&sa=X&oi=interstitial&ct=stopbadware[/url]





And this is on both, IE and FF. DO something or people won’t be able to spend millions there ;)[/QUOTE]