Watermark add on doesn't work

Hi, I made a clean install of the last version (4,0,2) in a new REP (myshop.com/v2).



I activated the watermark add on and copy the following code in .htacces


```php

Rewrite watermarks rules



RewriteEngine on

RewriteCond %{REQUEST_URI} /images/(detailed|thumbnails)/*

RewriteCond %{REQUEST_FILENAME} -f

RewriteRule .(gif|jpeg|jpg|png)$ /homez.44/myshop/www/v2/index.php?dispatch=watermark.create [NC]


/Rewrite watermarks rules

```



Now, I can see the watermark on the thumbnails, but when I click on them, the big size img cannot be found.



Any idea to solve this ?



thanx

no ideas friends ?

We couldn't get it to work either… Just another bug…

We could not get it to work either.



Could not find in bugtracker so I posted it here…

http://forum.cs-cart.com/tracker/issue-4772-watermark-does-not-work-in-version-403/

I know it is probably minor compared to other issues, but it also seems like it should be an easy fix and one less bug we have to deal with and waste time on.

Must have broken in the 4.0.2 release. I used it in 4.0.1 without problems but I didn't like the way it worked so I removed it when I upgraded.

Can anyone else help CS-Cart understand why the watermark add on does not work? Here is the ticket…

http://forum.cs-cart.com/tracker/issue-4772-watermark-does-not-work-in-version-403/

I'm just not for sure what else to tell them.

I'm still trying to convince CS that the watermark add on does not work. If find that it does not work on you version can you please post on the bug tracker at…

http://forum.cs-cart.com/tracker/issue-4772-watermark-does-not-work-in-version-403/

…so we can let them know.

I used a transparent png and it worked for me right away.



Is your PHP compiled with the GD libraries?



http://ca2.php.net/manual/en/ref.image.php

I did finally get the png to work. The text still seems to be messing up. I did figure out if I had the addon installed but “disabled” it did not allow me to upload an image. I was trying to leave it off while I messed with it. The text still did not seem to work right.