Want to disable "in stock" in my store

In the store I’m configuring for my client, inventory will be managed offline. If a customer buys an out-of-stock product, management of that will be done by customer contact, etc.

So, I do a global update of (in stock == 0) and apply. When I go to the Products list page every product has (quantity = 1). On product details, each product has (In Stock = 1).

My admin settings (General) say (Allow Inventory Tracking == cleared checkbox), (Allow negative amount in inventory == cleared checkbox), (Show out-of-stock products == cleared checkbox).

Funny to me, the Admin home page says (In Stock = 1), but I don’t know what that “1” is coming from. It should be zero or be the same as the number of products in the catalogs, no?


try setting a “-1” quantity at global update

or you can have the inventory on and configured and then just remove the quantity code from the .tpl file

use design mode>at products>view.tpl> show_invetory=false

I did a -1 update to the store. I originally thought it meant “set to this value”, but now I see it means "adjust by this value.

Now the Admin home panel says I have one product out-of-stock. I click on the “1” and I just get the catalog page. I work through all the product summaries and all of them say “0” for In-Stock.

Just what do I do with the summary information, to act on it? Clicking about in the summary page doesn’t seem to do something.

If you don’t have any interest all in it, just locate the css file, and I think the class is called “strong in-stock” or just “in-stock” and I added “display:none” to that class so it no longer showed up. We had no interest in showing stock at any time so if you have the same situation, it is the sure way to remove it.

LarryU - Thanks for this post.