Value Changer Issue-Any Way To Limit The Quantity Number?


I have version 4.2.4. I only see the option for the value changer for quantity with the plus and minus.

I used to have a dropdown for selecting quantity in the old version. Is it still available in 4.2.4?

Currently, a customer can select any amount and if not enough in inventory they get a message. Is there a way to limit the quantity to the amount in stock?

I finally realized what customers were complaining about when they said they selected 3 of an item and it they were never added to the cart. That is because there was only 1 left. No problem with the old dropdown quantity selector. Any fix for this?



hi Bo,

Please try to change the following fields on the editing ptoduct page:

  • “Quantity step”
  • “Maximum order quantity”

    Best regards,

    WSA team

Please check this article:

eCom Labs,

Thanks for looking. It appears that even though you have 4.2.4 in the cart version. The only tab available for the instructions is 1.3.5.


[*]This article is available only for CS-Cart versions: 1.3.5


Previous to 4.X. There was an option to use the selection field dropdown or use the current method of selecting quantity. With 4.x, it appears the option was removed.

I may just relocate the availability statement closer to the Quantity box. Currently, it is located in my theme above the image and not close to where the quantity is selected.

Damir; the Maximum quantity needs to be = available stock. Not manually set. Thanks for looking.


Sorry, my bad

Please do the following:

  • Disable the Settings → Appearance → Use 'Value changer' for the Quantity field setting
  • Go to the Update product page and set the Quantity step setting to 1 (do not change other settings)
  • Save and check the result