URGENT: Store Won't Reopen After 2.1.1 upgrade

I just upgraded my store to 2.1.1 from 2.1.0 and now my store won’t reopen. I click on the “Open Store” link and it says that the store was successfully reopened, but when I go to my storefront I just get the Closed for Maintenance message. And so are all my customers!

Immediately after upgrading I got these warning messages in my browser:

Warning: strpos() expects parameter 1 to be string, array given in /home/xxx/public_html/core/fn.control.php on line 683

Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/core/fn.control.php:683) in /home/xxx/public_html/core/fn.init.php on line 401

(where xxx is my cpanel username)

Not sure what that all means but maybe that has something to do with why the store can’t be reopened.


OK well I decided to revert back to 2.1.0 and my store is back up again.

I feel quite frustrated but I suppose I’ll calm down here after a while. I only upgraded to get the (supposed) speed improvements of version 2.1.1.

I’ve gone ahead and applied the manual patch for speed improvement but honestly can’t really tell much difference.


Not sure about the errors, but I had the same issue with my store not reopening. I read on another thread about deleting the contents of my var/compiled folder so I did this and the store opened just fine.

I actually think the store was open, but was cached in the closed state. Whatever I guess, at least it worked.


Thanks for the response Brandon.

In my var/compiled folder I have three folders:




Is that what you had?

You just deleted those three folders?

If you delete the three folders they will just repopulate on their own so that is the easiest way to do it.

You also could just delete the contents. I think the only one that really matters is the customer folder, but you might also need to do the admin folder.


If you are trying to use the sqllite caching mode then there are issues…

You will need to clear your cache. You can clear the cache from the admin url by adding the parameter “?cc” to the end. Or (similar to above) you can manually delete the var/cache and var/compiled directories. Strongly suggest always doing them both together since you might have pages compiled with registry data.