Upgrading Multivendor To 4.2.4 Version

I am getting following error after upgradation to 4.2.4 version when i try to open the storefront:





Message



[color=#333333]Unknown column 'cscart_categories.level' in 'where clause' [/color]b[/b]

[color=#333333]SELECT cscart_categories.category_id,cscart_categories.parent_id,cscart_categories.id_path,cscart_category_descriptions.category,cscart_categories.position,cscart_categories.status,cscart_seo_names.name as seo_name,cscart_seo_names.path as seo_path FROM cscart_categories LEFT JOIN cscart_category_descriptions ON cscart_categories.category_id = cscart_category_descriptions.category_id AND cscart_category_descriptions.lang_code = 'en' LEFT JOIN cscart_seo_names ON cscart_seo_names.object_id = cscart_categories.category_id AND cscart_seo_names.type = 'c' AND cscart_seo_names.dispatch = '' AND cscart_seo_names.lang_code = 'en' WHERE 1 AND (cscart_categories.usergroup_ids = '' OR FIND_IN_SET(0, cscart_categories.usergroup_ids) OR FIND_IN_SET(1, cscart_categories.usergroup_ids)) AND cscart_categories.status IN ('A') AND cscart_categories.level <= 3 ORDER BY cscart_categories.position asc, cscart_category_descriptions.category asc[/color]

Error at

[color=#333333]app/Tygh/Database.php, line: 677[/color]

You can check the link aquanta.in/dev_test to check all errors or the attached screenshot

Could anybody please help me out?



Thank You.

Screenshot from 2014-12-19 13_39_44(1).png

Good day,



Please use phpMyAdmin and add the following column to the cscart_categories table



Name: level

Type: INT

Length: 11

Default value: 1

Attributes: Unsigned



It should help

This worked…But now i am getting this error:

Message



[color=#333333]Table 'aquanta_dev_test_db.cscart_hybrid_auth_providers' doesn't exist [/color]b[/b]

[color=#333333]SELECT * FROM cscart_hybrid_auth_providers WHERE 1 AND status = 'A' ORDER BY position;[/color]

Error at



[color=#333333]app/Tygh/Database.php, line: 677[/color]

Screenshot from 2014-12-19 15:20:00.png

Try to reinstall the Social login add-on

But the problem is i cannot access the admin panel only.It is giving me the same error.

[quote name='madhuri' timestamp='1418985300' post='200341']

But the problem is i cannot access the admin panel only.It is giving me the same error.

[/quote]



Please use phpMyAdmin, find the cscart_addons table, find the hybrid_auth line there and set the status value to D for this module. Then clear the cache and check the result,

Thanks this worked for me…

[quote name='madhuri' timestamp='1419068857' post='200417']

Thanks this worked for me…

[/quote]



You are welcome!