Upgrading A Very Old Cs-Cart

Hello;



I'm trying to upgrade a very old cs-cart - 2.14-Community



In upgrade center, I click install upgrades, but get a blank screen



This is in the error log:



[Sun Jun 14 14:47:58.566456 2015] [:error] [pid 19641] [client (my_ip):52245] PHP Strict Standards: Declaration of Templater::display() should be compatible with Smarty::display($resource_name, $cache_id = NULL, $compile_id = NULL) in /var/sentora/hostdata/jvcrms/public_html/northlandoceanridersclub_co_nz/cart/core/class.templater.php on line 28, referer: http://www.northlandoceanridersclub.co.nz/cart/bdHisDcmo.php?dispatch=upgrade_center.manage




Im running Sentora Control Panel, PHP 5.5.9

Does your CS-Cart 2.0.14 work with PHP 5.6.9 ???

Not very well, submitting an order displays a blank page, same as logging in.



Unfortunately, this instance of cs cart was never upgraded from initial install :(

[quote name=‘modcar’ timestamp=‘1434360621’ post=‘218741’]

Not very well, submitting an order displays a blank page, same as logging in.



Unfortunately, this instance of cs cart was never upgraded from initial install :(

[/quote]

I suppose the problem with upgrade is you PHP version.

If I were you I would just import catalog/orders/users to the latest version. It would be easier to make changes in new 4.3.2 than upgrade from 2.0.14

Please note that there may be some incompatibilities in CSV format, so you will need to manually make changes in CSV.

[quote name=‘modcar’ timestamp=‘1434360621’ post=‘218741’]

Not very well, submitting an order displays a blank page, same as logging in.



Unfortunately, this instance of cs cart was never upgraded from initial install :(

[/quote]



When I was upgrading from 2x I did this on localhost with wampserver were you can change in between php versions easily. Had to change few times as what worked on 2x did not work for 3x and so on… Best is to like imac says do import, have clean db…

[quote name='imac' timestamp='1434363295' post='218757']



I suppose the problem with upgrade is you PHP version.

If I were you I would just import catalog/orders/users to the latest version. It would be easier to make changes in new 4.3.2 than upgrade from 2.0.14

Please note that there may be some incompatibilities in CSV format, so you will need to manually make changes in CSV.

[/quote]



Is it easy enough to export catalog/orders/users to csv?

[quote name='modcar' timestamp='1434364993' post='218762']

Is it easy enough to export catalog/orders/users to csv?

[/quote]



Can not say for sure. There could be some issues.

First you should export products/users/orders from your store and import it to 4.3.2 - than check if everything is imported correctly, if not than try to check required fields for import.



You can also contact tech support via Help Desk.

[quote name=‘modcar’ timestamp=‘1434364993’ post=‘218762’]

Is it easy enough to export catalog/orders/users to csv?

[/quote]



Since the csv with orders does not contain user IDs, all orders and users will be messed up!



Try to set older php version via .htaccess

[quote]

[color=#282828][font=arial, verdana, tahoma, sans-serif]Is it easy enough to export catalog/orders/users to csv?[/font][/color]

[/quote]



eComLabs are right, it is bad idea.

database can be moved to latest version only via Upgrade center and Store import and this procedure should be done on local installation (as Darius advised).



if you have problems with the upgrading, our specialists can help you to update the site so please don't hesitate to contact us.



best regards,

WSA team

Our team can also perform the upgrade on the local server and demonstrate the result to you. Feel free to contact us

In some cases you should make sure if you really need old orders and whether the money you are going to invest in transferring these orders worth it. What I say is that may be you can skip orders import and only import you catalog & customers to the latest version, and than in case you really need order a service to import orders from your old store.

But of course that depends on your requirements.

I would get eComLabs or W$A to give you a quote.

They can be trusted with access to your server.

This export/import CSV can really mess with your head.

Thanks for your suggestions, the store only has 10 products, 11 orders and 9 users. Have convinced my client to start again :)

Oh dear, so we will need to now run our v2 store (cant be upgraded) on a different server to v4 store to get the most out of v4.x.x…

[quote name='remoteone' timestamp='1435308997' post='220467']

Oh dear, so we will need to now run our v2 store (cant be upgraded) on a different server to v4 store to get the most out of v4.x.x…

[/quote]



Why do you think so? 2.x, 3.x and 4.x versions work correctly on our demo server

I thought 2.X and 3.x couldn't operate on higher versions of php.

Your hosting may support this feature:

I have the same problem as the original post stated. Where do I even check the logs? _logs folder is empty

After upgrading to 2.0.13 the screen goes blank and you cant rollback. :(

[quote name=‘Fedor’ timestamp=‘1435648824’ post=‘220963’]

I have the same problem as the original post stated. Where do I even check the logs? _logs folder is empty

After upgrading to 2.0.13 the screen goes blank and you cant rollback. :(

[/quote]



Could you please provide us with the temporary FTP access to this store?

So it appears that our main income generating store using v2.1.4 will not run correctly on PHP 5.4 and above.

We need to update our server to PHP 5.4 soon as a new update to a particular software (not cscart) requires PHP 5.4 or later.

We also have a v4.3 store running on the same server, so it would be good to jump straight to PHP v5.6



Perhaps there is some guide to the mods needed to make cscart v2.1.x compatible with PHP 5.6. ?

Especially since PHP 7.0.0 is now in Beta.