upgrade issue with 2.2.1 to 2.2.2

Just attempted the update to 2.2.2 and once it was complete all the styling was gone on the front of the site and also on the admin side.

I found a htaccess file in skins that had the following:

php_flag engine off

deny from all

Allow from all

Options -Indexes

I deleted that and looks like everything works. Has anyone else had this issue or know if I will run into problems with deleting the text in the file?

Did you try clearing you cache?

Also, if you have Smartoptimizer code installed, you might want to clear its cache as well.


The 'look' is all off when I upgrade to 2.2.2. The main window is moved off screen to the right (the top menu bar stays as it is.

The Submenus Adminstration, Settings and Design are off too. Now underneath each other and not clickable anymore.

I tried it a few weeks ago… same result. Had hoped it was fixed by now. I reverted back to 2.2.1 of course.

Showstopper !

Just clear your browser's cache/history and it will be all fine.




Tried that and it messed things up even more. I barely could find the ‘revert’ action now, since everything was displayed as a long LIST of keywords… no graphics at all anymore.

I am extremely reluctant to keep trying. Cannot afford to have the shop closed or worse… destroyed :-(

First time this happens, and happy with CS-Cart thus far, but this is not helping my confidence.

[quote name=‘Navvie’ timestamp=‘1316979321’ post=‘122268’]

I am extremely reluctant to keep trying. Cannot afford to have the shop closed or worse… destroyed :-(


Due to the variety and complexity of everyone’s servers, upgrading is a potentially dangerous thing.

  1. Backup Backup Backup - You should be doing regular backups anyway, but do one just before the upgrade

  2. DO NOT. DO NOT upgrade a live site. Clone your site and database and try on that first

  3. If you are within your upgrade period. Contact CS-Cart. They are usually more than happy to help with upgrades.

Try a different browser or something. That definitely sounds like it is your browser's cache. If you are using FF, just clear all your history/cache.

From everything you are describing, it definitely sounds like a cache issue.