Upgrade from CS-Cart 3 to 4.0.2 gives 404 page not found error

Hi, i've copied CS-Cart v4.0.2 into a sub folder of my current CS-Cart v3 website. I've changed the permissions as instructed, see below.



chmod 666 config.local.php

chmod -R 777 design images var

find design -type f -print0 | xargs -0 chmod 666

find images -type f -print0 | xargs -0 chmod 666

find var -type f -print0 | xargs -0 chmod 666



When i go to www.mydomain.com/csart4/install/ i get the CS-Cart message"Oops!

We were unable to find what you were looking for."



What am i doing wrong?



Thanks for any help

Maybe check with your host… I think for some servers you might need 644 instead of 666.

For anyone else with this problem CS-Cart support did the following “…install directory had 777 permissions. I changed them to 755…” which fixed the issue.

Bringing back this thread from the dead because it solved my problem… I'm installing a test version of v4 and the install directory would not load… Found a website called “Redirect Detective” which informed me that it was giving me a 404 error… so a google search led me to this thread about changing install to 755… problem solved.



Thanks