Upgrade From 4.3.1 - 4.3.2 Fails Silently

When I attempt and upgrade from 4.3.1 to 4.3.2 the upgrade runs, then the popover appears and seems to be running (message changes), then the popover message box disappears and the Upgrade Center page is unchanged. Checking the version I see the upgrade did not happen.

More specifically I see "Processing" in the popover message box then "Upgrade progress" with sub-message "Backing up data for cscart_products_categories". Then the popover message box goes away with nothing changed.

I did try a database backup using Administration | Backup/Restore and this worked fine. I also checked server error logs and nothing is shown.

The failure happens after roughly 3:20 (380 seconds) so considerably past the 120 second PHP execution timeout or default Apache timeout (I'm not sure of the actual Apache timeout in my host).

Any help is greatly appreciated.

To check server settings go to Administration->Logs->Select "PHP information" from gear icon dropdown menu

Also see this post http://forum.cs-cart.com/topic/41876-trying-to-upgrade-from-431-to-432/

Thanks Tool, good ideas there. Unfortunately none solved my problem.

It appears - looking at core_log.txt - that the upgrade always stops at "backup files and Database". In fact, backups using Administration | Backup/Restore also quietly fails when I back up both files and database. They works fine when I backup the database only.

I tried setting all var/cache, var/backups, and /var/upgrade folders to open permissions, changing the compress setting in App.php (per the other post), resetting ownership recursively for all project folders, clearing out the /var/upgrade folder (except for restore.php, which was required). In all cases the upgrade stops before finishing with no obvious error. It does seem to consistently stop on or after "Backing up data for cscart_products_categories".

So, I'm thinking this is a backup issue and will start looking at it from that perspective, but any other suggestions are most appreciated.

For a 4.3.1 -> 4.3.2 upgrade, check the file: var/upgrades/upgrade.log. It probably ends on backup. If so, follow the instrucitons here for commenting out the backup (but do your site and DB backups manually FIRST)


You should also check the Apache configuration value for Timeout. It should be set to 300 (seconds) or higher. Some hostings set this to an unrealistically low value.

But most likely, you will have to do the comment discussed in the other post and you will have to do this for the next upgrade (4.3.3) as well.

And I'd suggest you search the forum for solutions before posting new threads.

I have this same problem and tried commenting out the compress in the app file, but no luck.

You'll have to describe in more detail exactly what steps have completed and where things are at when you believe it's failed. Have you checked the Timeout value in Apache (note this is wall clock time for last PHP output to apache).

It fails in the first part when it's trying to backup. something about backing up tables. I deleted all info in log, but it writes nothing new there.

Also, using standard shared hosting at hostgator. I'd assume this upgrade is meant to run on standard unix webserver config.

Did you apply the change from link provided in message #4 above? That will disable backup during upgrade.

Yes, I disabled the backup

Yes, I disabled the backup

It fails in the first part when it's trying to backup

Doesn't sound like it.

...and don't assume anything on shared hosting.

Here is the message. Sometimes it fails on different schemas, but it always fails and then takes me back to the upgrade center where I get the install button to install the version that just failed to install

You can error screen shot at url below


Did you try this instead of commenting out the code?

Open the app\Tygh\UpgradeCenter\App.php file and replace:

$backup_file = DataKeeper::backup(array(
                'pack_name' => $backup_filename,
                'compress' => 'zip',
                'set_comet_steps' => false,
                'move_progress' => false,


$backup_file = DataKeeper::backup(array(
                'pack_name' => $backup_filename,
                'compress' => false,
                'set_comet_steps' => false,
                'move_progress' => false,

Also in the config.php file replace:

define('DB_ROWS_PER_PASS', 40);


define('DB_ROWS_PER_PASS', 4000);

Hi, thanks for response.

I tried both this: define('DB_ROWS_PER_PASS', 4000);

and this: $backup_file = DataKeeper::backup(array(

'pack_name' => $backup_filename,
'compress' => false,
'set_comet_steps' => false,
'move_progress' => false,

Make no difference. Still fails. error is usually difference each time, but still while the progress bar is up:

Upgrade progress

Backing up data for: cscart_shipping_descriptions

Then, it goes back to the upgrade center with the install buttuon.

You're on shared hosting, right?

If so, you are probably either exceeding memory or time limits imposed by your hosting.

First check your error_log file that should be in the root of your store. If nothing there about timeout or exceeding memory, contact your hosting and have them check your Apache logs to see if they can identify the problem

And also, if it is returning to the upgrade center, then the issue is NOT with an Apache Timeout but instead with exceeeding either a PHP resource setting or one imposed by your hosting.

Quick one please. It's also possible to change the PHP resource limit, correct? With no other side effects involved? 1.gif

Which resource limit? Generally, the answer is yes, but it's not absolute.