Upgrade From 3.0.6 To 4.1.4 Store Import Stalls

Theoretically this should work out of the box but guess what…lol

Installed my shiny new 4.1.4 in a folder on the same level as my current store.

Activated the Store Import add on.

Ticks along nicely until it gets to it's now almost infamous stumbling block.

[color=#282828][font=arial, verdana, tahoma, sans-serif]It gets to 'Converting orders' then just sits there like a lump.[/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif]CS-Cart live help says it can take hours.[/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif]I waited an hour at the stumbling block then gave up.

There are only 500 orders recorded. [/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif]The 'bugs' in this add-on were supposedly fixed after 4.0.3[/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif]Does anyone know of any tweeks ?[/font][/color]

Any particular reason you're not upgrading to 4.2.2?

I let my prolongation lapse back in April and 4.1.4 is the

highest version I have available in my file area.

I do not wish to pay for further prolongation at this stage.

Kingsleypress. I seem to recollect that you went from 3.0.6

to 4.1.4 without any problems ( or was it another 4.1.x ? )

Half your luck. I have wiped and tried 3 times now.

Try optimizing the v3 database first. You can do it right in the v3 admin.

Then let the import process run overnight - walk away from it, so you are not tempted to stop it before it's complete.

The bottleneck is probably the memory you have available for your mySQL database server, and it's just taking a long time.

Same thing for me, but submitted a ticket and ggot the dreaded “heavily loaded at the moment” message.

when the store import starts it does nothing, just times out on validate. Blue install bar doesnt move at all, just nothing, after about 10 minutes is stops and goes back to store import screen.

My database size is 357,410,393 bytes and I had cleared all logs/abandoned carts and had no statistics addon .

Var - Skins- images are set to 777 and config.local is 666

Any ideas.


Magpie Don.

What size import was yours and how long do you remember it had taken to complete ?

My db is only 20 meg and my images directory is over 1 gig.

I just sent a message in the Support help centre with these specs asking

guess how long it might take with these specs.

If it is just a waiting game then I can wait.

Having another go but this time it has dawned on me to ignore the static looking

progress bar and watch it via cpanel. Yes I 'should' have thought of it before.

It is happening as my physical disk space usage and db size are increasing.

Now just waiting and logging in to cpanel to watch the progress.

Well…it stalled at 'Converting Orders'. I watched the file sizes go up via cpanel

then they just stopped increasing.

Pulled the plug after 3 hours of no activity in cpanel.

All the files appear to have been transferred and the site functions.

A bit slow but maybe that's because it's in a folder.

I have sent a ticket to Help asking for a quote to check it out.

If I get tired of waiting…

Can I pack the live store into a folder at root then

move all the files out of my new store to root ???

Well…I got tired of the time lag with support and had a go.

The 4.1.4 store was running fine ( in a folder ) and fully populated with my 3.0.6 store data.

I packed all the 3.0.6 root files ( except the folder with new store ) into an 'OLDSTORE' folder

and moved all the 4.1.4 files to the root.

Maybe I forgot some fiddly little edit or something but the new store was a no go.

I deleted all the new files and moved my old store files back to root.

It still works…WHEW !! So it's back to square 1

I am now thinking of trying something else.

[size=5]PLAN B

Pack up all the root files into an OLDSTORE folder.

Unzip all the new store files directly in root ( as in a fresh installation ),

install 4.1.4 there THEN do the Store Import.


Change your VPS mode of PHP from suPHP to DSO

DSO was the only PHP config that didn't timeout for us



I have tried 5 times now but there is something I am missing and

the so called Knowledge Base does not cover my situation.

I have decided to stick with 3.0.6 until they retire my legacy server.

It's just all too hard for me and I can't afford CS-Cart support