Upgrade fails 2.1.4 to 2.2.1

Hello All,

I wanted to upgrade the cart today, went to http://url.com/admin.php?dispatch=upgrade_center.manage and clicked on Install - no response, got a blank page. The url in the address bar was: http:/url.com/admin.php?package_id=55027&md5=e001eb1ea86041c0b72825ee48f5d9c7&dispatch%5Bupgrade_center.get_upgrade%5D=%D0%A3%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0

Asked the hosting support whether the upgrade module hits the mod_security - the answer was no. Apache logs do not show any errors.

Usually when initiating an upgrade the card downloads the upgrade package as .tgz to the following folder var/upgrade/ however the only thing a found there is packages.xml. Permission set as 777.

Any suggestions apart from contacting the cs-cart support & pay the money :) ?

Pleasae Help…

Many thanks!

Clear our your var/upgrade directory and “refresh upgrade package list”. If it still fails, tell us the contents of the var/upgrade directory.

tbirnseth, thank for the reply. I cleared the var/upgrade directory, refreshed upgrade package list. packages.xml appeared again in the the var/upgrade directory. I tried to install the upgrade - still the same problem. The 'upgrade' dir contains packages.xml only.

That's the only file until after the upgrade is downloaded.

I would double check your PHP error_log file and see if you are getting any errors causing your problem. Otherwise it's probably a helpdesk issue.

Unfortunately, the error log file is also empty :(

Empty would be very unusual.

Sorry, but can't help via the forums. Have communicate what I know to check. But you're into a debug situation that you either need to go through or hire someone else to do it for you.