Upgrade Error

The site I’m working on recently got hacked so we’re upgrading and correcting some issues. I had the db restored to be working correctly and went to do the upgrade and now the install is stuck. Any help would be awesome. Thanks.



[url]http://dev.tigerlilycollections.com/tigeradmin.php[/url]

Sounds like you restored the database with a version older than the files.



Your files appear to be from v2.1.0. What version was the database from?



Running the query below will add the missing table to your database but there will probably be a bunch more errors after that.



```php CREATE TABLE cscart_companies (

company_id mediumint(8) unsigned NOT NULL auto_increment,

status char(1) NOT NULL default ‘A’,

company varchar(255) NOT NULL,

address varchar(255) NOT NULL,

address_2 varchar(255) NOT NULL,

city varchar(64) NOT NULL,

state varchar(32) NOT NULL,

country char(2) NOT NULL,

zipcode varchar(16) NOT NULL,

email varchar(128) NOT NULL,

phone varchar(32) NOT NULL,

fax varchar(32) NOT NULL,

url varchar(128) NOT NULL,

timestamp int(11) NOT NULL,

profit_margin varchar(1) NOT NULL,

categories text NOT NULL,

shippings text NOT NULL,

logos text NOT NULL,

PRIMARY KEY (company_id)

) ENGINE=MyISAM DEFAULT CHARSET=utf8; ```You will be better off replacing the files that were changed by the upgrade so they match your database then start over… You can find those files at

/var/upgrade/upgrade_2.0.15-2.1.0.tgz/backup/

Select the upgrade version that matches your database

I did restore the db but it was done prior to upgrading the system. I’m actually not 100% sure what the version is to be honest. :confused:



Also, the table actually is in the db. I double checked that before posting to the forum. I’m not sure why it’s not recognizing it. It created it when I did the upgrade, but then it says it can’t find it. Any ideas? Or any other options?