Upgrade 4.1.4 To 4.1.5

Hi everyone in the forum,

I started the update process from version 4.1.2 but in version 4.1.4 it returns me the notice "Unable to decompress file".

I followed the instructions of cs-cart help desk:

Another solution is to unpack the upgrade package manually and modify the upgrade script a bit. Take the following steps:

1. Click the Install button and wait for the decompress error to occur.
2. Copy the var/upgrade/uc.tgz file to the var/upgrade/upgrade_4.2.3_ultimate-4.2.4_ultimate.tgz directory and extract it via cPanel.
3. Open the app/controllers/backend/upgrade_center.php file and replace this line:

if (fn_uc_get_package($_REQUEST['package_id'], $_REQUEST['md5'], $package, $uc_settings, $backend_files) == true) {
with this one:

if (1) {
4. Run the upgrade again.
5. Revert the changes in the
app/controllers/backend/upgrade_center.php file once the upgrade is installed.

but it worked up to version 4.1.4

on the next attempt it returned me the notice "Unable to decompress file".

Someone who has encountered this issue?

From the help desk they give me the above solution. Nothing else.

The store import addon which I tried didn't work. It needs at least 4.2.1 version, so why in marketplace site, in addon page they write:


This add-on is available for CS-Cart only. Multi-Vendor is not supported.

The add-on can import data from:

CS-Cart Professional 2.2.4 - 3.0.6
CS-Cart Ultimate 3.0.1 - 3.0.6
CS-Cart 4.0.x, 4.1.x, 4.2.x
CS-Cart 4.3.x and 4.4.x older than the version to which you import the data

The add-on can't import CS-Cart Community Edition stores.

Make sure Phar and ZipArchive are installed on server.

The answer of the hosting company is yes is installed Phar and ZipArchive on server. Otherwise how the previous upgrade 4.1.2 to 4.1.3 and 4.1.4 was made?

I can't remember which version but CS made a change in the use of compressing/decompressing.

In a new attempt to upgrade from 4.1.4 to 4.1.5 now it returns me a white page. So I opened the error log and it has the below errors. What about these errors?

[23-Feb-2018 01:33:06 Europe/Istanbul] PHP Warning:  Error while sending QUERY packet. PID=1896 in /home/xxxxxxx/public_html/demo/app/Tygh/Backend/Database/Mysqli.php on line 79
[23-Feb-2018 01:33:08 Europe/Istanbul] PHP Fatal error:  Allowed memory size of 1073741824 bytes exhausted (tried to allocate 32 bytes) in /home/xxxxxxx/public_html/demo/app/Tygh/Database.php on line 636

Is someone knows what I have to do? I have a WHM hosting pack so I tried to increase these:

  • max_execution_time from 120 to 800
  • max_input_time from 120 to 800

but I have white page again :? :-( :?

I have spent three days for this update how many days more?


Increase memory to 512mb.

Nothing new. White page again with memory limit to 512.

[content removed]

First, make sure you do NOT have the debugger turned on (I.e. no define('DEBUG', true)) anywhere in config.local.php or local.conf.php.

The debugger tries to capture/log all sql requests and chews up large amounts of memory for sql intensive operations (like an upgrade).

Looks like you already have 1024M set as your memory limit and it's being honored. So my guess is you have the DEBUG constant set.

max_allowed_packet is 32M

the define('DEBUG', true is in comments

I misread your byte size in the error message so that was my bad.

1024mb is more than enough memory so there is something wrong if you're using more than that.

The code in the error message pertains to database error logging so you need to find out what's wrong with the database.