Uncheck "notify Orders Department" By Default Under "status"?

Is there a way for when I switch an order from processed to shipped etc, that it does not automatically check the “Notify Orders Department” box? I know it shipped, because I shipped it, I don't need an email telling me what I already know =) Im on 4.1.2. Thanks!

Hi,



I got this from cscart support and it works OK in my 4.1.4 store.



In order to make the Notify customer and Notify orders department check boxes clear on the Orders > View orders page and on the editing order page please replace the following part of code:







with this one:





and replaced the following line of code:





with this one:





in the select_popup.tpl file located in the /design/backend/templates/common directory of your CS-Cart installation.



You just need to remove checked=“checked” from the lines that you don’t want checked by default.



Remember to clear the cache to see the change.

Will this wok for the “supplier notify” check box?

Yes, I think so but you need to edit the lines just after these ones in the same file and with the same change that are for the supplier checkbox.

Hello guys!

I tried the method Pbraz suggested on ver. 4.2.3, but nothing changed…

I read the source code, it seems fine, minor changes in the current version, but the box is checked no matter what…

I also tried to change the checked=“checked” to checked=“unchecked”, but nothing happened.

I am confused, the code seems to be just fine, but …

Any suggestions?

Make sure you clear the cache.

I did, don't worry about that.

I googled about that and i it seems that what you suggested should work fine, “in order to have a checkbox uncheck you must not write the checked value at all, by default it is unchecked”. So you were right, but it doesn't work for some reason…

Only thing I can suggest is to look in var/cache/templates/backend and find the select_popup.tpl.php file and delete it (or change name) then the updated file will be added to the cache next time it is called. The .php file will have a random text and “tygh” prefix.



For example something like



1788921a9fg89cd20464102554cff19fbf18ae.tygh.select_popup.tpl.php

I found that file but i didn't delete it I removed the checked=“checked” part, SUCCESS!!! thanks a lot man!!!

I tried this and it is working for Notify Customer and Notify Orders Department but not for Suppliers.

I edited /design/backend/templates/common/select_popup.tpl and removed checked="checked" from name="notify_vendor" and cleared cache, and did ?ctpl etc...

How then do I make Suppliers unchecked by default?

Also, in Orders > Order > hover Save changes > how do I make Notify Customer CHECKED by default?

See picture.

Any help appreciated!

Order-Status-Default-Notifications.png

I tried this and it is working for Notify Customer and Notify Orders Department but not for Suppliers.

I edited /design/backend/templates/common/select_popup.tpl and removed checked="checked" from name="notify_vendor" and cleared cache, and did ?ctpl etc...

How then do I make Suppliers unchecked by default?

Also, in Orders > Order > hover Save changes > how do I make Notify Customer CHECKED by default?

See picture.

Any help appreciated!

/design/backend/templates/addons/suppliers/hooks/select_popup/notify_checkboxes.post.tpl

That's perfect thank you so much!

Is there a method to tracking down each template so I could find them myself?

Or is it just because you've "Been Here Way Too Long" ? :-)

I think I found the answer here http://docs.cs-cart.com/4.3.x/tools/debugger.html

Mainly because I have "Been Here Way Too Long".

Anything in the backend, such as the notify checkboxes, is not so easy to find. However, in the frontend, the easiest way is to use the On-site template editing. It pinpoints and shows you what files are used in a certain location.

Design->Templates->Click on gear icon->On-site template editing

Heh heh..

Yeah finding templates on backend is the one I've been struggling with.

After 20 minutes on the debugger I still couldn't find the one for Orders > hover Save > Notify Customer

If your experience knows the answer it would be greatly appreciated!

2016-06-02_10h35_09.png

It's the same as what they are discussing in the start of this thread. It appears that you removed it.?

/design/backend/templates/common/select_popup.tpl

Yeah I did. At the time I didn't realise it was 1 variable used twice on the same page, I get it now!

For now it's working ok like that but I guess in future if I wanted to have the Save>Notify Customer box ticked by default then I'd need to assign a new variable? Or remove the Notify Customer check box from the Order Status dropdown...

Thanks for your help.

If the checkbox is unchecked, the system checks setting of the order status. So please make both changes

Has this changed at all? After an update and clearing the cache editing /design/backend/templates/common/select_popup.tpl has not worked?