Total incorrect in CS Cart

I noticed today that we received an order on our site where the total was completely incorrect. We've been trying to find the cause of this all day with no success.



A person ordered the following:



15 items at $54.99, tax of $68.05

5 items at $67.99, tax of $28.05

Shipping cost: $9.76

Subtotal: $1,164.801

Taxes: $96.91



[color=#ff0000]The total was $1.00[/color]





The order says the tax charged was 8.25%. The tax amount doesn't seem to be correct here. But more importantly, the total is definitely not correct!



Can anyone provide some insight into where I can start looking to find the cause of this issue? The issue can be duplicated with different items and different quantities and tax percentages.

Without seeing the actual order, hard to guess. But you might want to see if you have a promotion or a quantity price that is affecting the price.



But if you're saying that the order total was $1.00 and tax was $96.91, something is seriously wrong…

dziner - Maybe you've already checked, but I've found in our experience that most incorrect totals have come as a result of our locations not being setup correctly… for example a country or state conflicting with each other. We've been on CS since '06 and I just now found a shipping miscalculation since upgrading to 2.2.2, and it was because “default country” and “USA” and another state were in conflict with each other.



Check your locations and how they are setup for taxes [EDIT : and/or as tb says, discounts/promotions]…

Thanks for the feedback.



I checked all promotions and don't see anything that would cause this. Also didn't see any issues with states, taxes, or country codes.



It's interesting that when I test this, I can add quantities of items to my cart with no issue. When I proceed to checkout, the subtotal looks correct, but upon the last step of checking out, the cart is calculating a total of $1.



The checkout process is as follows:[list=1]

[]Contact info and billing address

[
]Shipping method and payment method

[]Payment info and display final cost [color=#ff0000](this is where the cart displays $1 for total)[/color]

[
]Process payment

[/list]

My thinking is that something in the code is effecting the total when going through these steps.

dziner - Did you get it figured out? Still strange that if there was a bug in the code, many more users would be having problems.



Not second-guessing you, but unless your files have been corrupted (in which case a re-install of any/all files would tell you) it still seems like a setting in discounts/promos or a locations issue.



Hope you find it…

it couse by shipping cost. I have same problem. Check your real shipping cost, system add $1 to shipping cost

anybody can help ???

[quote name='Effendy Hakim' timestamp='1350239939' post='147015']

it couse by shipping cost. I have same problem. Check your real shipping cost, system add $1 to shipping cost

anybody can help ???

[/quote]



Have you got $1 in product shipping settings…*note, NOT in admin shipping , but in product details then shipping properties tab



John

please add a picture or provide more information where and what you mean with $1 doller.

is total price 1 dollar to mutch or final price looks 1 dollar.

how many is tax for products or tax in payment or shipping?

are product tax included?



Thanks

[quote name='johnbol1' timestamp='1350287231' post='147035']

Have you got $1 in product shipping settings…*note, NOT in admin shipping , but in product details then shipping properties tab



John

[/quote]



Yes John, there is $1 in freight, after remove, it running well