Test rate calculation does not work for Domestic Large Letter

cs cart MVE ULT 16.2

Using Australia Post real time calculation “Domestic Large Letter” maximum for this postage method is 500grams.

Entering 1 in weight box correctly returns max weight for this postage method is 500gm

Entering .5 (or 0.5) results in error Error Please enter a valid Service code.

Note: “Domestic Large Letter 500gm” method works correctly but “Domestic Large Letter” does not


For the Domestic Letters: Large Letter maximum is 125 grams, so that’s why it returns error.

small letter is 250gm
large letter is 500gm

… I thought this was a seperate bug but maybe it is the same one being discussed here Australia Post real time rates for letter doesn't return rate - #5 by chickentwisty

For it being the same bug is same error message
Against it being the same bug is that the other letter description (per OP) works ok

Possible theory, maybe this particular option is now an unsupported option given that small and large letters with weights are listed in addition to this option that isn’t working?

I’ve tested it with weights lesser or equal to 125 grams and it worked well :slight_smile:

URL: https://digitalapi.auspost.com.au/postage/letter/domestic/calculate.json
Request: 'country_code=AU&service_code=AUS_LETTER_REGULAR_LARGE_125&weight=100&from_postcode=3016&to_postcode=2000&length=10&width=10&height=10'
Response: {"postage_result":{"service":"Large Letter","delivery_time":"Delivered in 3 to 4 business days, dependent on point of origin and destination","total_cost":"2.40","costs":{"cost":{"item":"Large Letter","cost":"2.40"}}}}

hmmm … so do I, which is a limit they don’t advertise (per link above). OK not a cs-cart issue … I do wonder if Aus Post will honour the rate returned, it’s amost a third of the price!

Given that it is throwing same code as other bug it does seem that it is a weight related issue for the other bug (well not other bug because this one isn’t a bug)

1 Like