Style sheets not showing

Hi,



I have downloaded the trial copy of CS-Cart and installed.



Installation goes fine but when you go to either the customer front end or the admin the are no images/style sheets showing.



I have change the permissions on the files before installing.



I have re-installed a couple of times but with the same results.



Help!!!



Thanks,



Leigh.

There are only 2 things: permissions problem or server setting. You can be sure it’s not a CS-Cart problem.

Hi,



when using firebug it tells me “There are no rules in this stylesheet.” when on the index page.



I can see the text of the demo store and buttons, prices etc.



any ideas?



Leigh.

I am getting this same error with a site. It’s like the site is almost connecting to the database, but not fully.



The link to the style sheet is right when I view the source, but yet when I click on the link in the source I get a 404 error.



I have changed my style sheet every which way and still nothing.



Does anyone have any ideas?



Thank you,



Brandon

[quote name=‘brandonvd’]I am getting this same error with a site. It’s like the site is almost connecting to the database, but not fully.



The link to the style sheet is right when I view the source, but yet when I click on the link in the source I get a 404 error.



I have changed my style sheet every which way and still nothing.



Does anyone have any ideas?



Thank you,



Brandon[/quote]



I think the design and those files are not in conjunction with the db. In the db are stored products, users, orders and similar files, but not skin images or css files.

Is this store in a sub directory?

Well the store is at a temporary ip.



The link is:



[URL=“http://96.30.31.124/~hl2010/”]http://96.30.31.124/~hl2010/[/URL]



This is what is in the config.local.php file:


// Host and directory where software is installed on no-secure server
$config['http_host'] = '96.30.31.124';
$config['http_path'] = '/~hl2010';

// Host and directory where software is installed on secure server
$config['https_host'] = '96.30.31.124';
$config['https_path'] = '/~hl2010';




What do you think?



Thanks,



Brandon

The paths are wrong:


[quote]Home page:



[URL=“http://96.30.31.124/~hl2010/”]http://96.30.31.124/~hl2010/[/URL]



Other pages:



[URL]http://96.30.31.124/skin-type/combination-oily-t-zone/[/URL]



Should be:



[URL=“http://96.30.31.124/~hl2010/skin-type/combination-oily-t-zone/”]http://96.30.31.124/~hl2010/skin-type/combination-oily-t-zone/[/URL][/quote]



It can be the htaccess file (code, permissions, …)

Indy,



Here is the .htaccess file:


```php DirectoryIndex index.html index.php





RewriteEngine on

Some hostings require RewriteBase to be uncommented

Example:

Your store url is http://www.yourcompany.com/store/cart

So “RewriteBase” should be:

RewriteBase /store/cart

RewriteBase /~hl2010

RewriteCond %{REQUEST_FILENAME} !.(png|gif|ico|swf|jpe?g|js|css)$

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . index.php?sef_rewrite=1 [L,QSA]



RewriteCond %{REQUEST_FILENAME} ./catalog/.

RewriteCond %{REQUEST_FILENAME} -d

RewriteCond %{REQUEST_FILENAME}/index.html !-f

RewriteRule . index.php?sef_rewrite=1 [L,QSA]









ExpiresActive On

ExpiresDefault “access plus 10 years”







RewriteEngine On



RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(..(js|css))$ smartoptimizer/?$1





RewriteCond %{REQUEST_FILENAME} -f

RewriteRule ^(.
.(js|css|html?|xml|txt))$ smartoptimizer/?$1







RewriteCond %{REQUEST_FILENAME} -f

RewriteRule ^(.*.(gif|jpg|jpeg|png|swf|css|js|html?|xml|txt))$ smartoptimizer/?$1







FileETag none

```



Thanks again,



Brandon

Did you try to remove the smartoptimizer from the htaccess?

Yeah I did.



What is going on is that since the domain hasn’t been switched over and isn’t planning on being switched any time soon the site is set up with this IP.



The site is at WiredTree and they said that the files are just supposed to be in the public_html directory, but to access the site you have to go to:



[url]http://96.30.31.124/~hl2010/[/url]



Which is the home directory.



I have made the changes, but unfortunately the site still doesn’t work.



Personally I think it is because of having to use this url, but I don’t know.



I have tried every combination I can on both the config file and the htaccess file, but am still no where.



Any other ideas?



Brandon

Clear browser cache and delete all files in var/cache and var/compiled folders and subfolders (not the folders!)

Humor me. Back up and delete the .htaccess file. I had a similar problem with a client site and had to delete all the .htaccess files before the site would work.

Yeah I kind of did the basics. Clearing the cache and compiled folder were done even before I tried.



As for the .htaccess files, the only one I changed was the one in the root. I actually tried it every way. I even took mine from my site and put it on this site.



I am actually trying to help someone out with this and this isn’t my site.



For some reason this is being a huge pain in the rear. I am thinking that it has something to do with the host rather than the installation. She is in contact with the host so hopefully she’ll get an answer soon.



If you have any other ideas I would love to hear them.



Brandon

Well I guess the problem was that there was something that needed to be changed in the http.conf file.



I’m not sure what was changed, but now the site works fine.



Thank you Roban and Indy for your help, it was much appreciated.



Brandon

You’re welcome M8. It’s always nice to find a fix and not know what it was.:wink:

Well at least someone got sorted.



I have now bought the licence and have re-installed but still get the same results, no 404 msg like brandon did.



I shall email the help team, probably something simple that i’m over looking.

This was a problem with the host and not the cart. Have you contacted your host about your problem? Also what host are you using?



Brandon

No I have not contacted my host, which is easily. CS help/customer service just said check permissions, which I have done several times now with no difference.



Getting really fed up with this now, think I have made a mistake going with CS, as customer service/response time is diah to say the least.

[quote name=‘Kerhs’]No I have not contacted my host, which is easily. CS help/customer service just said check permissions, which I have done several times now with no difference.



Getting really fed up with this now, think I have made a mistake going with CS, as customer service/response time is diah to say the least.[/quote]



It’s a server settings issue. I said it in posts #2. If you don’t beleive it and are you not listening, then nobody can help you.