Store import


I'm having a problem importing my store from 3.0.6 to 4.0.3, its gets to Cloning database and it just will not go any further, its been stuck there for the last 1 hour!!

Any now know how to get pass that point? my database is around 95MB.

Dosent seem too big, but just in case, have you cleared all statistics(if turned on) and logs first.

Mine didnt like it until I did this too…about 150mb

Yea I cleared it but still the same, I've even uninstalled the statistics addon.

Was looking to see if there was anyone with the same problem and found a few people that the something happen but no solutions to the problem.

How long dose it take to import everything! I left it for like 2 hours yesterday and when I went back to it, it was still in the same place!

One of my store databases running 2.2.5 has a database of over 1gb with Statistics disabled. It does the Store Import, which I have now done a few times, to v4.0.2 and v4.0.3 in about 15-20 minutes. Run a repair on the current database and try again, this solved my problem very simply with a 3.0.6 > 4.0.3 import.

I will try that. What did you use to do the database repair?

I used phpMyAdmin to select all tables and run the repair option. Not sure if the 'Maintenance' in CS-Cart (one of the tabs in the Database backup page) only does optimisations or repair, or both.

This addon still will not work for me, I have tried everything and every trick that I could find but still nothing.

Dose any one know of any other way to go from v3 to v4 with out having to use this crapy addon?