SSL Problem

I have a shared SSL , that my host provide me, i want to use shared ssl on the checkout process, but i don’t know where to edit and give the link. Please someone tell me how to use shared SSL. :cool:

There are a bunch of threads regarding this:


“shared ssl”

I do not used shared SSL so I can’t help.

This is the thread I used. I have a shared SSL currently, make sure you have the correct address.


I have done this method , but it is not working , please help me

I have got this warning while on checkout

“The redirection to secure connection failed. Please check HTTPS settings in “config.php” file and make sure that SSL certificate is installed on your server.”

// Host and directory where cs-cart is installed on usual server

$cscart_http_host = ‘’;

$cscart_http_dir = ‘/shopping’;

// Host and directory where cs-cart is installed on secure server

$cscart_https_host = ‘https://******.net/’;

$cscart_https_dir = ‘/’;

this is shared SSL.


I’m just guessing and trying to help here…

try dropping the “/” on this line:

$cscart_https_host = ‘https://.net/';


$cscart_https_host = 'https://

Make sure the path to the secure server (where you have ***** for some reason doesn’t need the word or www.

in other words, make sure the secure URL is accurate.

If that doesn’t work, try dropping your domain name in the dir line:

$cscart_https_dir = ‘/’;


$cscart_https_dir = ‘/shopping’;

In other words, try a few different combinations and see if that gets it.

Also, make sure you refresh config.php after uploading it.

I have try but nothing work, this is my shared SSL


please help , i am tired , i have change all setting , but the problem is still there,

there is any CSCART technical person who can change the direct from website. :-o

Try this

// Host and directory where cs-cart is installed on secure server

$cscart_https_host = ‘https://******.net’;

$cscart_https_dir = ‘/’;

That is how I have got them to work before


It is still not working, i have say to host and they try but he is saying the problem is on a scripr the rredirect problem. :frowning:

I had the same problem i changed it to look like this:

$store_https_host = ‘’;

$store_https_dir = ‘/’;

This should fix the problem, if you have your shop in a subdirectory like “shop” then do this:

$store_https_host = ‘’;

$store_https_dir = ‘/’;

Hope this works for you.