SSL issue

I recently purchased SSL Hosting and a certificate. My web-host set it up. If I go to my admin page with https instead of http it is SSL secured. When I go to checkout and try to put https in-front of the address, it redirects to http. How do I make the checkout page secured?



SSL check boxes in admin are all checked. (3 I believe)



Thanks,

Zack

http://www.monstercableguy.com

You shouldn’t have to do anything. When you go to checkout it should be https. Certificates are domain specific. In other words if your certificate is for www.domain.com it will not work for domain.com without the www.

go to: [url]http://www.monstercableguy.com/index.php?dispatch=checkout.checkout[/url] or [url]https://www.monstercableguy.com/index.php?dispatch=checkout.checkout[/url]



It is not working.

Do you have an ssl directory on your server? Not in the root but in the directory just below the root.

I had a similar issue see link:

[url]http://forum.cs-cart.com/showthread.php?t=16873[/url]

It is setup for www.monstercableguy.com not monstercableguy.com … any suggestions here?

Look at mhulbrock’s link.

I tried modifying both files with no result. I don’t think our problems are related. My checkout is not showing up as secure.

Then I would look to your host and server.

it’s a cs-cart issue, not a hosting issue.

[quote name=‘zackstark’]it’s a cs-cart issue, not a hosting issue.[/quote]



Idiot. If Rob’s has spent HIS time responding to your issue at least have the respect of following through with his recommendation.



Javascript Error

Error: RATE is not defined

Source File: [url]https://www.monstercableguy.com/index.php?dispatch=checkout.cart[/url]

Line: 389



SSL Error (Cause by YOU, not CS-Cart)

NON-SSL image being loaded to the checkout page.

[url]http://www.monstercableguy.com/images/rapidssl_ssl_certificate.gif[/url]



Next time I suggest that you contact CS-Cart directly and tell them that their software doesn’t work, I’d like to hear their response.

when you go to checkout now for some reason it redirects to:



[url]https://www.monstercableguy.com/index.php?dispatch=checkout.checkout[/url]



but it is not secure. Any ideas? All I did was un-tick the 3 ssl checkboxes then re-tick them.





How can I clear out my cache? I read that may be the issue.

I apologize if I offended you or was incorrect in my assumption. I have been researching this for hours now. I am ignorant to cs-cart’s design and ssl in general. I was only asking for assistance. The link you provided is not secure and I do not know why. I tried changing the files as suggested but changed them back because it did nothing.

There were actually 4 images in that block that were under http instead of https. I disabled the block altogether, but still have the same issue. Checkout redirects to https but is not secure.

I refreshed cache and that was the issue. How do I go about putting those images on the https side?



Thank you so much for all of your help and input. I apologize again if I came off as being lazy and inconsiderate of the other posts, I truly was not.

SSL won’t be “SECURE” until you make sure that ALL HTTP (Non-Secure) links are removed. Since you’ve removed it, you no longer have issues.



Checkout.checkout will always redirect OUT of the checkout unless you have something in your cart.



If you want to re-enable the block (I suggest against it) make sure that all your links are in HTTPS (SSL/Secure) so that the SSL certificate loads the appropriate URLs.



I get pissy when people either dismiss the “pros” / “contributors” here (Rob is one of them) without regard to reviewing the situation. Pinning it on CS-Cart only makes live a living hell for everyone unless it’s a “true bug”, last but not least it’s free advice from hard-working people. Anyway rant over, just pay some respect to the people who help you.

So are you suggesting that I leave it out because of potential issues, or because it is not necessary since they are shown on the homepage?

Put them in the footer so that they can be seen sitewide.

this will re-enforce their validity once the user gets to the checkout. I suggest you contact rapid SSL and ask for code that works in both HTTP and HTTPS

Careful Jesse I might come down to FLA and buy you dinner.

[quote name=‘JesseLeeStringer’]Put them in the footer so that they can be seen sitewide.

this will re-enforce their validity once the user gets to the checkout. I suggest you contact rapid SSL and ask for code that works in both HTTP and HTTPS[/QUOTE]



Good Idea. How could I put everything in the footer? What file should I be looking for?



Also, RapidSSL doesn’t provide a code. It is just the .gif that they provide.