Ssl Install Problem 4.3.4


I am working on a site trying to enable SSL for the storefront

The certificate looks ok and displays the store_closed.html under https

config.local.php looks fine and has the correct settings for the domain as specified in the Certificate for the domain

All settings in database match the domain settings as they should be for the certificate

The error I get when I try to enable a secure connection to the storefront , just checkout or admin panel is:

WarningThe secure connection check has failed. Please check HTTPS settings in the "config.php" file and make sure that SSL certificate is installed on your server.

I cannot think of anything else to check, any ideas?


I found a post on this site which refered to a file called actions.functions.php

Located in app/schemas/settings

I commented out the section of code below as the other post said and then was able to enable stores https

Maybe this is a parameter issue with apache / php when this code does tthe check as this is the code that was not allowing me to set https and forcing it to disabled.

The site is working fine now with https, but would be interested to know what other people have done to enable https

/* if (empty($content) || $content != 'OK') {
// Disable https
Settings::instance()->updateValue('secure_storefront', 'none', 'Security');
$new_value = 'none';

fn_set_notification('W', __('warning'), __('warning_https_disabled'));

FYI - The code has changed in version 4.3.7

/* if (empty($content) || $content != 'OK') {
// Disable https
Settings::instance()->updateValue('secure_storefront', 'none', 'Security');
$new_value = 'none';
$error = Http::getErrorFields();
$error_warning = __('warning_https_is_disabled', array(
'[href]' => Registry::get('config.resources.kb_https_failed_url'
$error_warning .= fn_settings_actions_build_detailed_error_message($error);
fn_set_notification('W', __('warning'), $error_warning);
} */

I would NOT do the solution above. The problem you are having indicates a lower level problem with your SSL installation and/or what you have specified in your config.local.php file. I'm assuming you have the selection for SSL in Settings/Security set to checkout/profiles/admin only. What is the state of the checkbox for "keep SSL after visiting secure pages" checkbox?

Had similar problem with https due to cdn