SSL Install Issues...

Hi Everyone… sorry if you’ve seen this before :frowning:

CSCART is the current version (which is fantastic… no problems except for this and is probably me)



I’m receiving the following message:

Warning: The secure connection check has failed. Check HTTPS settings in config.php file and make sure that SSL certificate is installed on your server.



I’ve searched the forums on this, also read any documentation that I’ve got on CsCart & SSL and even tried a few coding things that I found within the forum but I still can’t get my SSL certificate to work.



I’m using cPanel through my hosting company - apparently I have shared SSL via the hosting company, but after seeing that the shared certificate was expired that freaked me out… so I purchased my own via GoDaddy.



a) followed the instructions in cPanel - creating the keys, certificate requests and was issued an SSL certificate to install. Followed all the install instructions via cPanel & GoDaddy



b) They are showing up on the server… well theres a folder called SSL and it has the certificates inside. When I click on the certifcates they show they belong to me and are current.



c) When I received the message above after updating my security in the admin of CSC - I put in a support ticket with my hosting company.



They moved me to a new server, I updated the DNS…



Then they tell me:

“The new server has more features then the old one, and it will also be easier for you to setup an SSL certificate (which was the same as the old server…) However in order to setup SSL, you will need your own dedicated IP address, otherwise you will receive errors.”



So now i’m more confused than ever… I have also done an SSL search.



[COLOR=“Blue”]www.snickerdoodledreams.com resolves to 111.118.160.187



Server Type: Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_jk/1.2.28



No SSL certificates were found on www.snickerdoodledreams.com. Make sure that the name resolves to the correct server and that the SSL port (default is 443) is open on your server’s firewall.[/COLOR]



This is what is showing in the config file:

// Host and directory where software is installed on no-secure server

$config[‘http_host’] = ‘www.snickerdoodledreams.com’;

$config[‘http_path’] = ‘/cscart’;



// Host and directory where software is installed on secure server

$config[‘https_host’] = ‘www.snickerdoodledreams.com’;

$config[‘https_path’] = ‘/cscart’;



I’ve tried all sorts of different configurations… but nothing. If anyone can even attempt to help - it would be greatly appreciated. If you need more info - just LMK



thanks

Darlene

Wow! That’s a lot this and that going on. LOL



First thing I can see is if your cart is in the root directory (/public_html for example) then you need to edit the config to reflect:


// Host and directory where software is installed on no-secure server
$config['http_host'] = 'www.snickerdoodledreams.com';
$config['http_path'] = '';

// Host and directory where software is installed on secure server
$config['https_host'] = 'www.snickerdoodledreams.com';
$config['https_path'] = '';

[quote name=‘Tool Outfitters’]Wow! That’s a lot this and that going on. LOL



First thing I can see is if your cart is in the root directory (/public_html for example) then you need to edit the config to reflect:


// Host and directory where software is installed on no-secure server
$config['http_host'] = 'www.snickerdoodledreams.com';
$config['http_path'] = '';

// Host and directory where software is installed on secure server
$config['https_host'] = 'www.snickerdoodledreams.com';
$config['https_path'] = '';
[/QUOTE]



LOL… something that should be so simple is always highly complex. :slight_smile: btw - yes I have CSC in the public_html (fully licensed not a test version)



Tried the code you suggested… it changed the look of the admin sign in page… however when I signed in… it shows



[COLOR=“Blue”]Not Found



The requested URL /admin.php was not found on this server.



Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.



Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_jk/1.2.28 Server at www.snickerdoodledreams.com Port 80[/COLOR]



thanks for trying :slight_smile: … I’ve reverted it back to the original coding… that works but just not with SSL.

I’m not sure I understand. Are your files in /public_html or in /public_html/cscart?



Edit: I checked and it is in /public_html/cscart. Did you check the box(es) in Settings for SSL?

[quote name=‘Tool Outfitters’]I’m not sure I understand. Are your files in /public_html or in /public_html/cscart?



Edit: I checked and it is in /public_html/cscart. Did you check the box(es) in Settings for SSL?[/QUOTE]

oops - thats where I meant…



Stupid me… I went and checked, and the SSL folder wasn’t under the public_html - went and moved it into public_html and retried the coding you suggested but still no go… it just shows the Not Found error.



When I revert back to the original coding in my 1st post I’m able to access my admin panel. If these are the SSL settings you’re talking about (correct me if I’m wrong) - yeah I’ve checked them off with all the original config settings… it says to check to see if SSL has been installed on the server and check the settings in the config.php file



Settings: General



Enable secure connection at checkout (SSL certificate is required to be installed on your server) ✓



Enable secure connection in the administration panel (SSL certificate is required to be installed on your server) ✓



Enable secure connection for authentication, profile and orders pages (SSL certificate is required to be installed on your server) ✓



Otherwise if I make coding changes like you suggested & what has worked in other forum threads here… I’m not able to access the admin panel at all.



Just another thought: should I move the SSL folder into the CSC folder and then make those changes you suggested.



I better stop before I confuse everyone even further… but totally appreciate all your help!! :slight_smile:

No, since your files are in /public_html/cscart then your original config is correct.



The SSL file does not need to be moved. It needs to be where it was created by Cpanel.



Is there any reason why you set your files up in /cscart? I noticed there isn’t anything set up in the root (/public_html) and if you aren’t planning on setting anything else up in the root, I would suggest that you move your cart to the root.



Another problem could be the domain name you provided for the SSL. If you provided snickerdoodledreams.com as opposed to www.snickerdoodledreams.com, that could be your issue.

SSL folder have to be in the root of your hosting package, not in public_html.

[quote name=‘Tool Outfitters’]

Is there any reason why you set your files up in /cscart? I noticed there isn’t anything set up in the root (/public_html) and if you aren’t planning on setting anything else up in the root, I would suggest that you move your cart to the root.



Another problem could be the domain name you provided for the SSL. If you provided snickerdoodledreams.com as opposed to www.snickerdoodledreams.com, that could be your issue.[/QUOTE]



1st Question… yeah there was a reason. I followed the install instructions & d/led XAMPP that all went well, had the myPHPadmin page up, typed in [B][url]http://localhost/cscart/install[/url][/B]… but install didn’t activate… not understanding PHP didn’t want to muck with that page. So went with setting up a manual DB in Cpanel by following this instruction in the CSC doc “[COLOR=“Blue”]Please note that if you install CS-Cart on a hosting server on the Internet, you will need to create a MySQL database manually before this step as CS- Cart will be unable to create a MySQL database automatically like on a local computer.[/COLOR]”… INSTALL WORKED - probably why it’s in public_html/cscart



So with out totally mucking up all the work I’ve done & re done because of a server change - I’m actually able to move the entire contents inside the /cscart folder and move those contents directly to public_html?? Gosh I wish I felt that confident… (yes I do have CSC backed up). Is it necessary to move those files if it’s working now… well except the SSL (which is a vital component)



2nd Qustion… when setting up the SSL in cPanel it doesn’t show the (www. ) so I’ll try that and see what happens! Alright, I took the (www.) away and tried the following code…



// Host and directory where software is installed on no-secure server

$config[‘http_host’] = ‘snickerdoodledreams.com’;

$config[‘http_path’] = ‘/cscart’;



// Host and directory where software is installed on secure server

$config[‘https_host’] = ‘snickerdoodledreams.com’;

$config[‘https_path’] = ‘/cscart’;



I’m able to access the admin with the above but when I check the settings to enable SSL is still shows up the error.



I’m a fixer by nature and this is so frustrating… but I thank you for you help.

[quote name=‘indy0077’]SSL folder have to be in the root of your hosting package, not in public_html.[/QUOTE]



Thanks Indy… yeah I have it in the root of the host server which I’ll assume is the my home directory…



The SSL folder has 2 folders = I private for the key and 1 for certificates which has 2 crt’s plus the generated csr



Maybe it’s something I’ve done in installing them to cPanel althought that seemed pretty easy from the instructions.



I’m open to any suggestions! Thanks for your help =)